×

Give a tip

URL Aliases: Plus Character Ignored in Filter Box


Secret-HQ

Recommended Posts

I've noticed the plus character (+) is ignored by the filter input box when searching URL Aliases in about:config — as is anything entered after the +.

For example, attempting to filter for notepad++ plugins behaves as if you've entered notepad into the filter box.  Filtering for + maxthon forum fails entirely.

Here's a quick video demonstrating the bug in action.

EDIT:  This is not a bug with the search box field.  It relates to the filter field in Maxthon Settings » Address Bar.  Here's a screenshot from the video above showing to which field I'm referring.  (Watch the video to see the bug in action.)

URLAliasFiltering_PlusCharacter_screensh

Tip   Give
Link to comment
Share on other sites

  • 2 weeks later...

Hi,

 

I'm not sure if I understand it right, but do you mean adding url alias and inputting a "+" before the alias, such as"+abc"?  I tried in my Maxthon with "+jet" to go to "www.jet.com" and it was fine. 

 

So if what i described is the issue you have currently having with your maxthon, which version are you using? Make sure it is the lastest version. If so, sync your data to your cloud, and reinstall maxthon. 

 

Best.

Tip   Give
Link to comment
Share on other sites

Hi,

 

I'm not sure if I understand it right, but do you mean adding url alias and inputting a "+" before the alias, such as"+abc"?  I tried in my Maxthon with "+jet" to go to "www.jet.com" and it was fine. 

 

So if what i described is the issue you have currently having with your maxthon, which version are you using? Make sure it is the lastest version. If so, sync your data to your cloud, and reinstall maxthon. 

 

Best.

Watch the video he posted in OP, he's referring to Settings > Address Bar > Navigation > Url Alias > Search.

Tip   Give
Link to comment
Share on other sites

I've noticed the plus character (+) is ignored by the filter input box when searching URL Aliases in about:config — as is anything entered after the +.

 

For example, attempting to filter for notepad++ plugins behaves as if you've entered notepad into the filter box.  Filtering for + maxthon forum fails entirely.

 

Here's a quick video demonstrating the bug in action.

Im my experience I have never left a space between the "+" and the term I waanted to be mandatory in a search.

Examples:

+maxthon forum would find items containing "maxthon" but "forum" would be optional

+ maxthon forum would find items with either or both of the terms, effectively ignoring the "+"

+maxthon +forum would find find items containing both "maxthon" and "forum" in any order together or separately

+"maxthon forum" would find terms containing the explicit string "maxthon forum"

 

Does this help?  Note the example "+abc" given in comment #2 by BugSir006 and his "+jet" URL alias which worked fine.

Tip   Give
Link to comment
Share on other sites

Hi,

 

I'm not sure if I understand it right, but do you mean adding url alias and inputting a "+" before the alias, such as"+abc"?  I tried in my Maxthon with "+jet" to go to "www.jet.com" and it was fine.

 

The + character doesn't cause any problems within aliases.  They work fine when typed into the address bar.

 

However, if you go to the Maxthon settings panel (about:config) and try to filter your list of URL aliases to find the +jet alias you created, you should see that the filter doesn't work.  Nothing beyond the first + is recognized by the filter.

 

Im my experience I have never left a space between the "+" and the term I waanted to be mandatory in a search.

Examples:

+maxthon forum would find items containing "maxthon" but "forum" would be optional

+ maxthon forum would find items with either or both of the terms, effectively ignoring the "+"

+maxthon +forum would find find items containing both "maxthon" and "forum" in any order together or separately

+"maxthon forum" would find terms containing the explicit string "maxthon forum"

 

Does this help?  Note the example "+abc" given in comment #2 by BugSir006 and his "+jet" URL alias which worked fine.

 

I should have been more clear in the original post, but it's not + as part of the search string that's causing problems.  It's how the character is parsed when Maxthon attempts to filter on the list of URL aliases in about:config.

 

I've added a screenshot from the video that should make it clearer on first reading the post.  Watching the video should allow you to see it happening in action.

Tip   Give
Link to comment
Share on other sites

  • 1 month later...

Hi,

Sorry for this late reply. After checking your video and screenshot again, I tried here and you are correct. The search filter in Alias doesn't filter the result containing"+". This is recorded but my thought is you could still get the result by not typing in "+", I mean in your screenshot, there is "notepad++", if you just type in "notepad", the result would come out too right? This should help you work for now. But this issue you brought up is useful and has also been recorded.

Thanks for sharing with us this experience. 

Best.

Tip   Give
Link to comment
Share on other sites

my thought is you could still get the result by not typing in "+",

Thanks, BugSir!

That is indeed how I've been getting around the bug — though, of course, it would be nice to filter across that dimension and see (for example) all my URL aliases that begin with +.

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.