Help with Different Language display(Square boxes)

Recommended Posts

Hello guys ,


So while on Facebook or any other page which contains the language "Bangla/Bengali" the characters doesnt show up.This is fixed by switching to retro mode. But is there any fix for the language display for Ultra mode? What are the difference between the 2 modes? And after switching to retro mode , The facebook page displays a text in the top of the page- "For a better experience on Facebook, switch to our basic site or update your browser."

And with Retro mode , I have a Maxthon Extension ( FB Purity) that doesnt work on Facebook retro mode. :(

Little help here guys?

Link to comment
Share on other sites

  • 2 weeks later...

Retro mode uses the IE renderer. Should only be used when sites don't work properly in Ultra. It doesn't support some features like extensions, which is why FB Purity won't work in that mode.


To remove the "update your browser" notice you can try enabling standard rendering mode. Go to the Main Menu > settings > Advanced > Browsing > Enable standard rendering in Retro Mode


But that won't solve the extension issue.


For the language issue, firstly check that you haven't changed the default webpage font in Advanced settings as above. If you have, change it to default and check again,.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.