Saved settings reverting to default

Recommended Posts

Yes, memories - Mx seems to "forget" some settings.

These occurred to me several times since this last version came out:



1. "Preload web" setting - I turn it off, it turns on on its own.

2. Search engine - even being deleted, the "new" google URL appeared again, and set itself default.



3. Maxthon's forum hasn't remembered a single time my user and pass. I mean, magic fill does the job, but the cookies don't do.

Link to comment
Share on other sites

Do you use Mx Passport.??  

If so, then first set "Preload web" to OF   And  set a mark in Normal Google and not in Google Search (the "bad one") also do it in your QA page, in the long search line.

Add a new Google (normal one) URL in that looks like this (= Copy / Paste)   and set it to Default

• [WinPC Followup] Google CSE - General Discussion  = there is photos of it here...


Last go to Mx Cloud Sync and make you full Sync to all options, to Mx Passport from there. (you can opt-out Magic Fill if you don't want it)

This way you Sync won't change you setting back again...  


The Login to Forum, is empty first, then right-click and your e-Mail pops up, press on it and it fills your form = Magic Fill and Cookies work, this is the same for all in the new forum i think.

Best Regards Ohke

Link to comment
Share on other sites

1. I haven't had that happen since turning it off. How often does this happen? After every restart of the browser? Randomly?

2. As above. 


Seems like it could be a settings issue where the data isn't being saved properly. Clean install should fix it. If you're using a passport all your data should be restored.


3. It's a known issue with the forum cookies not saving the login info. Being worked on.


Also what version of Maxthon are you using? If not the latest ( then try updating and see if that helps with the first 2 issues.

Link to comment
Share on other sites


Thanks for your question. About search engine, I have to tell you that it is a promotion of  our browser. You can change it only in our latest version which you can download here .http://forum.maxthon...leased/?p=82993 After installing that, you can find it in settings >searching engine, make google as a default one. About  "Preload web" setting, after turning it off, it works fine on my side with 3000. About account issue, you can set your Maxthon Settings > Magic Fill to Autotick remember me and sign in anonymously. And it will be fine then. I hope this could help you. Feel free to contact us.

Link to comment
Share on other sites

I'd say it happens randomly. But I suspect it happens after machine restart (because most of the time I simply keep it on). That would be log-off / log-on process.

And yes, I do use passport, and it should have kept my settings by now. There must be some bug.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.