×

Give a tip

Searching while typing - Google alert


Recommended Posts

Hello,

I'm having an issue with maxthon where it starts searching my default search engine (google) while i'm typing in the address bar.
This wouldn't be an issue if it started searching after a couple of seconds, but it's searching directly after each keypress.

This is causing google to block me from time to time:
post-47637-0-42533100-1432289246_thumb.p

It could be a setting somewhere, but for the love of me, I can't seem to find it.

 

Does anybody have an idea how to fix this?

 

This is an english version of the page:
sorry.png

Tip   Give
Link to comment
Share on other sites

If your IP has been used by multiple users or more than one client accessing Google at the same time, you may reach a connection threshold and will be automaticaly redirected to the Google IPV4 restriction page.
 
Change your IP will resolve your issue.
Tip   Give
Link to comment
Share on other sites

[[Template forums/front/topics/post is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

@Zugi no it doesn't appear related to either of those topics.
I have the normal interface of google and language is fine 2.
I also have no url aliases other than the defaults and url shortcut keys is empty.

@Dinataspace No, that's not it. Other Browsers and other PC's are working fine with google.
The issue is that because every keypress starts searching, google thinks i'm spamming their server.

 

Example I want to go to www.maxthon.com, so I type www.maxthon.com in the address bar, this happens:

1. I type a w, maxthon/google starts searching for 'w'

2. I type the second w, maxthon/google starts searching for 'ww'
3. I type the third w, maxthon/google starts searching for 'www'

4. I type the dot, maxthon/google starts searching for 'www.'
5 I type the m, maxthon/google starts searching for 'www.m'

 

and so on untill I have typed www.maxthon.com, so in the short time it takes me to type www.maxthon.com (I type that in about 1 second), maxthon/ google will have done 15 searches (3 x w, 2x dot, m, a, x, t, h, o, n, c, o, m).

 

So changing my IP won't solve anything and when I enter the code google asks me everything works fine, it's just that every url I type this comes back. 

Tip   Give
Link to comment
Share on other sites

@ Oliver, my browser version is: 4.4.5.1800, but I also had this issue in the previous (beta) version: 4.4.5.1200.

I'm not sure if I had this issue in 4.4.5.1000, but I don't think I did.

 

And yes that topic is indeed the exact issue I'm having.

Tip   Give
Link to comment
Share on other sites

[[Template forums/front/topics/post is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

It doesn't really happen regularly, but that's actually expected.

Google only blocks you if they get over a certain amount of request in a certain time, so lets say they only show that page when they get over 10 requests in 1 second, this means that if you type www.maxthon.com in 1 second, you get blocked (15 searches in 1 second), but if you take 2 seconds to type it they won't block you (15/2 = 7,5 requests per second).

Ofcourse I don't know what exactly they use, it could be a more complicated system, and it probably is, but it shows you that it's hard to reproduce.
The way that seems to work for me is just typing in a few random strings (jkldsjdfalksdfjlkjlkaj) in the addressbar, removing them, and rince repeat and after a while it will show up, just make sure you type fast :)

Tip   Give
Link to comment
Share on other sites

I just installed the latest maxthon (just noticed it got released) 4.4.5.2000 and it appears the issue no longer shows up, but this might be because now it's using an older version of google as described in the topic linked by Zugi (http://forum.maxthon.com/index.php/topic/15207-mx-4452000-and-new-search-engine-google-added/).
So it seems we jumped out of the frying pan into the fire, but at least this topic can be closed, I'll just keep an eye out for the other topic.

 

Edit: just noticed in the other topic the default search engine got changed in 2000, so set it back to the original one and the problem reappears.

I'll try a clean install on another PC to see if upgrading/clean install makes a difference. 

 

Edit 2: Just did a fresh install on a clean PC, changed search engine to google and removed the other google search one (old/new google search) and problem is exactly the same.

 

I'm still thinking there should be a delay between keypress and search, for instance 1-3 seconds of no new keypress -> search.
This way it will only do a search request when you're done typing, not after each keypress.

Tip   Give
Link to comment
Share on other sites

didn't test it with latest build, but this issue occured mainly  when I was performing a search using english words with french google.

It's possibly related to preview, since  It did no longer occur after I disabled it.

sigmax2.png

Tip   Give
Link to comment
Share on other sites

Yes, disabling the pre-search feature stops the issue, but if you're someone who likes it and wants to use google then you're out of luck.

Basically, you either use Google the way you always have and disable pre-search.

Use another search engine that doesn't have that issue.

Change the way you search, so type slow so the issue doesn't occur.

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.