×

Give a tip

Maxthon android adblock missing


Recommended Posts

I've installed the latest maxthon browser for Android from the play store. The page there claims it works with adblock plus, but after installing it I have literally gone through every menu item I can find, but see no setting for adblock, or for any addons/extensions. 

 

From what I was reading it looks like adblock is actually integrated into Maxthon Android? but it doesn't seem to work for me, as I am still seeing adverts, and http://simple-adblock.com/faq/testing-your-adblocker/confirms it is not working.

 

Can anyone help? I really like how fast Maxthon is, but at the moment I am still using the much slower Firefox android browser, since its adblock extension does work for me. 

Tip   Give
Link to comment
Share on other sites

I've installed the latest maxthon browser for Android from the play store. The page there claims it works with adblock plus, but after installing it I have literally gone through every menu item I can find, but see no setting for adblock, or for any addons/extensions. 

 

From what I was reading it looks like adblock is actually integrated into Maxthon Android? but it doesn't seem to work for me, as I am still seeing adverts, and http://simple-adblock.com/faq/testing-your-adblocker/confirms it is not working.

 

Can anyone help? I really like how fast Maxthon is, but at the moment I am still using the much slower Firefox android browser, since its adblock extension does work for me. 

What is your Android device specification?

FYI- ABP in Maxthon for Android doesn't work/ shows up on "weak" devices- for example Samsung Galaxy Young (one core CPU).

Tip   Give
Link to comment
Share on other sites

Thanks for replying. It is the Samsung Galaxy S6. Maybe it is a bug in Maxthon that the device might be too new for it know about it, so it is defaulting to "weak" device mode?

Yeah- really strange issue.

I'm sure that yours S6 is enough powerful to handle Maxthon's ABP :titter: .

Anyway- try to uninstall your current version and manualy install this one from http://www.apk4fun.com/apk/2915/ and check if it's helps.

Tip   Give
Link to comment
Share on other sites

Yeah- really strange issue.

I'm sure that yours S6 is enough powerful to handle Maxthon's ABP :titter: .

Anyway- try to uninstall your current version and manualy install this one from http://www.apk4fun.com/apk/2915/ and check if it's helps.

 

 

Yeah, I don't think it is the phone ;)  It's only got an octo core CPU *gloat*  :D

 

Anyway, I uninstalled and installed from your link (it reports ver 4.4.3.1000 build 2917). But don't see a difference. Testing it with the worst for adverts site I can think of I tried http://www.mirror.co.uk/and got an overlay, and pretty much an advert between every story. Also the http://simple-adblock.com/faq/testing-your-adblocker/ link still fails.

Tip   Give
Link to comment
Share on other sites

Hi vdex42, Glad to talk to you. How come there is no AdBlock settings in your browser? Which version of android installed on your phone please? Any screenshot of Maxthon settings page to have a look? Adblock Plus(beta) is located between Privacy&security and Advanced settings setting options.

Tip   Give
Link to comment
Share on other sites

Hi vdex42, Glad to talk to you. How come there is no AdBlock settings in your browser? Which version of android installed on your phone please? Any screenshot of Maxthon settings page to have a look? Adblock Plus(beta) is located between Privacy&security and Advanced settings setting options.

 

Thanks for looking into this. I was wondering where the setting was meant to be. No I don't see that. 
 
I've taken some screenshots of what I see in the settings, my ad filled mirror, and my exact android version:
 
Wi5HAWJ.jpg
----
 
 
wSbcglB.jpg
 
---
 
Ztzebb6.jpg
 
---
Tip   Give
Link to comment
Share on other sites

  • 2 weeks later...
  • 5 months later...

I have the same issue on my Chinese octa-core phone with Android 5.0.2, despite it was working on my S2. Both phones rooted and stuff

Which version are you using now?

Did you try this one http://forum.maxthon.com/index.php?/topic/17840-maxthon-cloud-browser-for-android-v4541000/#comment-92769?

Tip   Give
Link to comment
Share on other sites

I have the same issue on my Chinese octa-core phone with Android 5.0.2, despite it was working on my S2. Both phones rooted and stuff

Thanks for reporting this issue.

Please try the latest version and let us know if the problem persists.

We are collecting the all phone models that are having the problem with ABP settings.

Our android team will working the issue to make sure ABP works on all devices that are supposed to be supported.

Tip   Give
Link to comment
Share on other sites

  • 3 weeks later...
On 5/10/2015, 5:09:49, magg said:

Yeah- really strange issue.

I'm sure that yours S6 is enough powerful to handle Maxthon's ABP :titter: .

Anyway- try to uninstall your current version and manualy install this one from http://www.apk4fun.com/apk/2915/ and check if it's helps.

Thanks I downloaded the latest version from here http://www.apkmonk.com/download-maxthon-web-browser-4-5-4-1000-apk/

Tip   Give
Link to comment
Share on other sites

  • 2 weeks later...
34 minutes ago, Microsoft said:

I use external ABP because of ABP of maxthon not working under android it is fake

 

You're absolutely wrong- it's not fake, works just fine.

Simply try to download current version from here http://forum.maxthon.com/index.php?/topic/18024-maxthon-cloud-browser-for-android-v4552000/ and check again, please.

 

 

Screenshot_2015-12-04-14-05-18.jpeg

Screenshot_2015-12-04-14-05-32.jpeg

Tip   Give
Link to comment
Share on other sites

On 12/4/2015, 4:52:41, magg said:

You're absolutely wrong- it's not fake, works just fine.

Simply try to download current version from here http://forum.maxthon.com/index.php?/topic/18024-maxthon-cloud-browser-for-android-v4552000/ and check again, please.

 

 

Screenshot_2015-12-04-14-05-18.jpeg

Screenshot_2015-12-04-14-05-32.jpeg

Using External ABP with ABP in maxthon for undroid for me is perfect working

Tip   Give
Link to comment
Share on other sites

Having the same issue on my Xperia Z3+ which has a snapdragon 810 so plenty powerful enough. 

 

Tried uninstalling the play store version and manually installing the one suggested here but it made no difference. 

 

This is the one thing keeping me from using this as my main browser. 

 

Can you not just make the setting available but use your performance detection to default it off or provide a warning about detrimental performance? At least then those of us with powerful enough phones can override the buggy detection?

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.