[] Browser sometimes close itself a few seconds after startup.


Recommended Posts

Hi, i have searched the forum, seems my issue is not reported.

I had first experienced this with (previously i was on a 4.4.3.x), and now i am on I run winXP sp3.

Sometimes (between 0 and 2 times a day) i start the browser, it launches properly then after a few seconds (< 5s) it closes itself.

The content of the browser does not seem to matter (i.e. reload last websites opened or just bare quick access window).

In general, once the issue is there, i can't get away with it. If i relaunch the browser many times, it closes the same way as many times.

In some cases, if i wait a few minutes before trying again, i will launch and work properly, but often the only solution is to close the session and log in again, then it will 100% launch properly.

Except for this behaviour Maxthon is very stable for me, even for hours of browsing.

It doesn't behave like a crash, it just closes (there is not popup message, nor any other message when it happens to launch properly again).

I have verified in active processes before the launch and after the close, there is no Maxthon zombie thread running in the background.

I have tried also to disable ABP extension for 4 days and haven't noticed the issue, so it may be related to adblock, but considering the frequency of the issue, i could also be luck.

Link to comment
Share on other sites

It reproduced this morning, i have zipped the MaxthonCrashData folder and uploaded here.

As you can see by the numerous reports, when it happens once, it can be reproduced easily.

I performed many launches all ending up in a crash.

I have launched MaxthonPortable with success 5 times within these tries.

Also i succeeded 2 times to deactivate ABP extension during the 5s the browser was alive. Each time the next relaunch was successful and stable and it crashed as soon as i reactivated the extension.

For the other suggestions, i never used passport.


Link to comment
Share on other sites

So you normally use an installed version and it has the issue described. When you tried with the portable version it worked 5/5 times and no crashes?

If that is correct, then it's something in your settings that is causing the ABP addon to crash. As Oliver pointed out, a clean install should resolve that, meaning delete the userdata folder found in "%appdata%\maxthon3". Type that path into an explorer window and it will go directly to that folder. Make a copy of it first so you still have your data.

To figure out what exactly is causing the issue, you can then copy back one folder at a time till the issue reoccurs. Or depending on your settings it maybe just easier to reset your settings manually.

If I understood that wrong, then we'll need to look from another angle.

Link to comment
Share on other sites

Follow up of the story.

After integrating my settings by dichotomy -- yay that was fun... :-\

It seems that what is provocking the issue is the folder :


It seems that stability can be obtained this way :

- from an empty directory %appdata%/maxthon3/

- copying back all my settings

- except Users/guest/AdFilter

- except Users/guest/AdBlock

If i copy back AdFilter then it crashes, and no matter if i delete it again it continues to crash. The only solution is to start from scratch as indicated above.

I cross fingers, seems to hold for now.

I know that a clean install is recommended, yet losing one's settings everytime is painful, please favor migration whenever possible.

Link to comment
Share on other sites

zwim replied at 2015-4-4 09:09 back.gif

Follow up of the story.

After integrating my settings by dichotomy -- yay that was fun... :-\

yes clean install often fixes bugs and no clean install does not mean you lose everything, as long as you have a passport and synced your data.


Link to comment
Share on other sites

  • 2 weeks later...