What is the latest user agent string for Maxthon?


Recommended Posts

loooping8 replied at 2015-3-15 00:26 back.gif

When I click on your link I get the same result like in the settings of Maxthon.

it looks like you're using a custom user agent (chrome). Try with the default UA

Link to post
Share on other sites

loooping8 replied at 2015-3-14 15:59 back.gif

When I click your link it shows up similar like your result but in the settings it look different( ...

loooping8 replied at 2015-3-15 00:26

When I click on your link I get the same result like in the settings of Maxthon.

it looks like you're using a custom user agent (chrome). Try with the default UA

Comments

loooping8 both the same result

there's no way that using different user agents shows the same result here http://www.useragentstring.com/...

when I use a chrome user agent, it detects my browser as chrome 26 like it did with you, when I use maxthon default user agent it detects it as "browser : maxthon, chrome 30"

Link to post
Share on other sites

M.R.C. replied at 2015-3-15 11:59 back.gif

at every update of maxthon the user agent string must change?

if webkit is updated, default user agent should be updated too, as long as the devs don't forget to do it

user agent is like a browser signature, you can use "fake" ones (that's what you do when you change it in advanced settings)

Link to post
Share on other sites

odyssee replied at 2015-3-15 02:14 back.gif

if webkit is updated, default user agent should be updated too, as long as the devs don't forget t ...

i had a old user agent string even when i had uptade in the version 4.4.4.3000, why?

Link to post
Share on other sites

Oliver One replied at 2015-3-15 12:25 back.gif

But with http://whatsmyuseragent.com/ it's always Chrome 30!

I am not sure we're speaking of the same thing

sites checking user agent should show what you tell them to show (ie the way you set your user agent in the settings)

if you look at the list in the settings : default is different than maxthon (which is probably not updated)

default :Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.4.4.3000 Chrome/30.0.1599.101 Safari/537.36maxthon : Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.12 (KHTML, like Gecko) Maxthon/3.0 Chrome/26.0.1410.43 Safari/535.12chrome :Mozilla/5.0 (Windows NT 5.1; en-US) AppleWebKit/535.12 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/535.12safari :Mozilla/5.0 (Windows NT 5.1; en-US) AppleWebKit/535.12 (KHTML, like Gecko) Version/5.0.1 Safari/535.12therefore when you want to have the latest one for maxthon you have to use the default one (as long as the devs update it) or manually update the others.

Link to post
Share on other sites

So the correct latest user agent string for maxthon (as posted by magdalene) is:

For Windows 8.1:

Mozilla/5.0 (compatible; Windows NT 6.3; U; WOW64; IA64; en) AppleWebKit/599.0+ (KHTML, like Gecko) Maxthon/4.4.4.3000 Chrome/41.0.2272.89 Safari/537.36 OPR/28.0.1750.40 QupZilla/1.8.6

But why when I'm scanning with several scanners the result is always the same:

Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.4.4.3000 Chrome/30.0.1599.101 Safari/537.36

Does it mean that all those scanners wrong? Thank you.

Link to post
Share on other sites

 

@ Bisoprolol > Remember to leave a marking in " Customize UserAgent string ".
Restart the Maxthon Browser, so it rememebers your new settings.

Then go to (still with a marking in your UserAgent)
• UserAgentString.com
http://www.useragentstring.com/
Then it will show your new settings correctly.
Like this for mine :
Mozilla/5.0 (compatible; Windows NT 6.1; U; WOW64; IA64; en) AppleWebKit/599.0+ (KHTML, like Gecko) Maxthon/4.4.4.3000 Chrome/41.0.2272.89 Safari/537.36 OPR/28.0.1750.40 QupZilla/1.8.6

If you unmarked your UserAgent it will show the old settings again.
Like this for mine :
Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.4.4.3000 Chrome/30.0.1599.101 Safari/537.36
Best Regards Ohke

EDIT : Update your UserAgent here :
Latest Stable Version (Updated 20 March 2015). Thanks to Magdalene... (^^,)
• youtube/google issue workarounds - Maxthon for Computers Product Support
http://old-forum.maxthon.com/thread-11008-1-1.html

  • Like 1
Link to post
Share on other sites

Bisoprolol replied at 2015-3-15 18:41 back.gif

So the correct latest user agent string for maxthon (as posted by magdalene) is:

For Windows 8.1:

The truncated version of the UA is probably better than the long version. However both versions work.

I get this UA on the test sites as well

Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.4.4.3000 Chrome/30.0.1599.101 Safari/537.36

At this website

http://can-am.brp.com

I get this popup warning

Your browser (Chrome 30) is out of date. It has known security flaws and may not display all features of this and other websites. Learn how to update your browser

Link to post
Share on other sites

M.R.C. replied at 2015-3-16 04:15 back.gif

thanks to all for the support even if i didn't understood why the Maxthon String was not uptaded ...

Hi M.R.C,

Sorry for this inconvenience brought to you.

Just to let you know, every update the UA string will be change.

Would you please tell us what specific problem you encountered?

According to your feedback, you said that you have an old UA string, did you set the string in setting?

Looking forward to hearing from you.

Thank you for your support.

Link to post
Share on other sites