×

Give a tip

Rendering <i> tag


Svilen
 Share

Recommended Posts

Hello. I'm still getting problems on some sites:

There is one of the problem sites:

https://kibana.bedegaming.net

Unfortunately this is a company limited site so you won't have access to it. However there is the problem:

When i get in Ultra mode i can browse the site and the site is fully functional however the icons used with in the html are not rendered in Maxthon

Here is how the those icons looks like in Maxthon:

http://gyazo.com/708634d2340804c65e8cb52326810e29

This is how they look in Chrome for instance:

http://gyazo.com/8d643a790b7c35ed24939842909df090

When i switch to Retro mode i am able to see those icons

http://gyazo.com/f98e0589150d64fb235a69262f5cfd9a

However I'm getting the error message (as shown on the last screenshot) and the site is not working anymore.

Please advice is it possible to somehow workaround this.

PS: It might be worth to say that the site is on https:// protocol and i have to press "Run unsafe scripts" on Chrome in order to display the site correctly.

Regards.

Tip   Give
Link to comment
Share on other sites

Any chance of posting the HTML here, or at least the section with the offending code? (assuming it doesn't breach any privacy issues with the company).

However I'm getting the error message (as shown on the last screenshot) and the site is not working anymore.

Please advice is it possible to somehow workaround this.When running in Retro, ensure that the "Enable standard rendering in Retro Mode" option is checked in advanced settings to allow it to run with the current version Trident renderer. The page probably doesn't like running in IE compatibility mode which is what happens when that option is unchecked.

Tip   Give
Link to comment
Share on other sites

  • 3 weeks later...

Hi guys,

I was just wondering is there any additional info on that annoying problem.

There is one more site to add although there is plenty of sites that use tag which is not rendered in Ultra mode. The site is: https://github.com/explore the good thing is that most of the sites are working (with some compromise) in retro mode as well (except for kibana) so i can switch cause it is really annoying to browse without be able to see some images.

I was just wondering why is that not considered as a bug i can imagine the tag is pretty popular.

Tip   Give
Link to comment
Share on other sites

Hi again ,

After some investigation, we found out that the problem could be due to many factors including webpage display settings.

I would suggest that you try to reset "Web page font" ( in Wed page display options under advanced settings) to Default to see if it is effective or everything works properly.

Thanks for your support!

11675

post-30503264-1431512390757_thumb.png

Tip   Give
Link to comment
Share on other sites

It looks like a web font icons rendering is not working properly on your Mx version. Based on your pastebin, Kibana used bootstrap framework which use a web font icons like on Twitter and I think it's so popular on web tech today. So, If the icon on Twitter can render properly, it should be displayed well on Kibana too.

And you rite. Nowaday, html tag is commonly used to display a web font icons like font awesome and so on. But I can confirm that it also working properly on ultra mode too (trial error with recent Mx version/v4.4.3.x and v4.4.4.x).

Here's the ultra mode web font icons rendering on github and font awesome site.

11677

Last, what Mx version are you using?

else, make sure all web content (especially css/web font is css part) has been loaded and not blocked by adhunter/adblock rules or blocked by extension (violent monkey script, stylish rules etc).

post-30898809-1431512391078_thumb.gif

Tip   Give
Link to comment
Share on other sites

BugSir007 replied at 2015-2-3 22:09 back.gif

Hi again ,

After some investigation, we found out that the problem could be due to many factors incl ...

Thanks Guys, setting the web font the default seems to fix my problem. Thank you very much it bothers me for more than an year :) I'll keep you posted if i notice any further issues regarding that but so far everything looks good.

Thank you once again guys.

Tip   Give
Link to comment
Share on other sites

 Share