Symbols not showing correctly


Recommended Posts

First post! I just yesterday found Maxthon. I like it!

There's a little problem. I cannot see all symbols as they are supposed to be shown. Does anyone have any idea how to fix that? I did try searching for this, but I only found an opposite question. I am sorry if this has been asked before...

Screenshots:

chrome.jpg

maxthon.jpg

Link to post
Share on other sites

This is another obscure issue of Maxthon. When Maxthon sees a character that is not in the selected font (the default I think is Arial, dont quote me on this) instead of outright displaying an empty box it tries to find a font that has this symbol, this is called font substitution. All is good up until this point. What you see in your example is some regular symbols together with combining unicode symbols "Combining low line" and "Combining overline". How does symbol combining work? Here's an example: "ẃ". I combined two symbols: the Latin small letter W and a Combining acute accent. That acute accent is actually a separate symbol and if you copy and paste it into a text editor and press backspace the acute accent disappears leaving you with only a letter "w". Now I'll try it with Latin capital letter W instead: "Ẃ". Notice how it's a little higher than it was before, here's the small W for comparison: "ẃẂ", the combining character adapts to the letter that stays before it (or sometimes after). Back to Maxthon, so we know how combining characters work, but why do they appear as boxes? Well obviously the font doesn't have these combining characters, but why doesn't it just use font substitution? Because that would be combining two fonts, and the combining characters can't adapt to the other font. Right, why other browsers display it correctly then? Because, surprise, they substitute the symbols beside the problem symbol as well so it doesn't break. So if one symbol in a word is not displaying properly in one font, and that symbol just happens to be a combining one, it would substitute the font for whole word. What I think Maxthon does is it substitutes the font for a single character and, because you can't put a combining symbol with no actual "non-combining" symbols around, it shows as an empty box.

Link to post
Share on other sites

Hi There

Really sorry for the inconvenience, but could you please inform us the website that doesn't show the symbols correctly so i can reproduce the problem, and while you are on that website press the mouse right click and go to encoding and then more and choose the appropriate encoding for the website, or you can also try to switch to Retro mode and see if the problem still exist.

Many thanks

Regards.

Link to post
Share on other sites

Thanks for the replies!

Yup, Retro Mode did fix it. Interesting... Well, we are in the process of updating our website, so we'll look into this while we're at it.

Here's one of my posts where you can see my signature: http://www.potku.net/forum/viewtopic.php?f=29&t=20153&p=834402#p834402

In Retro Mode, it looks just like it should.

I switched the coding from Unicode UTF-8 to Automatic (after trying a few of the options). I still needs Retro Mode, though.

Link to post
Share on other sites