MX4.4.3.1000 cannot work with IDM6.21.15 again


Recommended Posts

When I upgrade MX to 4.4.3.1000 from 800 with IDM upgrade to 6.21.15

The MX downloader / QuickAccess cannot work again.

The issue is same before.

No respond, or MX response is very low on QuickAccess

downloader is always no respond.

Could you check this problem and fix it?

Link to post
Share on other sites

DARKSTORM replied at 2014-11-9 20:44 back.gif

MX downloader worked for me... Downloaded 2 files a while ago, 1 apk and 1 rar=>downloaded from Mega ...

the issue be installed IDM 6.21.15 on same PC.

When you install IDM and MX both, the MX downloader be not workable, QuickAccess be crash or stock on open the QuickAccess

Please see the issue, and get the point. If you never install IDM.

the MX be work very :@well.

Link to post
Share on other sites

Test with a clean install, or with the portable version. Don't sign in to your passport account or import anything. Just install/extract, run, and test with IDM.

If it works with other peoples installs, chances are it's something on your system that's causing the issue.

Just out of curiosity have you notified IDM about these issues, seeing as it seems they are somewhat related to IDM as much as Maxthon?

Link to post
Share on other sites

Yes, I have email the issue to IDM.

No any feedback now.

I think the problem is MX. Because my PC instll firefox, Chrome, Maxthon 4 /3

The issue is only happening on MX4. and the problem is MX4's downloader (default download), and MX4 QuickAccess.

How can I say? the problem is IDM, I don't think so.

I have tried guess account on my PC MX4, the issue is same.

And download the files thru MX4 to automatic capture the download address.

The IDM is work well.

But as you know: If I press alt, the download permission be transfer to MX4's downloader.

Then, downloader be no any respond, just the downloader UI.

Also, the QuickAccess is same, during open the MX4, or see the QA after close all tabs.

The QA be no any response.

I need close MX task by Windows task manager to close all of MX PID.

:@:@:@:@

Link to post
Share on other sites

Despite not liking installing programs that I won't use I decided to test IDM for myself to see if this is a repeatable issue. So here's what i've found out using Maxthon 4.4.3.2000 & IDM 6.21 Build 15.

QuickAccess - no issues with QA not working/crashing, taking too long to start or loading pages etc. I only added a few sites to test with (might test more later on). Closed and restarted MX multiple times - all good.

Misc download on startup - This seems to have been fixed in .2000. In all the tests i've done it never showed, only when going back to an older version did it happen.

MX Downloader - using the ALT key to disable the IDM download detection allowed the MX downloader to correctly catch and download the link. No crashes or any other issues.

This was using my standard MX portable install (with no passport account), and the default settings for IDM.

While it's not 100% confirmation that there is no problem, I can't replicate it here. Based off that i'd say that there is something on your system or IDM settings that is causing the issues. If it was an inherent issue with MX or IDM it should show itself consistently across multiple systems.

Also when testing make sure there aren't any other programs like virus/malware scanners running. They are forever causing issues on systems. Even better, test in Windows safe mode to ensure there is no random program running at startup.

Please start maxthon as Administrator and try again or test, it solves the problem from the Downloads dialog and Maxthon's downloader in my computer.That's an interesting find. Your account is currently a standard or limited user?

Link to post
Share on other sites