×

Give a tip

7twenty

MX Master
  • Posts

    4,695
  • Joined

  • Last visited

  • Days Won

    79

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Release Note6

Posts posted by 7twenty

  1. 6 minutes ago, PHYR said:

    No it didn't, unless you had previously logged in while logged out of your account.

    I think he meant "exit" as stated in an earlier post, rather than logout. Either way exiting/logging out deletes any entries when going back to the same account.

    I still think this is a fix for the privacy issue mentioned earlier.

  2.  

    6 hours ago, badnick said:

    Before instalation of new version If I clicked in the Facebook window for login name, a drop-down menu with the login names used is open and you  could choose  from them. Now if I click in the window for login names It does not appear anything.

    Just to be certain, your issue isn't that you need to login to sites every time you restart Maxthon, it's that the dropdown of previously used logins no longer shows. Correct?

    1 hour ago, badnick said:

    Tried with magic fill enabled(manual) and still dont't work.

    That makes sense, as it was determined that the dropdown you want wasn't related to MagicFill/Passkeeper.

    Have you since logged in to facebook? And does it remember that most recent entry? Sounds like it's just all the logins since the "update" that have been lost.

    I tested on mine and the dropdown is still there, but it seems to be per session. So if you exit Maxthon it removes those details. Which is what MagicFill/Passkeeper should be used for.

    I think you may have been stuffed around by utilising a work-in-progress feature and the current change has affected your workflow.

    Could be a bug that may be fixed at some stage. Or this could be the fix for issue that karajan mentioned.

    Your options at this stage would be go back to your previous version. Or start using Passkeeper for login details.

  3. 3 hours ago, badnick said:

    IF I update to 1000 , I think I loose all my bookmarks/history..etc, because I'm on portable version and has no update option (check for updates)

    Not sure where you got that idea?! The best part of using a portable version is that you can do whatever you want to the data, and always have a backup to go back to, not relying on installers or other means to update your data.

    Do the following and you should be good to go:

    Move your current Maxthon folder to another location as a backup. 

    Extract the latest version of MX portable.

    Copy over the userdata\users\guest and\or userdata\users\[YOUR_EMAIL] folders to the newly extracted Maxthon folder.

    When Maxthon starts it should run as though nothing has changed - with all of your data intact - but it will be the latest version.

    If for whatever reason something isn't right/doesn't work, just delete that folder and copy back the one that you saved elsewhere as a backup. You'll be back to where you were previously.

  4. 2 hours ago, badnick said:

    This option exists in earlier versions of MX4(Ctrl+click)

    Shift+click actually. And Shift+Ctrl+click in MX5.

    Add a shortcut for Shift+Ctrl+Click to your mouse if you can and use that to open new links in that fashion if required.

    2 hours ago, badnick said:

    Also I don’t know why it’s so hard to implement other basic option: the complete session restore (with more than one window).

    yep, another one that has been asked about for a while.

    2 hours ago, badnick said:

    On the other hand, now I run MX 5.0.2.900 –portable version..wich start every time in a strange mode like when i run an installing patch (see atached pictures). And I see that is a new version 5.0.2.1000 but the browser has no option to update..(chek for updates).What should I do in this case?

    Make sure the auto-login option is checked in the settings button in the top right. I think one version had an issue where that setting wouldn't stick.

    I don't think Portable updates automatically? Only option is to get new updates from the forum. Someone might be able to confirm that.

  5. Yeah the dev community is a little dead which is unfortunate, but understandable considering Maxthon is very much a niche browser.

    2 hours ago, astromedia said:

    i suppose one of reasons its hard to find something relevant to addon development is this is changed every version

    I don't agree with that. Much of the API's haven't changed much since the MX3 days, apart from some small revisions/additions. Almost anything written for MX3 should still run in MX5. In fact I think the framework version has only moved from v1.0.0 > v1.0.6 since MX3.

    As far as your original question, I'd say the popup blocker is what should be doing what you want. Unfortunately there are some sites that get around it as well. Although i've noticed the same on FF as well.

    While you probably could create an extension that parses each URL, it's well beyond my scope - at least to the point where it's actually usable. 

  6. 9 hours ago, valkyrie said:

    I activated two extensions and Youtube downloader youtube video downloader but I can not see them in any other bar along with the other extensions like I have to do to see them?

    Nothing gets added to the toolbar as A.S. said. It just adds a download button under the video which you can click.

    Although i'd recommend using Youtube Centre instead. Has more options and the download method is direct rather than a redirect link to savefrom.net.

  7. I've ported the MX4 night mode extension into a standalone extension after looking into it after requests by users to bring it back.

    All credit to the original creators from the MX team.

    Known issues:
    Toolbar button may need to be clicked twice to manually enable/disable Night Mode if Auto mode is enabled.


    http://extension.maxthon.com/detail/index.php?view_id=3060

     

    Changelog:


    1.5.0
    + Fixed issue with exetension running on Night Mode settings page on refresh even when Auto was not enabled
    + Added confirmation for Default settings button


    1.4.0
    + Added Auto enable option (enables on new pages or on refresh)


    1.2.0
    + Added first run user prompt to check default settings


    1.1.0
    + Added default settings button
    + Minor settings page UI changes


    1.0.5
    + Fixed issue where only background colour was being applied


    1.0.0
    + Added Settings page


    0.9.0/b2
    + Icon now updates to show if enabled/disabled


    0.5.0/b1
    + Updated to work as a switch. Click to enable/disable

    0.0.5/a
    + Initial release

    • Like 6
  8. Something weird definitely going on. Just checked windows default program settings and Edge was still set to default even though "Set Maxthon as default" was checked.

    So again, either MX isn't changing the setting properly in windows or windows isn't allowing it.

    Going to Default Programs in windows then selecting MX5/Maxthon Cloud Browser from the list fixes it. Not sure for how long though.

  9. 2 hours ago, A.S. said:

    Portable can not be default browser. This is portable.

     

    On 29/11/2016 at 6:10 AM, karajan said:

    in fact portable version never can be a default browser

    How so? Windows doesn't know it's a portable version... it's just an .exe file. And the browser has (and has always had) an option to set as default.

    I've always used a portable version and probably only recently with Windows 10 has it been an issue where you always get the prompt on starting. So it's either a problem with windows 10, or a conflict between MX and the way windows sets the default browser.

    • Like 1
  10. 4 hours ago, Tony said:

    its a shame the devs and those that waste time on ui log in animation could not put that time to better use and add them in the core browser

    Maybe the UI designers can't do the backend code for the browser. So they need to keep busy with something... that said, there's plenty of UI issues to fix...

    4 hours ago, Tony said:

    for those that dont understand it that is the history button that is coded into the standard skin - so its there and would show on the navbar but someone has chosen to hide it from users - WHY? - for what purpose

    Personally I remove it. It's available via shortcut, or from the reopen last tab rightclick menu. Still easily accessible (just one extra click) and i'd imagine not something that gets used all the time.

    More than anything probably just to unclutter the UI. Probably would have been better if they just disabled it from the default UI, rather than actually disabling it from the skin though. That's my take on why they dropped it.

  11. 3 hours ago, No.1MaxthonFan said:

    so guess a Surface Phone is not in the works.

    Still rumours about it. But it was never insinuated that it would be shown today. Talk is still for a 1st half 2017 release if it's going to happen. But whether it's worth waiting for it is another story altogether. If you want apps.. then it doesn't matter how good the phone is it's not going to magically bring over new apps to the windows world.

    I'm looking at updating in the next few months as well. And as much as I love the Windows phone/10 mobile UI I think it's time to move to where everyone else is. And i'm not even a big app user, but I still feel that WM10 isn't moving ahead enough to warrant buying another phone. I'll still keep an eye on it and see where it heads though. Maybe next upgrade might be a Windows device...

    2 hours ago, joemax said:

    the Pixel maybe the way to go.

    Have to agree with that. Although I don't really like the design. Way too iPhone-y. They could have at least given it it's own identity.

    • Like 1
  12. I like the new start menu. Having just the tiles makes it look much nicer/cleaner and all apps is just a click away just like they used to be. No doubt someone will complain as they always do.

    New features like PIN entry even when numlock is off is great. Can't believe it was never implemented before.

    Not too sure what to make of things like the Photo's app being updated. The new design is nicer (almost harks back to the Win8 style). But then loses the similarities with the rest of the OS and other built in apps. Although usability should trump that I guess.

    Curious to see what other goodies they're going to throw in before too long.

     

    2 hours ago, Tony said:

    i have 2 NAS setups - it can see both but if i try to map any of the drives it comes back with a permission error

    IIRC there was a known issue with some NAS or network things in the previous release.

    Quote

    Authentication changes affecting connectivity to NAS devices and home file servers

    After updating to the latest Insider Preview builds, you may have noticed that shared devices on your home network have disappeared from your home network folder. You may have also noticed your mapped network drives are not available. If you change your network to “private” or “enterprise”, it should start working again. For more information on this behavior change, see this Microsoft Security Bulletin.

    Read more at https://blogs.windows.com/windowsexperience/2016/09/28/announcing-windows-10-insider-preview-build-14936-for-pc/#7U5THOqgW4ebdm3S.99

     

  13. 3 hours ago, magg said:

    Ok, I've made another version of this extension ...

    So this time it uses favs from Infobox.

    Hmmm, this is quite nice. I'm wondering if there's a way to update or change the css to make it better as a fav's list, instead of the infobox style...

  14. They're getting close to release, so any changes will be minor and generally only bugfixes. I guess they're releasing so many so quickly to ensure that there are no problems. I think they did the same just before the 1511 release. Maybe not quite as many though.

    What's more annoying is that you need to download a full 3gb+ update instead of smaller patches. Would be nice if they could sort that out so insider updates come through as cumulative updates.

    • Like 1