×

Give a tip

7twenty

MX Master
  • Posts

    4,695
  • Joined

  • Last visited

  • Days Won

    79

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Release Note6

Posts posted by 7twenty

  1. 6 hours ago, PHYR said:

    Whether having that other player(SpotifyAB windows app) installed on my pc is affecting my experience, I do not know.

    When you click the icon to the left of the volume bar what shows? There might be a number of options depending on what you have run Spotify before.

    To ensure it's the current browser playing the music, there should be just some info on spotify connect. Otherwise it should show "Spotify Connect, this browser", or "Spotify Connect, Opera", etc depending on what is available to play through. If you do have more than one option and you select "this browser" and it still plays, then it's weird. If you, select that and it doesn't play then you have the same issue.

  2. 30 minutes ago, 7x3twenty1 said:

    Nothing will work for now unless there's a major core update

    2 things wrong with this comment.

    1/ Users above have said that it works for them. (unless there's something going on and it's actually playing through a spotify connect device they haven't noticed)
    2/ MX5 is currently using Blink/Chrome 55.0.2883.75. Well above the 45+ that is recommended by Spotify. (unless there's something stripped out that Spotify needs to work, but again see point above)

    Also, it was working fine up until about 1 week ago. So something did obviously change...

    What may be an issue is the DRM that is in place, of which MX doesn't offer any control over, as noted in your 1st link. But again, see point 1.

  3. 5 hours ago, BugSir006 said:

    Please try to back up the data and re-log in your account.

    I'm not using an account, only guest mode on two separate portable versions. One is my everyday browser which is where I first noticed this issue again. The other is a test version I use to play around with.

    As noted above, a new portable version was used to do all testing.

    But I did also test using an account and get the same error. Only thing that hasn't been tested is an installed version. Although I can't see how/why that should change anything?!

    Just out of curiosity, what does the console log show for you guys that it works for?

    MaxthonSnap20170914234550.png

    Note that is with ABP ON. WIth ABP off it still doesn't work, the errors aren't there, but the warning still is.

  4. 1 hour ago, PHYR said:

    Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/5.0 Chrome/55.0.2883.75 Safari/537.36

    Yes. Although it shouldn't matter, as i thought the whole point of MX pushing UA's is to ensure that if a site requires a different one it gets it regardless of what is set in the settings.

    This is error now with that UA.

    MaxthonSnap20170914085205.png

    1 hour ago, PHYR said:

    And what about your sync test version?

    Sort of. It get doesn't get any error, but there's no sound.

    Seems it's another one of these issues where different users get different results... odd.

    Will test a few other things later.

  5. 2 hours ago, BugSir006 said:

    Spotify has been pushed UA online, It should be back to normal, please test and give feedback~ And don't forget to restart the browser before test~

    Hmmm, not working for me. Restarted my main browser (portable), and tested on a fresh portable version as well. Both give the same error as noted above. Tested using the default MX UA, checked and unchecked.

    Cookies and all site data was cleared using dev tools as well.

  6. 11 hours ago, PHYR said:

    I sent them a note that they should support Maxthon.

    Will do the same, although i'm not sure it's them not supporting it, rather maxthon not providing the framework for them to support it.

    If it is related to the decryption module, it was mentioned above that the MX dev's were going to fix that issue. So the question is did it get fixed? or is there something else causing the issues now?

  7. 1 hour ago, PHYR said:

    In my case it opens the player and plays fine until I close the player. It's not playing on the page itself despite looking like it does.

    Yeah, doing this again:

    On 02/04/2017 at 0:27 AM, 7twenty said:

    Tested in Opera and it works fine. Now this is where it gets weird. With Opera still open, Spotify "seems" to run fine in Maxthon. I can play/pause change tracks no problem. Close Opera, then Maxthon doesn't work.

    So i'm wondering what happened with this? Did it ever get done?

    On 21/04/2017 at 3:57 PM, BugSir006 said:

    And the core reason that Maxthon doesn't support well for Spotify (Netflix, Amazon video, etc.) is that Maxthon is lack DRM plug-in, which is 6m big.

    Our PM decides to begin to program the plug-in for Maxthon, but will not add it to the install pack, since it will increase the size. They plan to make it cloud download when first time running Maxthon.

    Was the pushed IE UA cancelled or has something else happened.

  8. 6 hours ago, vedicaudio said:

    @MaxthonDevs, if you are going to support skins, wouldn't it be better to actually have an option within the program to "load" a skin, rather than making the user overwrite files in the Bin folder, which requires admin privleges? It's not a very elegant way to implement this feature.

    Excellent question, and one that they've decided to dodge despite it being asked countless times since the feature was dropped in MX4.

    Part of the problem is that I don't think it's technically an officially supported feature, even though there is documentation explaining the details (albeit much is from MX3/4). So users that know create and modify the skins, and offer them to others.

    On top of that the skin.maxthon.com page still shows " Maxthon Cloud Browser skin feature will see you soon. Please stay tuned.:) For more Maxthon news, please visit  ". Still no info on the main page that the skins on the site don't work with MX4/5. Given that MX3 is long since deprecated, there's no reason to even keep the site online anymore.

    Thankfully Wilser still does create some skins for users despite no support from MX to make it easier for users to add them.

    • Like 2
  9. 9 hours ago, Tony said:

    i guess some will be interested but i cannot see the point - i use the internet for me not to generate money for myself or others - it seems at odds with built in adblockers - they are embedded by maxthon to block ads which websites add to generate revenue - maxthon are now proposing they add something that generates revenue for them - kettle calling the pan black it seems to me

    You're probably one of the many that won't care about it and therefore won't use it. That's your choice.

    As far as finding ways of creating revenue, that's what any smart business does. Whether this works out for them i guess we'll find out in time.

    As for the pot-kettle-black thing, I don't quite agree. If you're using the browser anyway and you get paid for the time spent, then it's win-win for both parties. With ads, rarely does the user benefit from them. Apart from the fact you're effectively taking money away from the site owner, they still get a hit on their site which i believe is what drives the payments of ads on sites.

    Really it's no different to something like microsoft's rewards scheme. The more you use Bing, the more points you're awarded. So you get points to spend on things (win), and they get your eyes on their search engine and away from googles (win). Seems Maxthon are doing the same thing just using a "real" currency instead of points. Although why the need to create another cryptocurrency i don't know, but i'm sure there's a reason behind it.

    Interesting debate to have though.

  10. 5 hours ago, karajan said:

    there are many ways to introduce changes 

    Here you are clearly telling the world that they are few maxthon users and moderators so we make a change

    Nowadays each word has to be considered : is it a bad or a good sign ? 

    how to provide a positive message of Mx ? 

    You can read into the change however you want. The facts are there in black and white, the number of posts over the past few months are virtually non-existent.

    The reason for the change is to coax users into posting in the English support forum, instead of the International section where there post might not even get looked at let alone answered. It also leads to less areas that need moderation or are left un-moderated.

    The English support section is by far the most frequented, so it makes sense to ensure that if users want support they post there to get an answer to a question.

    They are the reasons. Nothing more, nothing less.

    • Like 1
  11. Due to the lack of posts in the international section of the forum, all languages will be combined into one forum which can be used for any non-English language.

    Posts can still be made here in any language. Due to the aforementioned lack of user posts and moderator languages, do not expect any support in a timely manner, or at all depending on the language.

    Note that depending on future posts (or lack thereof) this section may be closed completely.

    It is recommended that users post any issues in the English support section in English. If that is not possible, then your native language with a copy/paste of a Google translation.

    If you have any issues with this change, please post below (in English).


    The Maxthon Moderator team.

  12. Have you tried any of the other cmd. options? Could be that they're designed to only work with the MX UI, not extensions.

    Can't recall having played with these before so can't offer much more than that.

    A new SDK update wouldn't hurt either. cmd.lockBrowser wasn't listed in any of the older ones. So seems to be something new added since the last update for MX4, or has since moved from an internal setting to a cmd option.

  13. 26 minutes ago, bayas said:

    I cannot inspect the page script of extension in the "Content Scripts" section.

    Hmmm, that's not good. Hopefully it gets fixed. I can't image that is by design.

    EDIT: after another look, the do show if they're started and are a page script. Panel or other types don't show, but i'm unsure if that was the case previously as well.

    The ABP one doesn't seem to show anymore.

  14. Doing some digging around and noticed this:

    https://developer.mozilla.org/en-US/docs/Web/CSS/Using_CSS_variables#Browser_compatibility

    https://developer.mozilla.org/en-US/docs/Web/CSS/var#Browser_compatibility

    Seems these features aren't available in Chrome versions <v48. Seeing as MX5 up till now is based on Blink v47, that's more than likely the reason why it's broken.

    But good news is that it works fine, at least with the JSfiddle code that I was testing with, on the latest internal beta. So once that's released you shouldn't have any issues with the ViolentMonkey extension.

    • Like 1
  15. 7 hours ago, PHYR said:

    and new volume controls

    Still makes you wonder why things like this weren't in earlier versions. I'm currently using an app to do that, so it could always be done, but was never added to the to-do list.

    Not sure what to make of the new Fluent design. While Metro had it's haters, and there was a huge number of people asking for Aero glass to return (i used to be one of them), the new look doesn't sit too well with me. I haven't seen it outside of the images shown, maybe in use it will look nicer. The animation that it brings will be nice though. W10 has been a little too static since many of the win8 animations were removed.