×

Give a tip

7twenty

MX Master
  • Posts

    4,695
  • Joined

  • Last visited

  • Days Won

    79

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Release Note6

Bug Comments posted by 7twenty

  1. 1 hour ago, frankmorris said:

    What if I use this portable version on my laptop? Is there a real difference with the standard version, or it's just the fact that I can use it with my USB memory stick?

    No difference. Just that all the data stays in the same folder. Installer version saves stuff in registry and in the users\appdata folder.

    This way if you need to backup anything, or transfer any data you can just copy the entire Maxthon folder.

    Glad you got things figured out...even though we didn't get to the cause of the issue.

  2. 5 hours ago, frankmorris said:

    I don't think the problem is your cloud.
    I had nothing saved on that, before this issue.

    Ok then. I thought you were using a passport account. If you're just using a guest account, then it makes things slightly easier.

    Firstly, make a copy of your Maxthon3 userdata folder. That way if something goes wrong in testing you can just copy it back and continue from where you were. (Should've mentioned that in the post above...)

    Copy the MagicFill2.dat file from the \Users\[USERNAME]\AppData\Roaming\Maxthon3\Users\guest\MagicFill to the portable version \UserData\Users\guest\MagicFill folder from your install version to the portable version folder.

    To my knowledge that is the only file that contains the data, so if it's still able to enter that data on pages that means the data is still there and accessible. Hopefully by copying it to the portable version it will display it all properly, then we can look further for the no displaying problem if required.

    6 hours ago, frankmorris said:

    PS2: question: could it be caused by some disk cleaner?

    Anything is possible. But if there is a problem with the data file then i'd say the data would be corrupt, not invisible. The fact that it's not showing I think is more that the code that displays the data is the problem, rather than the actual saved passwords file.

    Hopefully transferring it to the portable version we can figure out if that is the case.

  3. 20 hours ago, frankmorris said:

    Any last suggestions to try before I trash my computer?

    Let's try something. (and apologies for going through this earlier).

    Download the portable version of MX4.9.4.2000

    Extract this to your desktop and run Maxthon.exe in the Bin folder. (Make sure your installed version of Maxthon is NOT running when testing!).

    Test saving a few forms in guest mode (not signed in) and make sure it works properly.

    Then sign-in to your passport account, wait for everything to sync and see if your saved passwords show.

    If still nothing shows, then it's something saved to the cloud that is causing the issue. If it's working, then it's a local issue with something on your install.

    If it does work properly, you can exit Maxthon portable, start your installed version and hopefully on sync it may fix whatever the issue was.

    If not, then we might look into some copy/pasting... but we'll deal with that later if required.

  4. I can't see any reason why that should happen.

    AFAIK Maxthon will just load the DLL that is in that folder. Works fine with the latest MX versions, and can't see any reason why XP should have any bearing on it loading or not.

    I'd check that the file is not corrupted, the correct file is copied and that Maxthon wasn't running when you copied the file over.

    Also check that the latest flash is working on the system using another browser that uses the same files. (That is not Chrome as it uses it's own one)

  5. 5 minutes ago, Chim said:

    Can you explain what the EasyList is, what it's for ... how it works?  It has me perplexed as to just exactly how those weird choices in there would serve me here in the USA.  I mean, you have choices in there about China, Czech, Dutch, Germany, Hebrew, Italy and what not.  I don't believe I see one in there for USA.

    It's just the name of the most popular and updated block list. The different countries are there to cater for those markets which have their own popular sites. No point in having filters for 1000 German sites if you never use them.

    I think you might be onto something with the dialup issues. The default blocklist is ~2mb, not huge by any stretch, but on dialup maybe there's something going on? If it's corrupted because of a dodgy update it could cause issues.

  6. 9 hours ago, Chim said:

    (2)  I tried 3 times to update the EasyList with the Update button.  I always eventually got a Download Failure Error.

    That's not a good sign. Shows there possibly was something wrong there.

    9 hours ago, Chim said:

    (3)  I unchecked and even X-ed out the EasyList.

    This is what I was talking about. If you did that and nothing changed, then i'm a little more stumped.

  7. 5 hours ago, Chim said:

     Seemingly, it was either something in BlogSpot or MajorGeeks that jumped started Adblock Plus

    Highly doubtful. In fact i'd go as far as to say, not related at all, just a coincidence.

    3 hours ago, Chim said:

    By any chance, does Adblock Plus NEED Google?  

    No. Not related at all. Considering Google are all about ads, and ABP is all about removing them... 

    Out of curiosity, did you do the following as noted above?

    On 9/11/2016 at 0:24 AM, 7twenty said:

    Remove all the filter subscriptions in settings.

    Restart Maxthon and add them again.

    Also check the "view blocked items" list and advise what/if there is anything listed there.

     

    1 hour ago, Chim said:

    Maybe the issue is more likely to manifest itself on Windows XP and not on other newer versions of Windows, Linux or Mac.

    Highly doubtful. What happens in Maxthon and the ABP addon has little to do with the OS outside of the data being downloaded through the network connection.

    1 hour ago, Chim said:

    And I use avast anti-virus.  I have no idea whether an anti-virus could remotely affect something like this.

    This on the other hand, possibly. AV's are notorious for causing grief with certain programs. But in the case, again i'd have to say it's not related. Especially as you didn't note that you made any changes to the AV during your testing.

  8. Remove all the filter subscriptions in settings.

    Restart Maxthon and add them again.

    Also check the "view blocked items" list and advise what/if there is anything listed there.

    6 hours ago, Chim said:

    Is the ad blocking supposed to happen on the Users' end

    This. All happens on the users machine.

  9. 10 hours ago, Chim said:

    1)  So, if that Flash Player Updater does work for me, will I now be able to update Flash Player from that same icon on my desktop upon the release of all newer Flash Player versions?  Or will a new updated Flash Player Updater link be put out by you for each ensuing newer Flash Player version?

    As stated above, it will work so long as the links to the file/s it uses aren't changed. I'll try to keep it up to date as best I can though.

    10 hours ago, Chim said:

    2)  Is that Flash Player Update ONLY for Maxthon?

    No. It updates Flash for the system, so it will affect any other program that uses PPAPI flash (like Opera).

    But you should run it after any new install/update of Maxthon, as it also copies over the correct files for maxthon to detect and work with the latest version. It won't download any flash installers unless there is a newer version.

    8 hours ago, Chim said:

    YAY!  Success!  It worked! :1f60e:   Actually, even better than I thought.

    Thanks for the feedback!

    8 hours ago, Chim said:

     I HATE dealing with any Adobe website.  They're always excruciatingly ssssslow. 

    Well... that's odd as the download is directly from the adobe site!? 

    2 hours ago, joemax said:

    Worked fine after running as administrator, thanx

    No probs... glad to see some people found it useful :D 

    About the admin thing... most people will probably have to do that as MX is installed into program files by default.

  10. 48 minutes ago, Chim said:

    QUESTION:  Is there supposed to be an active Progress Bar?  When I clicked on the button to start the download, it does display at the bottom of the window in Green letters that it is downloading the latest Flash Player version.  However, in that slot that appears like it probably should have had an active Progress Bar ... nothing is happening.

    No, I haven't implemented that. Might have a look, but not sure it can be done due to the way it detects progress.

    The flash update is approx 20mb, so on a dialup connection it may well take some time. To see if anything is downloading you can open up task manager and keep an eye on your network connection.

    It's quite possible that the reason you were having issues before was that the connection was timing out due to the slow speeds. 

  11. 4 hours ago, rick.lane said:

    Now, should this updater file be saved and used with each new update or will it only work for current version? It looks like it should work for any version.

    When MX updates it will copy over the older flash version every time. So yes, you should keep a copy and run it after every update if you want Maxthon to always have the latest flash.

    It will work so long as Maxthon or Adobe don't change any filenames/paths. So no guarantee on how long it will work.

    4 hours ago, rick.lane said:

    Ran the MX Flash Updater 0.65b and it solved that problem right away. Thanks again. ( Just for info, I had to download the file, close MX5 and run the file as admin to get it to work, but it tells you that as you go and then it worked as designed).

    Depending on where Maxthon is installed and your OS user level you may have to run as Admin as you found. I did as much testing as I could, but there still could be some things that I missed.

    Thanks for the feedback.

  12. On 5/11/2016 at 0:24 PM, Chim said:

    Now I just need to figure out how to be able to download it without the download getting stuck or aborting.

    Try download in another browser if MX is having issues. Although works fine here.

    Also check what version you already have installed: http://www.adobe.com/software/flash/about/

    Been playing around with creating an auto updater seeing as fiddling around with files isn't the most user friendly thing for most people. You can try the file attached.

    It will detect your MX and installed flash version, update Flash if it's not the most recent, and copy over the correct files to the Maxthon folders.

    If you do try it, it would nice to get some feedback if it all went smoothly.

    Link to VirusTotal Scan: https://www.virustotal.com/en/file/15807b67a026c22bb88e93ab15d052c4cdc4d2e172013d0ee653a9bba9da2fdd/analysis/1478411287/

    Gets 2 fails from some random scanners... not sure why.

     

    MX Flash Updater_0.65b.exe

    • Like 1
  13. 9 hours ago, Chantao said:

    That's why I still use mx4.9.2.600-beta because of the insinuation "No one else".

    Of all the users that have tested, you are the only one to have this issue. The maths and logic dictates it's a problem on your end.

    After going back reading through the linked thread i noticed that nowhere is it mentioned if you tested with ABP disabled (although it may have been implied with one response).

    Can you test with ABP off and see what happens.

    And nothing ever came of my last request in that thread:

    Quote

    If you try/have tried the portable version and the same happens, can you then delete any userdata (shouldn't be any apart from google sign in), zip up the folder, upload somewhere and link here. I'd be curious to know if that same install still has the issue on another PC

    If this was a site error, it should happen to everyone.

    If this is a Maxthon issue, it should happen to everyone.

    If this is a userdata error, then it will only happen to the user.  << this is where we're at now.

    If it's something else, then we need to narrow it down to what.