• can't delete history entries - help


    skln

    maxthon - 4.4.8.1000, for certain calendar days, the history entries can't be deleted

    they are temporalily removed when the 'x' is pressed but when the history list is refreshed or the browser reopened, the entries are showing up again

     

    this makes maxthon completely unusable for users like me, for two specific reasons associated with history:

    - maxthon crashes very often (for me, at least once a day, all versions, i must note that it's certain flavours of website code that crash it)

    - maxthon restores only 1 window after the crash which means all the websites that were open in other windows during the crash, can only be accessed again via the history

     

    in turn, this means that if history isn't working either, there is even more difficulty in sorting out which websites were open during the crash

     

    google couldn't find something similar reported, is there is something i can do in order to delete these history entries so i can move on browsing through history?
    thank you



    User Feedback

    Recommended Comments

    Pretty sure some/one of your history files are corrupt.

    You need to delete them and then it should start working again. Unfortunately you'll lose any history along with it.

    Files are found in; %appdata%\maxthon3\UserData\Users\[guest or email address]\History

    If you do do this make sure you keep a back up of your data!

    You may not have to delete them all, some trial and error delete/test and see if it starts working properly. If it doesn't then try another history file.

    Share this comment


    Link to comment
    Share on other sites

    chmm, well deleting them defeats the purpose of using history all together

    but anyway thnx

    chmm, well deleting them defeats the purpose of using history all together

    but anyway thnx

     

    edit: wait, no, it can't be corruption (caused by the system)

    i have two separate versions of maxthon installed on my os and the old version did that too, again with specific calendar dates

    i also have ecc memory which generally minimizes such problems

    if it is indeed corruption, it is generated by maxthon saving procedure itself, which means it's a bug

    Share this comment


    Link to comment
    Share on other sites
    12 hours ago, skln said:

    if it is indeed corruption, it is generated by maxthon saving procedure itself, which means it's a bug

    Interesting observation.

    That will definitely fix the issue - i've had the same problem. As i said above, you can mitigate the amount of history data lost by deleting only certain files, as maxthon breaks them up into ~3mb files. Backup, and delete/test/restore till you find the offending one.

    But going back to your observation, it could be something related to the site font encoding. There was an issue a while back where a particular site would cause the last session data to be lost if it was part of it. Turned out to be a hidden character in the websites title.

    Could be the same or similar problem here. But to determine it you'd need to go back and find the offending site/s as mentioned above.

    Share this comment


    Link to comment
    Share on other sites

  • Pending = We are still working on this report.

    Solved = The issue has been fixed and the resolution will be available in the recent version.

    Closed = Feedback or opinion better posted on our forum for discussion.