Perplexer

Maxthon 5.2.7.5000 not supported in Netflix

6 posts in this topic

I have really gotten used to treating Maxthon as a second-class browser. Every time I try something new, I automatically say to myself "I better try this in Chrome or Firefox because Maxthon will probably not work".

And sure enough, I registered on Netflix, logged in and tried playing a video. Immediately I got an error page on Netflix saying that the browser is not supported. It's really sad. Nothing ever goes smoothly with this browser. It seems the most incompatible browser that I use.Image1.png

Share this post


Link to post
Share on other sites

same here with Maxthon 5.2.7.5000 portable and with the user string that you comment

 

It happens not when you enter netflix, nor when you surf within netflix, but when you play some content

 

MaxthonSnap20190721205552.png

Error de Netflix M7121-3078

Si recibes el código de error M7121-3078 en tu ordenador, a menudo acompañado por uno de los siguientes mensajes:

Por favor, actualiza tu navegador
Navegador no compatible

 

Share this post


Link to post
Share on other sites

Hi there, this issue fixed in the v5.3.8.xxx, so I recommend you install v5.3.8.1200.

Share this post


Link to post
Share on other sites

Posted (edited)

If the recommendation is to install a beta branch 5.3.8.xx, with the added incentive that it should not (commented in these forums) mix with the stable installation of the branch 5.2.7.xx, I think we're going to fix :)

Better would be, in the absence of stable solution, openly recommend another browser, and we stop wasting time all of us

That in the end, I think that is what we are all doing (or almost), leave things "serious" for "serious" browsers, and continue browsing through a few webs with maxthon, what's a pity

Edited by pantantrollo

Share this post


Link to post
Share on other sites

Posted (edited)

It is indeed pretty sad that you HAVE to use a BETA version instead of a FINAL / STABLE version if you want to watch one of the most popular video sites on the Internet. I'm surprised that YouTube works in the current final "stable" version. At the moment 5.2.7.5000 is the version which is downloaded from the main Maxthon site by visitors. So people who download Maxthon from www.maxthon.com automatically get the version which they can't use to watch Netflix. This is pretty crazy if you think about it. 

Of course I will not install BETA. I just moved from 5.3.8.x to 5.2.7.x because BETA has issues of its own (I already posted about a BUG with snap tool). So whichever version I use, I will have problems in any case. That's just normal for this stupid Maxthon. These things are the reason I don't actively recommend Maxthon to other people.

Edited by Perplexer

Share this post


Link to post
Share on other sites