Archived

This topic is now archived and is closed to further replies.

stifani

Translate button popup in web pages

21 posts in this topic

hello,

In some webpages, actually to me it happened only in one, if I select some text, the translator button pops up and it will give the translation of the selected text which is a very nice feature to have (It reminds me that firefox plugin - simple translate).

The problem is:

1) why it works only in 1 specific web pages, and not in any other.

2) Is there a way to change the language result, since it always gives chinese

 

I know that I can use the toolbar button up-right to open the translator panel, but this feature of popup button is an extra-addon to maxthon which I think is very good and very fast if anyone need some translation on the fly. 

 

Here is the screenshot

EAGt9OO.png

 

Tnx.

Share this post


Link to post
Share on other sites

Hi and sorry,

I'm not a programmer.
I am a private person.

Share this post


Link to post
Share on other sites

Seems that you're using a maxthon plugin, which one ?

Share this post


Link to post
Share on other sites
1 hour ago, Polaurent said:

Seems that you're using a maxthon plugin, which one ?

 

I'm not.

The only extension I have installed is Adblock Plus

 

bPlz7sn.png

 

As you can see here... 

 

Share this post


Link to post
Share on other sites

Very curious , looks like an extension , never have seen a floating button like that exclude the video bar.

maybe we have to check on the web server you make capture from .

What is the URL ?

 

Share this post


Link to post
Share on other sites

Hi stifani,

You can customize the target language. The translation button will display when the selected language different from the target language.

translate.pngtranslation settings.pngtranslation settings 2.png

10 hours ago, Polaurent said:

Seems that you're using a maxthon plugin, which one ?

It is Maxthon official extension, you can enable it by going to Settings>Function&Addons>Maxthon Tools>Translate.

Share this post


Link to post
Share on other sites
4 hours ago, BugSir006 said:

Hi stifani,

You can customize the target language. The translation button will display when the selected language different from the target language.

...

 

1) It's an in-webpage button that appears after highlighting some text in a webpage (as you can see in post #1). I have Italian selected as "destinaton" language, but as you can see in post #1 it translates in chinese.

2) How to make that clickable button appears in every webpage after selecting some text?? (To me it only happened on github.com)

 

tnx

 

Share this post


Link to post
Share on other sites

I think I found a solution to get this thing to work.

I'm using a portable version of maxthon 5.2.7.1000 so I will provide a solution which worked for me:

 

You need to find the current file in current path

MaxthonPortable5\UserData\Users\guest\Translate\OptionConfig.ini

 

and manually edit the section [TranslateInfo]. Add/Modify the parameter Slipper=1
 

[TranslateInfo]
Slipper=1

 

You will now get inpage button everywhere. If anyone knows how to set  "slipper=1" via gui in maxthon, please let me know :D

 

 

BUT it's not correctly working in any website:

Here it's missing the icon in button:

ea9dEdx.png

 

And here it's missing the translated text:

3v1hrA5.png

 

Any idea how to fix this??

tnx

 

Share this post


Link to post
Share on other sites
16 hours ago, stifani said:

I have Italian selected as "destinaton" language, but as you can see in post #1 it translates in chinese.

3 hours ago, stifani said:

Here it's missing the icon in button:

3 hours ago, stifani said:

And here it's missing the translated text:

Hi stifani,

It would be great if you could provide the specific URLs.

Share this post


Link to post
Share on other sites
13 hours ago, BugSir006 said:

Hi stifani,

It would be great if you could provide the specific URLs.

 

Hello,

here they are:

https://www.test-english.com/  (no icon)

https://www.w3.org/MarkUp/Test/xhtml-print/20050519/tests/A_2_1-BF-01.htm (empty box)

 

 

 

16 hours ago, stifani said:

....

BUT it's not correctly working in any website:

....

Sorry, here I mean: "it's not correctly working in SOME website", because in many others it's working correctly

 

 


 

16 hours ago, stifani said:

...

...  If anyone knows how to set  "slipper=1" via gui in maxthon, please let me know :D

...

Any suggestion here?

 

tnx

 

 

 

Share this post


Link to post
Share on other sites

Hello, i've modified "page\translate\js\bootloader.js" inside "page.dat"

Now inpage button and translation it's working better, even on those website which had xhtml problem and z-index strange values.

 

I've uploaded https://www67.zippyshare.com/v/qi0fJAnM/file.html the modified page.dat, if you want to give it a try.

Just backup "page.dat" inside "Bin\" folder before replacing :D

tnx

 

Share this post


Link to post
Share on other sites

thats interesting. few days ago I had to install clean maxthon and for me it appeared on every website and there was no possibility (or at leasy I didnt find one, but I think I would) to turn it off. now Ive installed latest beta and its gone.

Share this post


Link to post
Share on other sites

okay, its back again. its just not on every website, but I think all boards and some websites. take a look. how do I turn it off?

MaxthonSnap20190405120039.png

Share this post


Link to post
Share on other sites
On 4/5/2019 at 6:01 PM, cphx said:

okay, its back again. its just not on every website, but I think all boards and some websites. take a look. how do I turn it off?

MaxthonSnap20190408192335.png

Share this post


Link to post
Share on other sites
2 hours ago, BugSir006 said:

MaxthonSnap20190408192335.png

yes, but I dont want to disable whole translation tool, just this weird popup. anyway it disapeared for now again..

Share this post


Link to post
Share on other sites
17 hours ago, cphx said:

yes, but I dont want to disable whole translation tool, just this weird popup. anyway it disapeared for now again..

I guess you hid it.

MaxthonSnap20190409151706.png

 

Share this post


Link to post
Share on other sites
On 3/26/2019 at 3:48 PM, stifani said:

hello,

In some webpages, actually to me it happened only in one, if I select some text, the translator button pops up and it will give the translation of the selected text which is a very nice feature to have (It reminds me that firefox plugin - simple translate).

The problem is:

1) why it works only in 1 specific web pages, and not in any other.

2) Is there a way to change the language result, since it always gives chinese

 

I know that I can use the toolbar button up-right to open the translator panel, but this feature of popup button is an extra-addon to maxthon which I think is very good and very fast if anyone need some translation on the fly. 

 

Here is the screenshot

2 hours ago, BugSir006 said:

I guess you hid it.

MaxthonSnap20190409151706.png

 

 

Tnx.

Im talking about this [A] which appears wherever you highlight any text on websites

EAGt9OO.png

Share this post


Link to post
Share on other sites
15 minutes ago, cphx said:

Im talking about this [A] which appears wherever you highlight any text on websites

Which language is the target language?

MaxthonSnap20190409174302.png

Share this post


Link to post
Share on other sites

it doesnt matter. for me it was okay, it translated to english. but i want this tool to be available in maxthon corner but not when I highlight any text

Share this post


Link to post
Share on other sites
On 4/9/2019 at 11:47 AM, cphx said:

it doesnt matter. for me it was okay, it translated to english. but i want this tool to be available in maxthon corner but not when I highlight any text

 

 

 

Hello,

Have you tried this ? But Instead try to set Slipper=0 to see if it works for you: it should disable popup translator button. Works in 5.2.7.1000. Restart maxthon after modifying OptionConfig.ini  :)

 

On 3/27/2019 at 0:51 AM, stifani said:

I think I found a solution to get this thing to work.

I'm using a portable version of maxthon 5.2.7.1000 so I will provide a solution which worked for me:

 

You need to find the current file in current path


MaxthonPortable5\UserData\Users\guest\Translate\OptionConfig.ini

 

and manually edit the section [TranslateInfo]. Add/Modify the parameter Slipper=1
 


[TranslateInfo]
Slipper=1

 

You will now get inpage button everywhere. If anyone knows how to set  "slipper=1" via gui in maxthon, please let me know :D

Share this post


Link to post
Share on other sites