SnowLeopard

Mx 5.2.4.x thru 5.2.6.x will not load PDF pages

10 posts in this topic

Posted (edited)

I have gone back through Maxthon versions from the current beta 300 to 5.2.4.2000-rc.  Mx 6.2.4.2000-rc is the last version tested that would load PDF pages/documents.  This function disappeared in 6.2.4.2000 amd all later versions. WHAT IN HADES HAPPENED?  PLEASE TRSTORE THIS FUNCTION!!!

I have also discovered a bug in the file type management panel when I tried checking PDF to open by default in Mx 5.2.6.300 & 2000.  The panel closed when I clocked OK.  But when I re-opened the panel after finding that didn't help, there was no checkmark by PDF.  I tried SELECT ALL, closed and re-opened the filetype manager and it was blank - no checkmarks were saved.  It seems the filetype manager is non-functional.  I haven't explored how far back this problem goes, but some users will be very miffed by this not working.

For me getting PDF pages to open in Maxthon iis the main priority though correcting non-working feature is a close second.

                                        <<SL>>

Edited by SnowLeopard
Corrections

Share this post


Link to post
Share on other sites
4 hours ago, 7twenty said:

nothing. Works fine in 5.2.6.300 using http://www.orimi.com/pdf-test.pdf to test.

PDF opens directly in MX using the built-in reader.

Disabled_plugin2_www.orimi.com_20181105034221.png

This is what I get after a clean install/syncing of portable 5.2.6.300.  The only thing missing in the screenshot are the words "has been disabled" under the plugin icon.  I have no clue what plugin it means,  The last versions that work for me are 5.2.4.1200 and .2000-rc.  But the kick out an error message saying something is wrong in my account and asking me to login again.  If I do that, the PDFs no longer work.

If I copy UserData from 1200 or 2000-rc into the current 5.2.6.300 and ignore the error message, PDFs loas fine.

So, one question: Do you know what plugin, and more inportant, where it is located?

                                                   <<SL>>

Share this post


Link to post
Share on other sites

Hi SnowLeopard,

Did you enable "Allow all sites to run plug-ins"?

allow all sites to run plug-ins.png

22 hours ago, SnowLeopard said:

I have also discovered a bug in the file type management panel when I tried checking PDF to open by default in Mx 5.2.6.300 & 2000.  The panel closed when I clocked OK.  But when I re-opened the panel after finding that didn't help, there was no checkmark by PDF.  I tried SELECT ALL, closed and re-opened the filetype manager and it was blank - no checkmarks were saved.  It seems the filetype manager is non-functional.  I haven't explored how far back this problem goes, but some users will be very miffed by this not working.

Did you use the system guest account?

QQ截图20181105193240.jpg

Share this post


Link to post
Share on other sites
6 hours ago, BugSir006 said:

Hi SnowLeopard,

Did you enable "Allow all sites to run plug-ins"?

allow all sites to run plug-ins.png

Did you use the system guest account?

QQ截图20181105193240.jpg

BINGO! :)  :5884970a7da3a_1: PDF problem solved. Thanks for pointing that out.  Some of my UserData folders have different settings for that, reason unknown now.

Your question abount account, I was using my account not Guest mode when I encountered the problem about retention of filetype settings.

But your screenshot is not the Maxthon filetype settings pane; it looks like you may be in Windows filetype associations dialog - not sure since I've never used it that I recall.  I expect Maxthon's dialog would control Maxthon operations not change system settings.

Does that clarify or raise more questions?

                                               <<SL>>

Share this post


Link to post
Share on other sites
11 hours ago, SnowLeopard said:

But your screenshot is not the Maxthon filetype settings pane; it looks like you may be in Windows filetype associations dialog - not sure since I've never used it that I recall.  I expect Maxthon's dialog would control Maxthon operations not change system settings.

Hi SnowLeopard,

If you use the Windows guest account, the file type association cannot be selected properly, this is a known bug. Please try to help confirm your system account is admin or not.

Share this post


Link to post
Share on other sites
2 hours ago, BugSir006 said:

Hi SnowLeopard,

If you use the Windows guest account, the file type association cannot be selected properly, this is a known bug. Please try to help confirm your system account is admin or not.

There's noWindows Guest account on this computer.  I have a user account and there are some admin accounts including mine (currently expired).

So, in short, I'm using a normal Windows user account.

                                                               <<SL>>

Share this post


Link to post
Share on other sites
3 hours ago, SnowLeopard said:

There's noWindows Guest account on this computer.  I have a user account and there are some admin accounts including mine (currently expired).

So, in short, I'm using a normal Windows user account.

                                                               <<SL>>

Hi SnowLeopard,

Currently, except the administrator, other user accounts cannot select the type association properly, this is a known bug. 

Share this post


Link to post
Share on other sites