Ryu

Maxthon 5.2.3.5000

5 posts in this topic

I apologize for putting this here but I cannot comment on the news page SO...

I just downloaded Maxthon 5.2.3.5000 and now practically every site I visit tells me it has an expired certificate.

While it is great I can now bypass the notification to get to sites I was previously locked out, of now every site has expired certificates.

There may be other issues but I had to switch to the previous version for now.

Just thought I'd post this. Again I apologize for posting this topic here.

Share this post


Link to post
Share on other sites

This is the correct place for this issue.

So it was working correctly before the update?

Check your date/time is correct.

If you're using a passport, logout and see if it still occurs.

 

1 person likes this

Share this post


Link to post
Share on other sites
8 hours ago, Ryu said:

I apologize for putting this here but I cannot comment on the news page SO...

I just downloaded Maxthon 5.2.3.5000 and now practically every site I visit tells me it has an expired certificate.

While it is great I can now bypass the notification to get to sites I was previously locked out, of now every site has expired certificates.

There may be other issues but I had to switch to the previous version for now.

Just thought I'd post this. Again I apologize for posting this topic here.

Hi Ryu,

Could you please provide a screenshot for us?

Share this post


Link to post
Share on other sites

At this time I cannot post a screen shot however I am NOT using passport. All I know is that many of the sites (not all of them) I that I could readily access with the previous browser now gives me the "Expired Certificate" window.

Again..I really appreciate that you fixed this issue however it is..ummm...too fixed?

Other than that the 5.2.3.5000 works nice. Look forward to the release of 5.2.4.1200 final version.

Share this post


Link to post
Share on other sites
8 hours ago, Ryu said:

At this time I cannot post a screen shot however I am NOT using passport. All I know is that many of the sites (not all of them) I that I could readily access with the previous browser now gives me the "Expired Certificate" window.

Again..I really appreciate that you fixed this issue however it is..ummm...too fixed?

Other than that the 5.2.3.5000 works nice. Look forward to the release of 5.2.4.1200 final version.

You can also send a URL to me. 

Share this post


Link to post
Share on other sites