Paultx2

request Annoying alert about the default browser

20 posts in this topic

Posted (edited)

Every now and then this alert appears in the Windows 10 notification area. I want to stop it for good. How can I? TIA.

mxthnsh2.jpg

Edited by Paultx2
Small corrections

Share this post


Link to post
Share on other sites

cant post in relevant forum so its here, for past month now been getting this dam annoyance every time i load up any browser other than maxthon

https://imgur.com/a/kHlNyMW

Share this post


Link to post
Share on other sites

I have to assume that you are seeing this while using Windows 10 since you didn't give that information. Win10 loves to make one's default browser Edge and has done so to me several times when I have installed a new instance of Maxthon. And I have seen this warning from Maxthon several times as well. I just click the X in the upper right corner and then check Win 10 default programs to see if my default browser has been changed or not. If it had been, I change it back. I would not like it very much if Win 10 had changed it to Edge and Maxthon did not notify me. Not sure what is a bigger annoyance.

Share this post


Link to post
Share on other sites
4 hours ago, rick.lane said:

I have to assume that you are seeing this while using Windows 10 since you didn't give that information.

It's in his very first sentence.

Share this post


Link to post
Share on other sites

In Menu > settings > General, uncheck "At startup, check if its icon is abnormal"

 

9 hours ago, DR3W said:

cant post in relevant forum so its here,

merged with another thread.

See above for fix.

1 person likes this

Share this post


Link to post
Share on other sites
13 hours ago, No.1MaxthonFan said:

It's in his very first sentence.

Oops. Missed that.

1 person likes this

Share this post


Link to post
Share on other sites
20 hours ago, rick.lane said:

I have to assume that you are seeing this while using Windows 10 since you didn't give that information. Win10 loves to make one's default browser Edge and has done so to me several times when I have installed a new instance of Maxthon. And I have seen this warning from Maxthon several times as well. I just click the X in the upper right corner and then check Win 10 default programs to see if my default browser has been changed or not. If it had been, I change it back. I would not like it very much if Win 10 had changed it to Edge and Maxthon did not notify me. Not sure what is a bigger annoyance.

I said: "Every now and then this alert appears in the Windows 10 notification area", so it's clear that my system is Windows 10.

My default browser is Chrome, I rarely open Edge and I use Maxthon with sites Google's browser is not good at, and for some Maxthon native resources, like closing tabs by double-clicking, Boss Key and others.

AFAIK Windows never tries to change my default browser, it only shows some pop-up suggestion for me to do so, but, apart from this little intrusiveness, it's not a system-wide pop-up like Maxthon's, since it only shows up on some Microsoft websites.

But the most important thing here for me is that I know my default browser is not at risk, so I don't want Maxthon to now and then interrupt me with such a creepy warning.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, Paultx2 said:

I said: "Every now and then this alert appears in the Windows 10 notification area", so it's clear that my system is Windows 10.

I already in the post right above yours addressed the fact that I missed that. Sorry.

You didn't say that Chrome was your default browser in you OP. And I never implied that you use Edge. So, here are a few other things that come to mind:

When you install Maxthon, do you use the Advanced button and uncheck "set as default browser". Many people just click "Install Now", you probably do use Advanced, otherwise you would also get a desktop icon and a taskbar icon.

In Maxthon in Menu>Settings>General>Default Browser do you have both options ("Check whether Maxthon is default browser at startup" and " Keep Maxthon as default browser") unchecked.

Since you have been a participant here for some time, I would think that these things are already on your radar and are not the cause of your problem, but it never hurts to check. However, even when I have seen that alert, I have never thought of it as "creepy" and have simply dismissed it by clicking the close X.

That's all I can think of right now. Hope you find your answer.

 

Edited by rick.lane

Share this post


Link to post
Share on other sites

Posted (edited)

Quote

You didn't say that Chrome was your default browser in you OP. And I never implied that you use Edge.

Dear rick.lane, I said that FYI only, so you all could get the whole scenario, since I didn't before and you mentioned these other browsers in your first answer. BTW whenever I install(ed) Maxthon I never set it as the default browser and I always keep it that way in its settings.

As I couldn't find anything about it on Maxthon's interface, I thought the alert we're talking about here might be somehow hard coded within Maxthon.

So when it showed up today I found in the Windows 10 Task Manager there was this MxUp app running and its properties informed it's located in C:\Users\XXXXXXXX\AppData\Roaming\Maxthon5\Public\MxUp (where XXXXXXXX is my user name in the system). The folder has a config file that reads:

[Maxthon]
LastStart=20180810083950
tips=0
RepairShortcutTime=1
SetDefaultTime=1534164871
RepairTime=1532949660
[MxHotnews]
interval=-1

 

Here's the guy! Now I wonder how I can stop it.

Edited by Paultx2

Share this post


Link to post
Share on other sites
On 8/10/2018 at 6:54 AM, 7twenty said:

In Menu > settings > General, uncheck "At startup, check if its icon is abnormal"

 

Thanks a lot man. I've already been thinking to remove Mx from my device. This popup is critically annoying. Who could think it's a good idea to do this?

1 person likes this

Share this post


Link to post
Share on other sites
7 hours ago, vertus said:

Who could think it's a good idea to do this?

I believe the idea is to ensure the startup icon hasn't been hijacked by malware/virus leading you to a fake site, or a fake program on startup.

Not sure how common a occurrence that is, but they felt the need to protect against it. Why people are having it show, what seems to be quite consistently, is something that might need to be looked at. Could be that any change to the shortcut is flagging the warning, when it should only happen if the target startup file is changed. At least that's my understanding of it.

1 person likes this

Share this post


Link to post
Share on other sites

After I install Maxthon, I go to Settings > General, uncheck At startup, check if its icon is abnormal, then I delete its desktop shortcut, go to C:\Program Files\Maxthon#\Bin\ and select Maxthon via mouse/context menu to pin it to the taskbar.

A lot of work that could be avoided! ► I think Maxthon should give users the option to choose, during the installation, if they want a desktop shortcut or not, like many other apps do. And at this point it should have the option to pin it to the taskbar.

I don't like to have a lot of shortcuts on the Windows desktop, so I organize my stuff this way:

Windows Desktop - shortcuts for apps I use frequently but not every day (office package, CorelDRAW, etc.)

Windows Taskbar - shortcuts for apps I use or need to access quickly every day (browsers, music player, etc.)

 

1 person likes this

Share this post


Link to post
Share on other sites
23 hours ago, Paultx2 said:

 

23 hours ago, Paultx2 said:

A lot of work that could be avoided! ► I think Maxthon should give users the option to choose, during the installation, if they want a desktop shortcut or not, like many other apps do. And at this point it should have the option to pin it to the taskbar.

Maxthon does give users the option to choose. In the install window, click on "Advanced" in the lower right corner and both of these options are available. In my earlier post above I asked if you use the Advanced option and from your response I just assumed that you did.

Share this post


Link to post
Share on other sites
5 hours ago, rick.lane said:

Maxthon does give users the option to choose. In the install window, click on "Advanced" in the lower right corner and both of these options are available. In my earlier post above I asked if you use the Advanced option and from your response I just assumed that you did.

rick.lane, I uninstalled and reinstalled Maxthon to check and you're absolutely right! My bad!

I guess I installed previously without my eyeglasses, so I didn't see the Advanced button... :Flushed_Face_Emoji_42x42:

2 people like this

Share this post


Link to post
Share on other sites
2 hours ago, Paultx2 said:

rick.lane, I uninstalled and reinstalled Maxthon to check and you're absolutely right! My bad!

I guess I installed previously without my eyeglasses, so I didn't see the Advanced button... :Flushed_Face_Emoji_42x42:

Now I think that if you go to Menu>Settings>General>Default Browser and uncheck both options and you should not see the "default Browser is at risk" warning any more as I believe the MxUp app is triggered by these settings and kicks in because Maxthon is not your default browser and Chrome is. I am not a total expert on this,  but I think that is what was going on for you.

 

Share this post


Link to post
Share on other sites
On 10/18/2018 at 6:43 PM, rick.lane said:

Now I think that if you go to Menu>Settings>General>Default Browser and uncheck both options and you should not see the "default Browser is at risk" warning any more as I believe the MxUp app is triggered by these settings and kicks in because Maxthon is not your default browser and Chrome is. I am not a total expert on this,  but I think that is what was going on for you.

 

Both options are now unchecked, but it's still showing up.

Share this post


Link to post
Share on other sites
On 10/29/2018 at 4:03 PM, Paultx2 said:

Both options are now unchecked, but it's still showing up.

I discovered a way to stop it. I uninstalled the desktop Maxthon and now only run the portable.

1 person likes this

Share this post


Link to post
Share on other sites
13 minutes ago, DaveMax said:

I discovered a way to stop it. I uninstalled the desktop Maxthon and now only run the portable.

I use the portable version on my laptop. But that's not the point. I think we users should have clear and simple options to stop anyhing annoying to us, don't you agree?

2 people like this

Share this post


Link to post
Share on other sites
On 11/3/2018 at 0:32 AM, Paultx2 said:

I use the portable version on my laptop. But that's not the point. I think we users should have clear and simple options to stop anyhing annoying to us, don't you agree?

Yes. There's absolutely no need for the pop-up/nag screen.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Today I had this notification again despite I switched off this function. 

UPD It was on 5.2.5.600. I've just updated to 5.2.5.3000. Gonna watch it's behavior.

Edited by vertus

Share this post


Link to post
Share on other sites