Ryu

Invalid Certificate?

4 posts in this topic

There are a few websites I tried to access but couldn't because of a supposed "Invalid Certificate" and I am not sure how to get past that.

I can access them on another browser but don't necessarily want to have to keep opening another browser just to view a site so..what are some ways we can rectify this issue? 

Thank You

1 person likes this

Share this post


Link to post
Share on other sites

It's normal for Windows XP and chrome-based browser.

But earlier it was possible to open with command line key.

1 person likes this

Share this post


Link to post
Share on other sites
13 hours ago, Ryu said:

There are a few websites I tried to access but couldn't because of a supposed "Invalid Certificate" and I am not sure how to get past that.

I can access them on another browser but don't necessarily want to have to keep opening another browser just to view a site so..what are some ways we can rectify this issue? 

 

Do you mean the use of a personal certificate for access to a website? , or to the SSL / TLS connection certificate (https), of the website?

If you refer to the first case, since the series v5.2.xx, personal certificates with the core blink do not work (if they work with core IE)

 

 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

On 6/12/2018 at 10:51 AM, pantantrollo said:

 

Do you mean the use of a personal certificate for access to a website? , or to the SSL / TLS connection certificate (https), of the website?

If you refer to the first case, since the series v5.2.xx, personal certificates with the core blink do not work (if they work with core IE)

 

 

Umm...what? Heh, I do not understand the personal certificate thing. (or the other one for that matter).

I am not using a beta version of Maxthon but 5.2.3.2000.

I am able to access other sites that have the HTTPS but there are spare others that I cannot access; I get this message along with the "Invalid Certificate" page.

Error code 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH)

So...how do I fix this? 

P.S: I am not a programmer so I am not well versed on the technical aspect of all this. In other words don't get too complex with explanations....

Edited by Ryu
Fixed something
1 person likes this

Share this post


Link to post
Share on other sites