SirNasso

Stop MX5 open PDF files

10 posts in this topic

Hi guys,

I tried looking through the forums and found nothing about MX5,only some advices from 2 years ago.I want to stop it from opening pdf files when they are downloaded and/or opened from some pages.The default program for viewing PDF files on my PC is Acrobat reader,and it opens all files that are on my hard drive.I can't figure out how to stop Maxthon from doing that.My version is 5.2.3.1000.

1 person likes this

Share this post


Link to post
Share on other sites

I agree - it is very annoying ...

 

1 person likes this

Share this post


Link to post
Share on other sites

This was the topic, but for a change, the thread was closed, and no solution was taken.

 

Share this post


Link to post
Share on other sites

Go to Settings/ Advanced/ Default File Type/ File Type Association Settings and untick PDFMaxthonSnap20180608173629.png

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

3 hours ago, Magdalene said:

Go to Settings/ Advanced/ Default File Type/ File Type Association Settings and untick PDF

In the thread that I emphasize above, the answer you put is already stated, but that is not the problem (let alone the solution)

The thread would not be so long and not so documented if it were so easy  :)

Edited by pantantrollo

Share this post


Link to post
Share on other sites

Posted (edited)

I use Foxit Reader as my default PDF reader, and have the settings just as displayed in Magdalene's post. When I click on a PDF for downloading I get a "download file" dialog and then I click on "Open", a download manager window opens but nothing is downloaded and the PDF opens in Foxit. It used to open in Maxthon until I changed that setting. But even then, I clicked a couple of times on the PDF window download arrow and it would open in Foxit. Are you all clicking on "Save" perhaps instead of "Open"?

Edited by rick.lane

Share this post


Link to post
Share on other sites

Posted (edited)

42 minutes ago, rick.lane said:

I use Foxit Reader as my default PDF reader, and have the settings just as displayed in Magdalene's post. When I click on a PDF for downloading I get a "download file" dialog and then I click on "Open", a download manager window opens but nothing is downloaded and the PDF opens in Foxit. It used to open in Maxthon until I changed that setting. But even then, I clicked a couple of times on the PDF window download arrow and it would open in Foxit. Are you all clicking on "Save" perhaps instead of "Open"?

I use Sumatra as default for Pdf's. It functions the same as rick.lane's Foxit.

Go to Settings/General/Download Settings and tick  Open the file using default program

MaxthonSnap20180608220850.png

Edited by Magdalene
1 person likes this

Share this post


Link to post
Share on other sites

I also have the same settings for that one as well, Magdalene. The combination of the setting in General>Download Settings and in Advanced/ Default File Type/ File Type Association  made it work for me.

 

Share this post


Link to post
Share on other sites
1 hour ago, Magdalene said:

I use Sumatra as default for Pdf's. It functions the same as rick.lane's Foxit.

Go to Settings/General/Download Settings and tick  Open the file using default program

This only works if you choose to download the file, then open from the download dialog. This won't work if you just click on the file - maxthon opens it instead, no matter what the settings are.

The request is that Maxthon opens the PDF directly in the default program.

1 person likes this

Share this post


Link to post
Share on other sites

I checked the 2 settings Magdalene mentioned.The first one was uncheked,but the seccond wan wasn't checked.So I made them as on the screenshots and will see what happens.

Share this post


Link to post
Share on other sites