Archived

This topic is now archived and is closed to further replies.

chuilities

Apparently 5.2.2.1000 still freezes

10 posts in this topic

Ever since 5.2.X, Maxthon crashes randomly, at least for me that is.
Doesn't matter if it's on idle, on a website or watching videos, it just freezes, and must force close. Could be any time from a minute, 5 minutes or 20 minutes, just at random.
Some people reported they didn't experience any failure with 5.2.X, so I'm not sure if it only affects on certain operating system (8.1) or interfering with a certain program.
Neither portable nor fresh install makes a different.

5.2.2.1000 is the worst so far, and most noticable for me because it floods the Event Viewer every 2 seconds (literally) as long as Maxthon is opened.
The following 2 separate entries is from Application Tab, alternating every second, Event ID 0, Source PSI

System.Data.DeletedRowInaccessibleException: Deleted row information cannot be accessed through the row.
   at System.Data.DataRow.GetDefaultRecord()
   at System.Data.DataRow.get_Item(String columnName)
   at PSI.PsiSystemDataModel.EndUpdate(Int32 updateId)
Stack Trace
    at System.Data.DataRow.GetDefaultRecord()
   at System.Data.DataRow.get_Item(String columnName)
   at PSI.PsiSystemDataModel.EndUpdate(Int32 updateId)
System.Exception: Could not End Update ---> System.Data.DeletedRowInaccessibleException: Deleted row information cannot be accessed through the row.
   at System.Data.DataRow.GetDefaultRecord()
   at System.Data.DataRow.get_Item(String columnName)
   at PSI.PsiSystemDataModel.EndUpdate(Int32 updateId)
   --- End of inner exception stack trace ---
Stack Trace
    at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at PSI.PsiSystemDataModel.RecordExceptionInEventLog(Exception exception)
   at PSI.PsiSystemDataModel.EndUpdate(Int32 updateId)
   at PSI.PsiSystemDataModel.pollWorker_DoWork(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
   at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)
   at System.Runtime.Remoting.Proxies.AgileAsyncWorkerItem.ThreadPoolCallBack(Object o)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

 

1 person likes this

Share this post


Link to post
Share on other sites

I'm having the same issues on windows 10.

It started with one of the 5.x but not the first one.

I'm always testing betas too so I can't tell which one is causing the problem.

I'm now testing this latest 5.2.2.1000.

Steps.

1. uninstalled maxthon removing everything including user data with Iobit uninstaller to be sure no left over

2. used wise registery cleaner to make sure everything is cleared

3. restarted in safe mode

4. installed 5.2.2.1000 in safe mode

5.checked it working in safe mode with no issues

6.rebooted and started maxthon normally with guest mode

7.everything was a OK so logged in with my user account 

8.A note:

I had to disable all my addons except maxthon ones

9. testing it now with no problems so far

10. I'll be updating this if it goes back to freezing

 

Hope this helps

Muhammed 

1 person likes this

Share this post


Link to post
Share on other sites

me too, i should have never updated. my old maxthon ran like a demon, but i updated to maxthon5 and now im slower than dial up. now i cant uninstall all the parts, im freezing crashing and unable to connect to the internet.  :(:(  i love maxthon and dont want to run anything else.

1 person likes this

Share this post


Link to post
Share on other sites

The last stable version without freezes or crashes for me is 5.1.7.2000, the browser works fine that is until the auto update kicks in and forces you back to the lastest version.
My guess is whatever certain element they introduced in 5.2.X is mostly the culprit that caused the error.

Also, I'm not sure if this is an intended feature or bug or just me, ever since 5.2.X, mouse gesture takes two swipes to register. The first swipe does nothing and just opens the RMB menu.

1 person likes this

Share this post


Link to post
Share on other sites
11 hours ago, chuilities said:

The last stable version without freezes or crashes for me is 5.1.7.2000, the browser works fine that is until the auto update kicks in and forces you back to the lastest version.

It's the version I'm working with. For me, the 5.2.xx series is more beta than anything else.

If you do not want to be updated, use the portable version

Share this post


Link to post
Share on other sites
19 hours ago, chris ashby said:

, but i updated to maxthon5 and now im slower than dial up. now i cant uninstall all the parts, im freezing crashing and unable to connect to the internet.  :(:(  i love maxthon and dont want to run anything else.

How did you update to Maxthon 5? What did you update from and where did you install it? I am not a computer geek and do not have a high tech machine, but I have never experienced any freezing or slowness in any Maxthon version since 2004, and especially not with any of the Maxthon 5 versions, so I am at a loss as to why you folks are having these troubles since we are installing the same software into a Windows computer.

1 person likes this

Share this post


Link to post
Share on other sites
55 minutes ago, rick.lane said:

How did you update to Maxthon 5? What did you update from and where did you install it? I am not a computer geek and do not have a high tech machine, but I have never experienced any freezing or slowness in any Maxthon version since 2004, and especially not with any of the Maxthon 5 versions, so I am at a loss as to why you folks are having these troubles since we are installing the same software into a Windows computer.

For me freezing stopped after I disabled all my 3rd party addons.

Do you have any installed? If yes. Could you name them so that I can check maxthon with them

Thanks

20 hours ago, chris ashby said:

me too, i should have never updated. my old maxthon ran like a demon, but i updated to maxthon5 and now im slower than dial up. now i cant uninstall all the parts, im freezing crashing and unable to connect to the internet.  :(:(  i love maxthon and dont want to run anything else.

Have you tried my steps above?

Try that fix and see

2 people like this

Share this post


Link to post
Share on other sites
1 hour ago, Mhzayer said:

For me freezing stopped after I disabled all my 3rd party addons.

Do you have any installed? If yes. Could you name them so that I can check maxthon with them

The only third party extension I have installed if F.B.Purity and it's enabled.

Share this post


Link to post
Share on other sites
7 hours ago, rick.lane said:

The only third party extension I have installed if F.B.Purity and it's enabled.

Thanks Rick

It's one of my disabled ones

I'll be enabling it and see.

:edit

FB wasn't updated too so thanks again I had the chance to update it to the latest version

really appreciate it bro

Share this post


Link to post
Share on other sites

Update:

So far no freezing though I enabled adblock, FbPurity adons.

I even enabled savefrom addon for a short time with no sign of freezing.

Share this post


Link to post
Share on other sites