mcv

pc issue MX5 PC Beta 5.2..... problem with domain login

79 posts in this topic

@pantantrollo

We have tested on the issue that you mentioned, It is the same situation as Chrome, so QA-engineer think that is URL issue, it related with the website.

1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, BugSir006 said:

@pantantrollo

We have tested on the issue that you mentioned, It is the same situation as Chrome, so QA-engineer think that is URL issue, it related with the website.

Webmoney.ru - same problem

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

13 hours ago, BugSir006 said:

@pantantrollo

We have tested on the issue that you mentioned, It is the same situation as Chrome, so QA-engineer think that is URL issue, it related with the website.

With all the webs that request digital certificates? , I recommend you change your qa-engineer

Core, IE, egde, ok
Core, gecko, quantum, ok
Core, blink, (opera, vivaldi, chrome, etc), ok

!!!! Maxthon before series 5.2, !!! , ok

We have been like this, almost 2 months

bad, bad, bad, support (and image) you are giving people who go through this forums

Edited by pantantrollo
2 people like this

Share this post


Link to post
Share on other sites

Hey, do you have any website that "We" could use to reproduce the problem? The sites in above posts just don't display any certificate dialog on any browser. Maybe they require special login information.

1 person likes this

Share this post


Link to post
Share on other sites

This is still not fixed in 5.2.3.500 ? Terrible. But it's exactly like I said in my last post on April 18th! They will not fix this. So this browser is basically dead. It cannot be used anymore for on-line banking or any other websites which require digital certificates. All versions after 5.1.7.2000 are useless.

Share this post


Link to post
Share on other sites
3 minutes ago, Perplexer said:

This is still not fixed in 5.2.3.500 ? Terrible. But it's exactly like I said in my last post on April 18th! They will not fix this. So this browser is basically dead. It cannot be used anymore for on-line banking or any other websites which require digital certificates. All versions after 5.1.7.2000 are useless.

Could you give a site we can test the problem ?

Share this post


Link to post
Share on other sites

Posted (edited)

39 minutes ago, MaxthonJeff said:

Hey, do you have any website that "We" could use to reproduce the problem? The sites in above posts just don't display any certificate dialog on any browser. Maybe they require special login information.

 

I copy and paste the same web. (in order to show the dialog, you must have a valid certificate installed, otherwise, obviously it will not jump).

No additional information is needed for the login, which is precisely what it is about when using the certificate, to log in

https://empleocastillayleon.jcyl.es/oficinavirtual/comprobarPIN.do?srvc=mostrarLeerDni&tpdstn=2

https://sede.sepe.gob.es/GesUsuariosSEDE/GestionUsuariosTrabajaWeb/intro_seguridad.do

https://www.sede.fnmt.gob.es/certificados/persona-fisica/verificar-estado

 

Is enough, I think, documented in my post of this thread, with the captures, which in other browsers works without problems

 

Edited by pantantrollo

Share this post


Link to post
Share on other sites

The problem is we don't have valid certificate for these sites.Do you know how to get them?  Maybe you could record a video to show the problem ?

Share this post


Link to post
Share on other sites
2 minutes ago, MaxthonJeff said:

The problem is we don't have valid certificate for these sites.Do you know how to get them?  Maybe you could record a video to show the problem ?

 

I imagine you can try with any certificate that you have for the corresponding websites. Does anyone in Maxthon Dev use an electronic certificate in their country?

I think that in the screenshots it looks perfectly, if I have time, I will try to upload a video.
 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Like I wrote in one of my previous posts, you can't just "test" this problem on some random site. I can give you a link to my online bank, but since you don't have a certificate for it, you will always see the error page, in all browsers:

https://epoti.abanka.si/abanet/kdp/sys/prijava.aspx?

I do have a certificate for this online bank so when I visit this page, Maxthon should display a certificate window or it should take me to the log-in page. But it doesn't. It shows me the error page, exactly like you see it.

You can only test this problem yourself if you have your own digital certificate for some website (online bank, healthcare website, ...).

Like I said before, Maxthon does not see the certificates on the PC, so you can't use Maxthon to log-in to those websites. Without fix, Maxthon is unusable.

Edited by Perplexer
1 person likes this

Share this post


Link to post
Share on other sites

@pantantrollo

Could you please send me you certificate file? Here's the steps: It would be great if you can help us reproduce this issue

66.png

444.png

 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

42 minutes ago, BugSir006 said:

Could you please send me you certificate file? Here's the steps: It would be great if you can help us reproduce this issue

 

Please, how can you ask me to send you my digital certificate for personal use? ,

With all due respect, I think that with this request, I think that you do not really know what you are trying to fix, and more seeing the screenshots that you put me up here.


And if what you want are the SSL certificates of the web, you can save them yourself. What would you want me to send them to you?

But I'm telling you, the screenshots you mention do not make reference to the problem, since they are totally different things

Edited by pantantrollo
1 person likes this

Share this post


Link to post
Share on other sites
On 5/30/2018 at 4:40 PM, MaxthonJeff said:

Hey, do you have any website that "We" could use to reproduce the problem? The sites in above posts just don't display any certificate dialog on any browser. Maybe they require special login information.

You may registered on https://www.wmtransfer.com/eng/ and test login with sertificate (with Keeper WebPro (Light)). Whats problem?

44 minutes ago, BugSir006 said:

Could you please send me you certificate file? Here's the steps: It would be great if you can help us reproduce this issue

You may registered on https://www.wmtransfer.com/eng/ and test login with sertificate (with Keeper WebPro (Light)). Whats problem?

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

20 minutes ago, gudkov said:

You may registered on https://www.wmtransfer.com/eng/ and test login with sertificate (with Keeper WebPro (Light)). Whats problem?

I must do something wrong, because from that url I can not access (I do not ask for a certificate (neither with maxthon, nor with other browsers), but from this url, it looks fast if it fails or not (if ask for the certificate)

https://light.wmtransfer.com/

No need to register, with the icon of the "certificate", it is checked whether the request to use the certificate is skipped or not.

 

But the problem remains the same, if the maxthon development team does not have a personal digital certificate, they will not be able to prove anything :(

Edited by pantantrollo
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

6 minutes ago, pantantrollo said:

I must do something wrong, because from that url I can not access (I do not ask for a certificate (neither with maxthon, nor with other browsers), but from this url, it looks fast if it fails or not (if ask for the certificate)

https://light.wmtransfer.com/

But the problem remains the same, if the maxthon development team does not have a personal digital certificate, they will not be able to prove anything :(

https://light.wmtransfer.com/v3/Login/Login?ReturnUrl=%2Fv3&lang=en

https://light.wmtransfer.com/v3/Login/NoCert

 

No installed certificates found

This can happen in the following cases:
 
  1. You are not registered with WebMoney Transfer and do not have a personal certificate yet. You can receive certificate two ways:
    • Register new WMID and get certificate at start.wmtransfer.com
    • Receive certificate for existing WMID in Settings->Security section after logging in Keeper WebPro via other method.
  2. You failed to install the personal certificate for WM Keeper WebPro into the browser via light.wmtransfer.com Please, install the certificate from the backup file (.PFX), restart your browser and try to log in again.
  3. You have already opened the page in this browser but haven't chosen any certificate for further usage. The browser now remembers this choice. Please, restart your browser, log in again and choose the appropriate WebMoney Keeper WebPro certificate. If you use Internet Explorer, click "Clear SSL state " at Tools/Internet Options/Content.
  4. If you use MacOS X and updated the operation system to version 10.5.3 please see http://support.apple.com/kb/HT1679?viewlocale=en_US to resolve the issue.
  5. Some antiviruses can block certificate choice dialog. Try to disable secure connection (HTTPS) scan in antivirus settings or add site to trusted sites list. If there are no such settings, try to completely disable antivirus.

Only WMIDs with Keeper WebPro connected can receive certificate.

The developer must perform this action: 

and then conduct the tests. I repeat, I do not see any problems for the tests. 

You can also register and test.

Edited by gudkov

Share this post


Link to post
Share on other sites

We continue the same as 2 months ago !!! ,  digital certificates with core blink do not work.
Maxthon v 5.2.3.2000 portable

2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

Wow, with everything that was said in this topic, it's unbeliveable to see that they actually don't seem to even know what digital certificates are, how they work, or what the problem is. Don't they have certificates in China? This is incredible! And it's really weird that nobody else complains here about it. Don't people use certificates? Or maybe they use old MX 5.1.x.xxxx versions. I'm forced to use 5.1.7.2000 and when this gets outdated I'll be FORCED to stop using Maxthon. I never thought this is how I will leave this browser.

BugSir006, to ask somebody for his certificate is the same as asking for his username & password. Please don't do that! It's inappropriate!

Edited by Perplexer
1 person likes this

Share this post


Link to post
Share on other sites
On 6/9/2018 at 5:37 PM, Perplexer said:

Don't people use certificates

I don't imagine it's an overly common thing to do, at least not in the mainstream. Possibly more so with those in certain fields or those with the desire to add an extra level of security.

But that's just an assumption.

I'd say you're using the wrong browser if you want many/any higher level features or options. As a basic browser Maxthon is great, if only for the number of default features available. But when it comes to the more advanced options/features it falls way short of almost every other browser out there.

It's quite possible it was working previously because it wasn't removed/disabled/broken. But the reason it's not getting fixed is because the feature has been removed/disabled/broken but they're unsure of how/why?? don't know... interesting though,...

Share this post


Link to post
Share on other sites
6 hours ago, 7twenty said:

I don't imagine it's an overly common thing to do, at least not in the mainstream. Possibly more so with those in certain fields or those with the desire to add an extra level of security.

It's more common than you imagine :-)
At least in the EU area, and in particular is spain (which is what I know).
For any procedure with the public administration, you need a digital certificate (if you do not want to endure long queues and lose time). With the same universities, with medical services, financial institutions, ect ..

 

6 hours ago, 7twenty said:

I'd say you're using the wrong browser if you want many/any higher level features or options. As a basic browser Maxthon is great, if only for the number of default features available. But when it comes to the more advanced options/features it falls way short of almost every other browser out there.

It's quite possible it was working previously because it wasn't removed/disabled/broken. But the reason it's not getting fixed is because the feature has been removed/disabled/broken but they're unsure of how/why?? don't know... interesting though,...

Is that we are not talking about a "feature" that defines a browser, we are talking about the management of that browser with the pages that ask for an electronic certificate.

NO browser that has tested has that problem, because as I mentioned it is not a lack of a feature, but a failure in the development of a browser-specific function (to give you a similar example, it's as if in a browser update, it did do not manage encrypted SSL connections with the web in https:// )

I am clear that it is not a feature not implemented, but a tremendous failure of implementation and a lack of response (on the part of support and development) of the company that develops it, either due to lack of resources or ignorance (seen the last comments on the matter).

 

But the advertising in the browser, that's not missing, especially with the cryptocurrency theme :-(

 

MaxthonSnap20180614105840.png

1 person likes this

Share this post


Link to post
Share on other sites