Archived

This topic is now archived and is closed to further replies.

BugSir006

MX5 PC official Release 5.1.6.3000

19 posts in this topic

Hey Maxers, 

Welcome to have a try of the brand new release!

Version 5.1.6.3000

For the full release note and changelog: click here

Also available on Maxthon's official website

http://www.maxthon.com/

 

Happy browsing and feel free leave your comment!

1 person likes this

Share this post


Link to post
Share on other sites

still waiting for new core which was said to be coming in 2 weeks many weeks ago

3 people like this

Share this post


Link to post
Share on other sites

On 03.02.2018 at 2:11 AM, zork said:

It seems that Violentmonkey is not working in this version.

  On 03.02.2018 at 2:11 AM, zork said:

Scripts not running!!!

Violentmonkey works normal only with mx_core.dll from 5.1.6.1000

3 people like this

Share this post


Link to post
Share on other sites
14 hours ago, Tony said:

still waiting for new core which was said to be coming in 2 weeks many weeks ago

https://trello.com/b/ofOaTdxE/mx5-pc-public

Tony, we had made arrangements for core update in next plan stage. The core update was exactly postponed because of some reasons and thank you for your patience and understanding in this matter.:p

10 hours ago, zork said:

 

 

Scripts not running!!!

Violentmonkey works normal only with mx_core.dll from 5.1.6.1000

Will have further test please wait

1 person likes this

Share this post


Link to post
Share on other sites

In Maxnote editor in note or memo mode tooltips translation is missing. Only english or сhinese. No such strings on Crowdin or ini-file.

Untitled-1.png

1 person likes this

Share this post


Link to post
Share on other sites

As I reported with the release of 5.1.6.2000, the FB Purity extension also does not work with this release, so I continue to use 5.1.6.1000, which is the last version that this extension worked in. I have completely removed the extension from the browser, downloaded the latest extension version and re-installed it and it still does not work. In Menu>settings>Functions and Addons>Addons, it is shown to be installed and enabled but it does not appear when I open Facebook.

Fortunately, for some reason I am able to run 5.1.6.1000 on my main desktop machine (Win10 Home 64 bit) without Maxthon being automatically updated to 5.1.6.3000, as it is on my Win10 32-bit tablet and on my Win7 32 bit older machine. Not sure what I did to my main machine to stop the auto update, but on my other 2 units, I am unable to open Maxthon without it being automatically upgraded to 5.1.6.3000. This is pretty unacceptable as I, as a tester for years now, always have several version releases installed so that I can better be able to try and duplicate others problems that are posted and do not want them updated automatically. If there is a "switch" to enable/disable this automatic update, I have not yet come across it, and there definitely should be one. I get my best results when I install new versions manually, many times in a new folder, and really never want to have any version automatically updated. I realize that many users that don't regularly hang out at the forum are used to all of their programs/applications/apps being automatically updated or at least are notified that a new version is available and can click to update and have been requesting this for years now, so it's good that it is finally available, but it should be an option, not without any control over it. My 2 cents.

5 people like this

Share this post


Link to post
Share on other sites
11 hours ago, rick.lane said:

If there is a "switch" to enable/disable this automatic update, I have not yet come across it, and there definitely should be one.

to my surprise, I got this automatic update too, no notification, no question to ask if I'm ok, no way to disable this :(

1 person likes this

Share this post


Link to post
Share on other sites
12 hours ago, rick.lane said:

As I reported with the release of 5.1.6.2000, the FB Purity extension also does not work with this release, so I continue to use 5.1.6.1000, which is the last version that this extension worked in. I have completely removed the extension from the browser, downloaded the latest extension version and re-installed it and it still does not work. In Menu>settings>Functions and Addons>Addons, it is shown to be installed and enabled but it does not appear when I open Facebook.

Will give a test 

12 hours ago, rick.lane said:

Fortunately, for some reason I am able to run 5.1.6.1000 on my main desktop machine (Win10 Home 64 bit) without Maxthon being automatically updated to 5.1.6.3000, as it is on my Win10 32-bit tablet and on my Win7 32 bit older machine. Not sure what I did to my main machine to stop the auto update, but on my other 2 units, I am unable to open Maxthon without it being automatically upgraded to 5.1.6.3000. This is pretty unacceptable as I, as a tester for years now, always have several version releases installed so that I can better be able to try and duplicate others problems that are posted and do not want them updated automatically. If there is a "switch" to enable/disable this automatic update, I have not yet come across it, and there definitely should be one. I get my best results when I install new versions manually, many times in a new folder, and really never want to have any version automatically updated. I realize that many users that don't regularly hang out at the forum are used to all of their programs/applications/apps being automatically updated or at least are notified that a new version is available and can click to update and have been requesting this for years now, so it's good that it is finally available, but it should be an option, not without any control over it. My 2 cents.

We have given the matter much thought before. The problem is there maybe some serious bugs still exist in previous version. So any bugs or problems would create a bad using experience.  That's the reason we made update to users.

1 person likes this

Share this post


Link to post
Share on other sites
56 minutes ago, BugSir006 said:

We have given the matter much thought before. The problem is there maybe some serious bugs still exist in previous version. So any bugs or problems would create a bad using experience.  That's the reason we made update to users.

you provide the software from there it should be user choice - if they want to use an older version thats up to them - its not for you to force any version on the user base - thats dictatorship 

Share this post


Link to post
Share on other sites
1 hour ago, Tony said:

its not for you to force any version on the user base

Ummm, maybe not depending on what the licence agreement states.

Updates at the discretion of the developer may well be part of the agreement.

Share this post


Link to post
Share on other sites
On 2/22/2018 at 2:31 AM, rick.lane said:

As I reported with the release of 5.1.6.2000, the FB Purity extension also does not work with this release, so I continue to use 5.1.6.1000, which is the last version that this extension worked in. I have completely removed the extension from the browser, downloaded the latest extension version and re-installed it and it still does not work. In Menu>settings>Functions and Addons>Addons, it is shown to be installed and enabled but it does not appear when I open Facebook.

We made a test on this, and there something we need confirm with you.

1.Have you upgrade this extension to latest version(Last Updated:2018-02-22), and is it work fine after update?

1.png

2.We just try to install this extension both on V5.1.6.1000 and V5.1.6.3000, and it seems works fine on both version. I mean, it can block ads. You said it doesn't work anymore, could you please tell us some specific information of which part doesn't work anymore? Can't block'sponsored' on fb? 

1 person likes this

Share this post


Link to post
Share on other sites
8 hours ago, BugSir006 said:

1.Have you upgrade this extension to latest version(Last Updated:2018-02-22), and is it work fine after update?

You quoted me but apparently did not read what you quoted: " I have completely removed the extension from the browser, downloaded the latest extension version and re-installed it and it still does not work. In Menu>settings>Functions and Addons>Addons, it is shown to be installed and enabled but it does not appear when I open Facebook". So the answer, again, to your question is Yes, I downloaded and installed the latest version of F.B. Purity and it does not work fine after update still; it does not work at all. It does not show up on my toolbar as FBP right next to Home, I can not acces it's options page and it is not cleaning up anything in Facebook.

2.We just try to install this extension both on V5.1.6.1000 and V5.1.6.3000, and it seems works fine on both version. I mean, it can block ads. You said it doesn't work anymore, could you please tell us some specific information of which part doesn't work anymore? Can't block'sponsored' on fb?

Not sure what you think this extension does, but it is not an ad blocker. When I say it doesn't work I mean that there is no sign that it is installed when I open a Facebook page, even though in Settings it shows as being installed and enabled. Here are 2 screenshots of my toolbar in 5.1.6.1000 and in 5.2.0.700 (the problem still exists in the latest internal and I don't have an installation of 5.1.6.3000 to make a screenshot of): The top one is 5.1.6.1000

 

MX5.1.6.1000toolbar.jpg

And this one is of 5.2.0.700.

MX5.2.0.700toolbar.jpg

Note on the top one that FBP is in the toolbar next to Home and that in the bottom picture it is not there. Also notice that the toolbars are different colors in each picture as I used FBP to change it in 5.1.6.1000, which indicates that nothing is working in the 5.2.0.700 installation, which is further obvious in the rest of the page in that none of the Facebook items I hide are hidden. Not sure what you are doing but from your questions, I don't get the idea the you know what this extension actually does, since blocking ads is not it's main function. Without that FBP in the toolbar, one can not access it's options page and it is obvious on my machine that it is not working at all, as though it is not even installed even though it shows as installed and enabled in Settings. Like I said, it still works properly in 5.1.6.1000 but does not work in 5.1.6.2000, 5.1.6.3000 and the newest internal 5.2.0.700. Let's let all of this sink in for now.

1 person likes this

Share this post


Link to post
Share on other sites

Can't confirm the FBP issue here. Seems to be working as expected.

Tested on my current install of 5.2.0.700 with userdata imported from previous version.

I'm guessing you've done the usual clean cache.

You can also try and remove the extension savedata in %appdata%\Maxthon5\Users\guest\addonsdata\{e4eda742-605a-4201-b785-e0e228400516}

MaxthonSnap20180225103047.png

1 person likes this

Share this post


Link to post
Share on other sites
On 2/24/2018 at 1:25 AM, rick.lane said:

Not sure what you think this extension does, but it is not an ad blocker. When I say it doesn't work I mean that there is no sign that it is installed when I open a Facebook page, even though in Settings it shows as being installed and enabled. Here are 2 screenshots of my toolbar in 5.1.6.1000 and in 5.2.0.700 (the problem still exists in the latest internal and I don't have an installation of 5.1.6.3000 to make a screenshot of): The top one is 5.1.6.1000

Tested on V5.2.0.700, it's working here, have you enabled this extension in Menu-settings-addons-enabled

2222.png

1 person likes this

Share this post


Link to post
Share on other sites
On 2/24/2018 at 4:42 PM, 7twenty said:

Can't confirm the FBP issue here. Seems to be working as expected.

Tested on my current install of 5.2.0.700 with userdata imported from previous version.

I'm guessing you've done the usual clean cache.

You can also try and remove the extension savedata in %appdata%\Maxthon5\Users\guest\addonsdata\{e4eda742-605a-4201-b785-e0e228400516}

Don't know what happened to my original response to your comment. I have now done all of the things you suggested, including uninstalling/reinstalling the various browser versions and the latest version of the FBP extension along with the config.ini file in the {e4eda742-605a-4201-b785-e0e228400516} folder. And I have found that FBP doesn't work properly in any version after 5.1.6.1000. That is on my main desktop machine, on my Windows 10 8" Dell tablet (with only 5.1.6.3000 installed as a result of the automatic update) as well as on my older Windows 7 machine again with 5.1.6.3000. What "doesn't work properly" is that on the home page, there is no icon in the toolbar or in the news feed to access the options page of the extension and no option changes are implemented. Newly discovered, I found that in all instances and machines, if I open another Facebook page from a link on my Homepage, the icon appears and I am able to access the options page and make option changes that are implemented on the newly opened Facebook page; but these changes are not implemented on the Home page. (This also occurs with the newest beta 5.2.0.900).

Now I realize from your screenshot, that it appears to be working for you with 5.2.0.700. I also seem to recall that you are using the portable version of Maxthon and all of my installations are of the install version. Is it possible that you and BugSir006 are using the portable version and that is possibly why you can not confirm what I am experiencing? I also saw another post (http://forum.maxthon.com/index.php?/topic/23222-extensions-does-not-work-after-5161000/#comment-122991) that also claims the same thing concerning FBP among other extensions not working, so it appears to not just be me. 

Having never used or even played with any portable versions, I can only throw that out as a possible reason that we have different results with this extension. And it still works just as it's supposed to in 5.1.6.1000.  Since this happens in 3 separate installations on 3 very different computers and operating systems, and after all of the investigating that I have done since this weekend, it sure doesn't appear that it is just a problem for me. And there have been reports from others of other extensions not working properly or not working at all; the Spotify problem has been reported in several instances, and they all may be related. I will be curious what you think about this  and maybe we can get closer to determining why this is happening. Thanks again for your efforts.

EDit: I just downloaded and opened Maxthon Portable 5.1.6.3000 and the same problem exists on my Facebook homepage; so much for that theory. Unrelated, it is curious that when I use a new version like this portable one, the spell check dictionary flags Maxthon, of all words, as not in the dictionary.

 

1 person likes this

Share this post


Link to post
Share on other sites

 Tested both on portable and install version 5.1.6.3000. The FBP will display on the bar normally. Strange:Flushed_Face_Emoji_42x42:

 

1 person likes this

Share this post


Link to post
Share on other sites

@Mo88 post on my pm:

I did a bit of testing, the issue only happens if l open Facebook from Quick Access. If l open Facebook by typing it in address bar then FB Paurity loads fine. If you can post in that conversation asking if the other people who have the same issue are loading it from QA.

---------------

I can reproduce this, does anyone get same situation?

2 people like this

Share this post


Link to post
Share on other sites
8 hours ago, BugSir006 said:

@Mo88 post on my pm:

I did a bit of testing, the issue only happens if l open Facebook from Quick Access. If l open Facebook by typing it in address bar then FB Paurity loads fine. If you can post in that conversation asking if the other people who have the same issue are loading it from QA.

---------------

I can reproduce this, does anyone get same situation?

Well I'l be da**ed. Following up on your discovery, I find that the FBP problem only exists when Facebook is opened from various QA tiles. If I open it from the Favorites bar, with the identical URL as the QA tile, the FBP extension performs as intended. I did my testing using 5.2.0.900. It also works fine if Facebook is opened from the side bar Favorites. Will test on other versions, but it appears that you may have stumbled upon the source of the problem. I never tried this as I do not regularly use the Favorites bar (keep it hidden) or the sidebar (also hidden) and always open Facebook from a tile in the upper row of tiles on QA. At least I know how to make it work now, but still hope that this can now be further looked into and hopefully solved. Thanks for keeping on this.

Edit: All holds true for 5.1.6.3000 in my case; hopefully others will find the same thing.

 

2 people like this

Share this post


Link to post
Share on other sites
On 3/2/2018 at 11:54 PM, rick.lane said:

Well I'l be da**ed. Following up on your discovery, I find that the FBP problem only exists when Facebook is opened from various QA tiles. If I open it from the Favorites bar, with the identical URL as the QA tile, the FBP extension performs as intended. I did my testing using 5.2.0.900. It also works fine if Facebook is opened from the side bar Favorites. Will test on other versions, but it appears that you may have stumbled upon the source of the problem. I never tried this as I do not regularly use the Favorites bar (keep it hidden) or the sidebar (also hidden) and always open Facebook from a tile in the upper row of tiles on QA. At least I know how to make it work now, but still hope that this can now be further looked into and hopefully solved. Thanks for keeping on this.

Edit: All holds true for 5.1.6.3000 in my case; hopefully others will find the same thing.

 

Sorry for bring you inconvenience this period of time(I know you done many tests on this)

This is related with new tab logic, and it's a known issue. I guess it will be fix in next version. Kindly wait for the new version. 

1 person likes this

Share this post


Link to post
Share on other sites