zzxxhhzxh

pc issue Can not load Google Photo

10 posts in this topic

Maxthon PC 5.1.5.2000

win10 1709 64bit

When click Google Photo from Gmail (Google Apps), the new page can not load correctly and the whole application will have no response. I have to close it from task manager. 

https://photos.google.com/

This link.

1 person likes this

Share this post


Link to post
Share on other sites

What mode are you using? You'll notice I am using ultra mode in my screen grab, otherwise, I am using the same version as you are and have no issue accessing Photos.

Edit: Just tried retro mode without issue too. Try turning off any addons to see if it helps.

 

ph2.png

Share this post


Link to post
Share on other sites

I am using ultra mode. I found that if I turn Adblock Plus off, the page is loaded normally. But when I use Adblock Plus, the browser will crash. Conflict?

Share this post


Link to post
Share on other sites
1 hour ago, zzxxhhzxh said:

But when I use Adblock Plus, the browser will crash. Conflict?

How many/what filter lists do you have enabled?

1 person likes this

Share this post


Link to post
Share on other sites

I have two, one is a default one and the other one is China plus something (also in the list). I'm using cellphone now. Crash each time.

1 person likes this

Share this post


Link to post
Share on other sites
4 hours ago, zzxxhhzxh said:

1. EasyList

2. EasyList China + EasyList

It seems like you have EasyList twice,  Try with just #2 active.  It may not help, but is an easy try.

                             <<SL>>

1 person likes this

Share this post


Link to post
Share on other sites

Like SnowLeopard said, try disabling both and see if it helps. Then enable them one by one to see if it starts happening again.

But you should only need the 2nd one.

1 person likes this

Share this post


Link to post
Share on other sites

If I only use 1. EasyList, the page is loaded normally.

If I use 2. EasyList China + EasyList, the browser is crash definitely...

So how to solve this? I need China list because so many ads are on Chinese pages.

1 person likes this

Share this post


Link to post
Share on other sites

You've got a few options:

1 / Disable ABP on that site only by unchecking the "block ads on this website" option.
Looking at the site there's no ads anyway, so I don't think that is an issue.

2 / Try and find the filter that's causing the crash and add an exception rule for it.
Open the "view blocked items" dialog, then open the site. Hopefully when it crashes the filter, or one of the filters that's causing the issue will show. You can then add an exception for it.

1 person likes this

Share this post


Link to post
Share on other sites