skidude

resolved Desktop internet shortcut not working in XP

11 posts in this topic

I have several desktop internet shortcuts which have the correct  URL entered.

Using MX4 as default browser these work by opening the browser or opening a new tab and then connecting to the URL address. 

However, on exactly the same machine, if I change default browsers to MX5 these same shortcuts do not work in M5.1.2.1000. The browser will open but a tab is not then created to go to the URL. If I right click the shortcut there is an option to use MX5 or Maxthon Cloud Browser and these will indeed open and go to the URL.

This happens when using XP and both browsers are portable only.

Ideas or workarounds anyone or is this a sign of vanishing XP support.

Share this post


Link to post
Share on other sites

So the browser gets focus but the page doesn't open in a tab?

Share this post


Link to post
Share on other sites
On 11/10/2017 at 5:08 AM, 7twenty said:

So the browser gets focus but the page doesn't open in a tab?

Precisely.

Yes that is another way of describing it.

Share this post


Link to post
Share on other sites

Seems this is a known issue, apparently fixed in the latest internal release.

Should be available soon.

Share this post


Link to post
Share on other sites
On 13/10/2017 at 6:17 AM, 7twenty said:

Seems this is a known issue, apparently fixed in the latest internal release.

Should be available soon.

Thanks for the update. I will look forward to the next release more than usual this time.

Update : Looks like this is now fixed in v5.1.3.200. 

Share this post


Link to post
Share on other sites
On 13/10/2017 at 6:17 AM, 7twenty said:

Seems this is a known issue, apparently fixed in the latest internal release.

Should be available soon.

Thanks for the update. I will look forward to the next release more than usual this time.

Update : Looks like this is now fixed in v5.1.3.200. 

 

 

2nd update 19/10/17 : Yes the above issue is fixed but now, using 5.1.3.200 , each time I open MX5 the url for my desktop internet shortcut opens as if it was a home page. I have chosen in Settings to open at last session  and this does open as well but the first tab to open is the desktop shortcut. 

I had a look round and discovered in config.ini under LastTabs the offending url. Deleting this did not prevent it being opened again at the next browser startup.

Now, I have two internet shortcuts on the desktop and opening the other one does not make it act like a home page as well. So it looks like MX5 has decided to select the first one I opened and make this a permanent additional homepage. 

Edited by skidude

Share this post


Link to post
Share on other sites

What's the url on your desktop shortcut?

If the shortcut has a link to a particular site then it makes sense why MX is opening that site.

What happens if you open Maxthon directly from the  .exe file in the installed folder?

Share this post


Link to post
Share on other sites
On 19/10/2017 at 10:50 AM, 7twenty said:

What's the url on your desktop shortcut?

If the shortcut has a link to a particular site then it makes sense why MX is opening that site.

What happens if you open Maxthon directly from the  .exe file in the installed folder?

Knowing the URL will not affect this problem as MX5 opens now with a home page of the desktop shortcut without my clicking on the shortcut. It also opens with the last session, two tabs in all at startup. All that is set in settings at startup is last session. The desktop url: http://www.larousse.fr/dictionnaires/francais-anglais/  seems stuck to continually open with the browser not the shortcut, although it will open as well when the shortcut is clicked.

This behaviour is wrong, and I have reverted to an earlier version for the moment. This is one for the devs I think to fix. Unless someone knows which ini file is forcing this extra tab to open.

Share this post


Link to post
Share on other sites
5 hours ago, skidude said:

Knowing the URL will not affect this problem

Sorry, meant the target to the file as shown in the properties dialog.

MaxthonSnap20171021034747.png

Share this post


Link to post
Share on other sites

That's it ! The Target to open MX5 was the path to the maxthon.exe with the offending url added on. When removed normal behaviour is resumed and browser opens as expected so thanks for the helpful diagnosis. I am not at all sure how it got there though.

Actually that is a smart way of having a home page of choice as well as the Last Session list. 

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, skidude said:

I am not at all sure how it got there though.

Only thing i can think of is that at some stage you created a desktop shortcut from the tab context menu (send to > desktop shortcut).

Good to see that it's fixed for you now.

Share this post


Link to post
Share on other sites