Archived

This topic is now archived and is closed to further replies.

17167647

resolved Maxthon vs Chrome

4 posts in this topic

No issue here.

Make sure you're not in Retro mode.

Make sure you're using the default User agent in settings > advanced (customise box should be unchecked)

Share this post


Link to post
Share on other sites