Sign in to follow this  
Followers 0
ArielOjosVerdes

resolved Certificates not working? SiteDisable error

7 posts in this topic

Hi,

A long time ago I noticed that server certificates are not working properly or, at least, can´t be verified successfully.
Whenever I access an HTTPS site, instead of seeing a closed grey or green lock indicator on the address bar, I see a Brown indicator with the message "SiteDisableMessage" and it is impossible to chech  the certificate´s atributes.

I am having this issue since I upgraded to Maxthon 5 and I am up to date using version 5.1.1.200 and stiill I see the same behaviour,

Is there anything wrong?

Regards,

Ariel

 

1 person likes this

Share this post


Link to post
Share on other sites
6 hours ago, ArielOjosVerdes said:

I see a Brown indicator with the message "SiteDisableMessage" and it is impossible to chech  the certificate´s atributes.

You've disabled the secure URL scan in settings > Privacy & Content.

Enable that and you should get a green padlock with the option to view the certificate.

The error you noted "SiteDisableMessage" seems to be a placeholder that hasn't had it's text string updated.

Share this post


Link to post
Share on other sites

Posted (edited)

Thank you 7twenty. That was it. I use to disable that feature as it seems to mean that the browser send the URLs I access to Maxthon, and I want to avoid that, Even more annoying and worrisome is that when that feature is disabled there is no option given to see the site´s certificate. Shoud I post a bug report about that second issue?

Edited by ArielOjosVerdes

Share this post


Link to post
Share on other sites
11 hours ago, ArielOjosVerdes said:

I use to disable that feature as it seems to mean that the browser send the URLs I access to Maxthon,

I'm not 100% certain, but looking at some of the Maxthon files, i'm pretty sure the security check is done locally against a list of urls provided by the Chinese company knet (http://knet.cn).

As to why they don't allow you to check the sites certificate when you disable that feature, i'm not sure. Make a post and hopefully you'll get answer or they'll fix it and add that option even with the security check disabled.

Share this post


Link to post
Share on other sites

Hi maxthon team !

I got this issue about 2 weeks, I am trying to solve by myself and for me it's impossible.
Someone please that tell me to solve this?

best regards

issue.png

error.png

Share this post


Link to post
Share on other sites
42 minutes ago, IceHouse said:

I got this issue about 2 weeks, I am trying to solve by myself and for me it's impossible.
Someone please that tell me to solve this?

Merged thread.

See post #3 for answer

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0