Mo88

pc issue 5.1.0.1900 Keeps Changing Default pdf Reader

10 posts in this topic

Posted (edited)

I use Adobe Acrobat as my default program for pdf's, but everytime I open Maxthon, it changes the default pdf reader to Maxthon. I change it back to Acrobat and it changes to Maxthon again. I am on Windows 8.1 with Maxthon set as my default browser if that helps

Edited by Mo88

Share this post


Link to post
Share on other sites

try this

or uncheck checkbox with default browser in browser setings (mx5 remains the default browser) and set adobe as default program for pdf's

Share this post


Link to post
Share on other sites

you mean you have PDF files on your computer and you've set the file association with acrobat?

( right click on a pdf file property and open with to check)

if you mean, when you got a file on the web and maxthon will open the pdf that's because it's built-in reader

i guess there is an icon of acrobat on the toolbar to  set adobe reader as default reader ( but i ain't got Acrobat since years )

Share this post


Link to post
Share on other sites

Posted (edited)

47 minutes ago, No.1MaxthonFan said:

Get into your "Default Programs" scroll down and click on "Choose default programs by file type" and then scroll down to the PDF and change it there.

I am on Win10 and use Foxit Reader and have set it as the default for many years. And in the Default Programs window as well. And when I click on a pdf file in say File Explorer or in an email, Foxit opens and displays it. But when I click on a PDF file in a browser window, say at a financial site for a statement download, it opens in the browser using the Maxthon reader. (And this has been the norm for quite a while now for me.) So, at least for me, setting my reader to be the default makes no difference in how pdf's are displayed in the Maxthon Browser and I haven't yet been able to find a setting to make it happen as I desire in either Foxit Reader or in Maxthon. Just adding my experience to this conversation. Personally, from what I read in the OP's query, he has the same problem that I experience as he has Acrobat Reader already set as his default reader for Pdf's but it doesn't work in Maxthon (though I'm not sure if he is using Adobe Acrobat or just the Acrobat Reader, which used to be called Adobe Acrobat Reader and many people still make that mistake).

 

Edited by rick.lane

Share this post


Link to post
Share on other sites
57 minutes ago, rick.lane said:

I am on Win10 and use Foxit Reader and have set it as the default for many years. And in the Default Programs window as well. And when I click on a pdf file in say File Explorer or in an email, Foxit opens and displays it. But when I click on a PDF file in a browser window, say at a financial site for a statement download, it opens in the browser using the Maxthon reader. (And this has been the norm for quite a while now for me.)

That's how things should and have worked up till now. Since .1900 they've decided to make Maxthon a media viewer, with PDF one of the filetypes. There is/was? a bug where on running MX it would associate all the supported media types with MX. Obviously all users may not want this to happen, and this is the issue the OP is having.

At this stage I don't believe there's a fix. Reverting to the previous release would be my suggestion until it's fixed.

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, 7twenty said:

That's how things should and have worked up till now. Since .1900 they've decided to make Maxthon a media viewer, with PDF one of the filetypes. 

 

I guess I wasn't that clear on this issue, which has been happening for me with the Foxit reader for way further back that 1900 and is not related to the new Maxthon media viewer feature/bug, which I have had to deal with after a few installs. However, I didn't make enough note of this issue when I first noticed it so that I have no memory of with which release it started for me, but it still occurs with several of my billing sites when I attempt to download a billing statement. The option to integrate Foxit with Maxthon either in Foxit or Maxthon used to exist but I can't find any such option any longer in either program. I seem to recall that there was an option in Adobe Reader, Adobe Acrobat Reader or whatever it is being called today, to integrate it with your browser, but I no longer have that installed so I can't check to see where that might have been.

Edited by rick.lane

Share this post


Link to post
Share on other sites

Posted (edited)

Sorry I wasn't clear on my issue so I made a video showing exactly what I mean. This issue is only on pdf's but doesn't affect my videos or other media types like other's are reporting.

pdf1.avi

Edited by 7twenty
I've compressed the video. I don't think most users would bother with downloading 150mb just for a 30sec video.

Share this post


Link to post
Share on other sites
6 hours ago, rick.lane said:

The option to integrate Foxit with Maxthon either in Foxit or Maxthon used to exist but I can't find any such option any longer in either program

You used to be able to delete the pdf.dll file from maxthon which would ensure that any default application to open pdf's would open them. They seem to have removed the file and made it a native feature. Not sure how to work around that now unless a pdf reader can read the links from the browser?

 

6 hours ago, Mo88 said:

This issue is only on pdf's

In Settings > Advanced > Default file types, make sure none of the boxes are checked.

But as I said above, there seems to be a bug where this version of MX doesn't respect the default associations and creates them even if they're not set. Hopefully will be fixed shortly.

Share this post


Link to post
Share on other sites

Posted (edited)

I don't see pdf as an option.

EDIT: The newest version, 5.1.0.2200 fixed the issue

MaxthonSnap20170712142653.png

Edited by Mo88

Share this post


Link to post
Share on other sites
1 hour ago, Mo88 said:

I don't see pdf as an option

 

It's coming...in a future release, probably what 7twenty is using.

pdf.png

Share this post


Link to post
Share on other sites