Archived

This topic is now archived and is closed to further replies.

zzxxhhzxh

resolved Maxthon 5 responds slowly in Google Inbox

6 posts in this topic

All the versions of Maxthon 5 responds slowly in Google Inbox (inbox.google.com/), it can show the page, but be really slow when you click any mail, even no response. I hvae to open a new page, sometimes it becomes normal, sometimes still doesn't work.

Share this post


Link to post
Share on other sites

Hi there, thanks for the reporting and I tried the site you mentioned in the same network with Chrome and Maxthon5 (version 5.0.4.1000). No obvious lag for the site, I experience almost the same speed on both browsers. 

Does the lag happen every time on your side? If so, could you provide some detailed info like your internet provider, your computer OS, and the seconds it lags? 

From our preliminary investigation, it should be related to the network. So we recommend you to try some more.

Share this post


Link to post
Share on other sites

I use the internet by NewWave Communications in U.S. The system is Win 10 1703 64bit, it is not a kind of lag, it just doesn't respond. I can open the web site and log in. But when I click a mail for conversation, it doesn't respond, and then I click another one, almost everything is frozen. I can see the browser is trying to load the mail, but nothing will make progress. Then the only way is to open a new page for it. Will it be related to some javascript or ActiveX?

1 person likes this

Share this post


Link to post
Share on other sites

Hi zzxxhhzxh, sorry that I misunderstood your question. 

Thanks for the further explanation, I tried it again using version 5.0.4.1000, open a mail, and try to reply, pin, or delete it, all works fast.

May I ask which version are you using? Would you like to give a try to the new version? It's available through clicking the banner upper ahead.

Share this post


Link to post
Share on other sites

This time I used the latest version (5.0.4.1000), it seems to be much better. It can respond almost every time I click it.

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, zzxxhhzxh said:

This time I used the latest version (5.0.4.1000), it seems to be much better. It can respond almost every time I click it.

Cool!

Share this post


Link to post
Share on other sites