Galileusz

WebRTC IP leak again

3 posts in this topic

@BugSir006 About eight months ago I wrote about problems with WebRTC IP leak. And so it looks today:

                             Notatka20170421004213.png

Unfortunately, this has not been fixed yet. It is a pity because in this case Maxthon 5 is not suitable for safe use. I currently use version 4.4.8.2000 which does not have this problem. But since this version is no longer being developed, I will probably have to look for another alternative than Maxthon.

Share this post


Link to post
Share on other sites

Hi Mr.G, I searched the topic of WebRTC IP leak on the internet again, and most media said it's a loophole on webRTC around two year ago, and it affects chromium based browsers under windows system. So maybe the most effective method to solve this problem maybe for WebRTC to fix it.

You can try this site (https://ipleak.net/) on your different browsers to see if it shows your IP address. I'm using a VPN, and it shows my real IP on Chrome, MX4 and MX5.

And you can solve it by installing this extension: https://chrome.google.com/webstore/detail/scriptsafe/oiigbmnaadbkfbmpbfijlflahbdbdgdf?hl=en

So the problem now is that maybe Maxthon needs an extension like this. How about we contacting the builder of this extension and ask that if he/she could build one for MX as well? I believe you can find his contact info here: https://www.andryou.com/

I'll also let our PM know this, and assess the severe level of it.

Share this post


Link to post
Share on other sites

Posted (edited)

On Friday, April 21, 2017 at 4:14 AM, BugSir006 said:

Hi Mr.G, I searched the topic of WebRTC IP leak on the internet again, and most media said it's a loophole on webRTC around two year ago, and it affects chromium based browsers under windows system. So maybe the most effective method to solve this problem maybe for WebRTC to fix it.

@BugSir006  I know that this loophole exists for a long time but in most browsers it can be remedied. In Maxthon, there is unfortunately no option to disable WebRTC, nor there is no an extension to remedy it.

Quote

You can try this site (https://ipleak.net/) on your different browsers to see if it shows your IP address. I'm using a VPN, and it shows my real IP on Chrome, MX4 and MX5.

Yes, I did a test on different browsers using at the same time NordVPN. Here are the results:

Maxthon 5 Maxthon 5.png

 

Maxthon 4 Maxthon 4.png

 

Comodo Dragon & ScriptSafe Dragon & ScriptSafe.png

 

FireFox with Disable WebRTC option  FireFox with Disable WebRTC option.png

 

FireFox without plugins FireFox without plugins.png

 

Cent Browser, UnGoogled Chromium, CyberFox, Vivaldi, K-Meleon and SlimJet without plugins !!! Cent Browser & UnGoogled Chromium without plugins.png

Quote

And you can solve it by installing this extension: https://chrome.google.com/webstore/detail/scriptsafe/oiigbmnaadbkfbmpbfijlflahbdbdgdf?hl=en

:titter: Namely, how would I install this extension in Maxthon?

Quote

So the problem now is that maybe Maxthon needs an extension like this. How about we contacting the builder of this extension and ask that if he/she could build one for MX as well? I believe you can find his contact info here: https://www.andryou.com/

Yes, Maxthon needs an extension with similar action. The scriptsafe you suggested I translated into Polish and I sent to Andrew. In my email, I have sent also a question, whether it possible to adapt the ScriptSafe for Maxthon browser. If I get an answer then I will write you about it.

Quote

I'll also let our PM know this, and assess the severe level of it.

This is too serious a matter to neglect this.

Edited by Galileusz

Share this post


Link to post
Share on other sites