Archived

This topic is now archived and is closed to further replies.

MAXSHARK

confirmed Disable multi-search

23 posts in this topic

Hello guys,

Event I don't have multi-search in search enginge settings,when I paste some phrases in address bar and go,it opens multi-seach.

In previous releases it searched in default search engine in the settings.Now it automatically searches in mult-search.How to delete or disable muti-search?I'd like it to use plain google.

Version: V5.0.3.2000

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, MAXSHARK said:

Hello guys,

Event I don't have multi-search in search enginge settings,when I paste some phrases in address bar and go,it opens multi-seach.

In previous releases it searched in default search engine in the settings.Now it automatically searches in mult-search.How to delete or disable muti-search?I'd like it to use plain google.

Version: V5.0.3.2000

 

Zrzut ekranu20170403213456.png

Share this post


Link to post
Share on other sites
15 minutes ago, john doe said:

 

Zrzut ekranu20170403213456.png

Thank you john.But as I wrote in my first email,there is only google in my settings.Maxthon has an internal multi-search and it uses that I guess.Here is my settings:

msearch.jpg

Share this post


Link to post
Share on other sites
49 minutes ago, MAXSHARK said:

.Maxthon has an internal multi-search and it uses that I guess

It doesn't.

A long time ago I (and others I think) had an issue where you might do a search from the address bar and instead of MX using your default it would use Google instead. That hasn't happened for a long time. Seems to be a similar issue.

I'd reset the search options (reset to default button) and see if that helps. Thankfully you've only got one to add back so shouldn't be too much of an issue to get back your old settings.

1 person likes this

Share this post


Link to post
Share on other sites

Hello, the problem with 5.0.3.2000 search engine management may be somewhat broader than indicated above.

I've been using almost 20 custom search engines and all the prefixes I have defined for them (e.g., "gmap" for Google Maps search, "yt" for Youtube search, etc.) work correctly when invoked from the Quick Access page. However when invoking any of the custom search engines from the address bar, the search prefix (e.g. "gmap") is not properly interpreted and instead of waiting for me to input the text I'm looking for (e.g. "London"), the page hosting the search engine (e.g. Google Maps) is launched immediately and the "London" string is looked for using my default search engine (Google) instead.

Share this post


Link to post
Share on other sites
5 hours ago, phoenix-76 said:

However when invoking any of the custom search engines from the address bar, the search prefix (e.g. "gmap") is not properly interpreted and instead of waiting for me to input the text I'm looking for (e.g. "London"), the page hosting the search engine (e.g. Google Maps) is launched immediately and the "London" string is looked for using my default search engine (Google) instead.

Sounds like you've set them up as URL aliases and not search aliases. In my testing adding a correct Search URL into URL aliases will not perform a search and will instead send the full text entered to the default search.

I can't understand how the search prefix page opens without you actually pressing enter though? Only reason would be that you think that you're supposed to press enter after the search prefix and then enter again after the search term. That's wrong. The prefix and the term need to go together eg. gmap London [enter]

After pressing space after the search prefix you should notice the left of address bar then change to show what search is being used. If it doesn't then it's not detecting the search alias, and as above will search via the default search which should also be shown in the address bar.

Share this post


Link to post
Share on other sites
1 hour ago, 7twenty said:

Sounds like you've set them up as URL aliases and not search aliases.

Despite my Freshman status on this forum I've been using customizable search engine definitions since the ancient My IE2 times (this feature is actually the main reason I've stayed with Maxthon for all these years) and I've registered this problem only with the recent 5.0.3.2000 release, never before as far as I can remember. It was also my first thought to doublecheck whether there were some predefined URL aliases embedded into 5.0.3.2000 that could collide with my own search engine prefixes, but no, there were none. I even temporarily disabled URL alias functionality completely but the issue persisted. To me it's a bug.

I would like to highlight that all my custom search engine prefixes work correctly when used within Quick Access search box. The problem can only be reproduced when entering the search prefix into the address bar.

As for the procedure of entering the search prefix and the searched value, I of course follow the correct steps: 1. enter the search prefix ("gmap"), 2. press space -> the Google Maps search engine choice gets indicated on the left side of the address bar, 3. enter the searched string (e.g. "London"), 4 press Enter. The problem is that at the moment I press space at step 2, MX5 does not wait for me to enter the "London" string but launches maps.google.com page on its own. At that point the Google Maps search engine indication is still present on the left side of the address bar, however when I finally enter the searched "London" string, it's looked up using my default search engine instead.

Following is the Google Maps search string I've been using with the "gmap" prefix which I used for the aforementioned example: https://maps.google.com/maps?q=%us. The problem however impacts my other search engine definitions as well.

Share this post


Link to post
Share on other sites

Well at least we've cleared up that you aren't doing something odd to use them.

13 minutes ago, phoenix-76 said:

The problem is that at the moment I press space at step 2, MX5 does not wait for me to enter the "London" string but launches maps.google.com page on its own

This still makes no sense though. No reason why it should be doing that unless it's mistaking the space for enter.

10 minutes ago, phoenix-76 said:

To me it's a bug.

A bug on your system sure, but it's hard to define as a bug if it can't be replicated.

Try with MX portable and see if the same happens. If not then it's your userdata. I'm going to guess it's going to work properly.

10 minutes ago, phoenix-76 said:

prefixes work correctly when used within Quick Access search box. The problem can only be reproduced when entering the search prefix into the address bar.

If i'm not mistaken it's the same search box. Only difference is where the box is.

Share this post


Link to post
Share on other sites
9 minutes ago, 7twenty said:

Try with MX portable and see if the same happens.

Have duplicated the problem with MX portable right now! Perhaps the only hint I can give on reproducing the problem is to enter the search alias/prefix within the previously used tab - i.e. launch a random page, then re-write the URL in the address bar with custom search alias and see what happens. Repeat several times if necessary, I'm able to reproduce the problem consistently this way.

Share this post


Link to post
Share on other sites
1 minute ago, phoenix-76 said:

Have duplicated the problem with MX portable right now! 

Guest account or passport?

Share this post


Link to post
Share on other sites
7 minutes ago, 7twenty said:

Guest account or passport?

Passport account.

Share this post


Link to post
Share on other sites
4 minutes ago, phoenix-76 said:

Perhaps the only hint I can give on reproducing the problem is to enter the search alias/prefix within the previously used tab - i.e. launch a random page, then re-write the URL in the address bar with custom search alias and see what happens. Repeat several times if necessary, I'm able to reproduce the problem consistently this way.

I couldn't quite understand what you're describing, but this is what i did:

New search alias https://maps.google.com/maps?q=%us added to Settings > General > Search Engine Management. Alias = gmap

While on this forum page:

ALT+D (to focus address bar)
typed gmap london [enter]
ALT+D (to focus address bar)
typed gmap london [enter]

Done the above at least 10 times at various times after changing tabs, going to other programs, and at least 5 times in a row.

Every single time google maps opened showing London as the search term.

 

Just now, phoenix-76 said:

Passport account.

And there's your problem... userdata related.

Try with guest to confirm.

Share this post


Link to post
Share on other sites
2 hours ago, 7twenty said:

And there's your problem... userdata related.

What does that imply? That my userdata got somehow messed up with installation of 5.0.3.2000? I take it it's still Maxthon problem, making me the affected side, not the side causing the problem. Btw. I've just replicated the problem scenario on yet another computer with different OS. I will give it a try with the Guest account later.

Edit: I've just duplicated the same behavior with Guest account using the predefined Google and Amazon search strings which I only additionally assigned with "g" and "am" aliases. Could using more than one search alias at a time could be the culprit then?

Share this post


Link to post
Share on other sites
6 hours ago, phoenix-76 said:

What does that imply? That my userdata got somehow messed up with installation of 5.0.3.2000?

yes. Very odd that you're getting it on a portable version using guest. I can't replicate it no matter how i try. I even went through all of my search aliases one by one after each other. Every single one opened the correct site using the correct search term.

Or we're talking about completely different things.

Share this post


Link to post
Share on other sites

Hi 7twenty, thanks for all your attempts to replicate the problem.

I ran series of additional tests tonight and finally pinpointed first occurence of the problem to 5.0.3.1200! Unless there was some dev version released for internal purposes between 5.0.3.900 and 5.0.3.1200, the latter one is the cause of the problem which destroyed search alias functionality (for me at least).

Regarding the test I took, I downgraded my MX5 installation version by version until I found that with 5.0.3.900 (and below) the issue could no longer be replicated. I then upgraded back to the recent version to duplicate the problem and downgraded again to doublecheck 5.0.3.900 fixed the issue for me.

The full down/upgrade path of my test: 5.0.3.2000 (issue replicated) -> 5.0.3.1400 (issue replicated) -> 5.0.3.1200 (issue replicated) -> 5.0.3.900 (worked OK) -> 5.0.2.2000 (worked OK) -> 5.0.3.2000 (issue replicated) -> 5.0.3.900 (worked OK) -> 5.0.3.2000 (issue replicated).

1 person likes this

Share this post


Link to post
Share on other sites

Well that is quite interesting. Still makes no sense though.

The issue seems to stem from MX thinking that ENTER has been pressed after the alias is entered. And I can't figure out why that would be the case unless you're using some keyboard management software or otherwise which is getting in the way.

Any chance you can zip up the portable version that you tested with and post a link to it? I'd be curious to see if the same happens on my end using a version that is known to have the issue.

Share this post


Link to post
Share on other sites
6 hours ago, 7twenty said:

zip up the portable version that you tested with and post a link to it

Hi 7twenty, I sent you a personal message with a download link.

Edit: And to your keyboard management note, I've been using no such software, just two regular OS keyboard localizations - English (US) and Czech (CS).

keyboard_loc.jpg

Share this post


Link to post
Share on other sites

It seems I narrowed the problem down even more - the problem seems to be linked to 5.0.3.1200 function optimization described as Separate “search box” in the official Change Log. I don't even use the search box feature, so it took me a while to notice that the messed up search alias behavior is somehow linked to this GUI item. Here's the scenario I went through:

  1. Alt+D to focus the address bar.
  2. Typed "London" and pressed Enter to look it up using the default search engine (Google in my case). I noticed that the Search Box remembered the "London" string and kept it displayed even after the Google search had been completed and its results displayed. (No idea if that's intended behavior or not since I cannot figure out any use case supporting existence of a separate search box these days.)
  3. Alt+D.
  4. Typed "gmap" to invoke my Google Maps search alias.
  5. Pressed "space". At this point the Google Maps page loaded and zoomed to my surprise to... London :-)

The test above also explains why the first search attempt using any search alias has always worked for me. The search box cache (or other temporary storage of the searched data) apparently needs to be fed with some value first in order to make the collision with consecutive searches apparent. I would really very much appreciate if this could be looked into by the dev team since all my findings point to a bug in processing logic of the address bar and search box.

2 people like this

Share this post


Link to post
Share on other sites
14 hours ago, phoenix-76 said:

Alt+D to focus the address bar.

the first step is performed on the quick access page? Could you please record a short gif to us? I'll forward the gif to our technicians.

Share this post


Link to post
Share on other sites

Hello BugSir006 / 7twenty,

Attached is the requested gif. It really does not matter if you perform the first step in the QA page or in the address bar. As long as the search box is not fed with some value at that time, the first search attempt will work OK. I'm glad to inform you that 7twenty finally succeeded to replicate my findings, so hopefully this nasty bug can be quickly fixed.

Following is the step-by-step description of the gif content:

  1. Notice the maxthon forum page opened on the first tab. Something strange will happen to it later in step 9.
  2. Press Ctrl+N to open another tab.
  3. Type in the text string you want to look ("London") and press Enter. The text will be looked up using the default search engine (Google in this example).
  4. Alt+D to focus the address bar. Type in the search alias string (gmap for Google Maps in this example) and press Space. You can see MX5 immediately launches maps.google.com page with "London" (!!!) as the searched string.
  5. Alt+D. Press Backspace to revert the choice of the search engine (this will fall back to default Google search).
  6. Alt+D to select the existing URL. Type in another search alias string (map for Mapy.cz in this example) and press Space. You can see MX5 immediately launches mapy.cz page with "London" (!!!) as the searched string.
  7. Alt+D. Press Backspace to revert the choice of the search engine (this will fall back to default Google search).
  8. Alt+D to select the existing URL. Type in another search alias string (g for Google.cz in this example) and press Space. You can see MX5 immediately launches google.cz page with "London" (!!!) as the searched string.
  9. Close the active tab and see what happens. The previously intact maxthon forum page is replaced with google search results of the previously searched string "London".

Please note I deliberately used one search string ("London") across all the steps to illustrate the role the broken search box plays in this case. Should you however pick different search string every time, the user experience will get messed up even significantly more.

MX5_search_box_bug.gif

1 person likes this

Share this post


Link to post
Share on other sites

Many thanks to the details and gif picture, they are very clear and easy to understand! 

I'll explain to our tester and developer of these reproduce procedures! I'll take them as two bugs while related. 

 

1 person likes this

Share this post


Link to post
Share on other sites
On 10. 4. 2017 at 2:10 PM, phoenix-76 said:

I narrowed the problem down even more - the problem seems to be linked to 5.0.3.1200 function optimization described as Separate “search box”

 

On 12. 4. 2017 at 8:28 AM, BugSir006 said:

I'll explain to our tester and developer of these reproduce procedures! I'll take them as two bugs while related. 

Hello BugSir006, any update on this persisting issue, please? I've just replicated it with the most recent 5.0.4.800 release.

Share this post


Link to post
Share on other sites
On 5/9/2017 at 5:02 PM, phoenix-76 said:

Hello BugSir006, any update on this persisting issue, please? I've just replicated it with the most recent 5.0.4.800 release.

Hi phoenix-76, sorry for my late reply. This bug has been ranked as level 3, so we may have to wait a little bit longer for the developers to run down the list to this one.

But please don't worry, they will fix it definitely, just because it won't affect much on user experience, so it's placed a little behind on the list.

We really thanks for your patience. 

Share this post


Link to post
Share on other sites