Archived

This topic is now archived and is closed to further replies.

vedicaudio

resolved Printing not possible with certain privacy settings

4 posts in this topic

In case anyone is curious about what this check box will do:

plugin.png

It will break the printing function, as well as many other functions, including uploading a file on Maxthon's own bug report page. And when I say "break", I mean that you cannot get a print preview, and when you try to print with the system dialog, the tab will hang, and you must close the tab. So don't uncheck that box if you want Maxthon to be useable. The way it is worded, you would think Maxthon would ask you on a per-site basis if you want to allow a plug-in. But no, it just stops all plugins from running on all sites. It should be renamed "Block all plugins on all websites."

print broke.png

1 person likes this

Share this post


Link to post
Share on other sites
10 hours ago, vedicaudio said:

The way it is worded, you would think Maxthon would ask you on a per-site basis if you want to allow a plug-in

I've never taken that setting to be as you described. I've always understood it to mean if unchecked no plugins are available to any sites. i.e. all disabled.

Although the "print using system dialog" should then work and not cause the tab to crash. Definitely needs to be fixed.

1 person likes this

Share this post


Link to post
Share on other sites

@7twenty, this seems to be a pattern, where our intepretations differ on what an English phrase used in Maxthon means. I think we would agree though that the best phrase for a particular use though is the one which leaves no ambiguity in its intended meaning. So there is definitely room for improvement in the English translations for Maxthon options.

1 person likes this

Share this post


Link to post
Share on other sites
16 hours ago, vedicaudio said:

So there is definitely room for improvement in the English translations for Maxthon options.

You are soooo welcome to join in our translation volunteer team!

 

As for the issue you reported, if plug-in not enabled, then the preview cannot be shown due to the PDF plug-in cannot be activated.

Share this post


Link to post
Share on other sites