Archived

This topic is now archived and is closed to further replies.

BugSir006

announcement MX5 Beta Release 5.0.2.1400

71 posts in this topic

 have done now an realy extremely clean deinstall and now I begin without any bookmarks, and now I test my beloved Super-Browser "On heart and kidney", as we say in german. I'm not someone who gives up quickly, had only one night sleep over it ;)))))

NO, does not work, if I click "copy" nothing happens. And "the right steps" :I've been around since the first version, I know the right steps. With "mx5.0.2.1000" it works but also. So, it's only for snapshots.

Share this post


Link to post
Share on other sites

Hi Chantao ,

Same problem for me , so confirmed , What is your OS ?

 

 

Share this post


Link to post
Share on other sites
20 hours ago, 7twenty said:

Something wrong there. I've been testing each MX5 version and they all import my old MX4 data correctly (except for skynote on the past few). But all the settings data happily gets transferred between each.

No doubt will help with compatibility. But there is no issue with drag'n'drop. Chances are that the issue will still occur as it's not related to blink seeing as it's not common issue.

Maxthon will never be on the bleeding edge of the latest blink release due to the fact it's not a chrome clone. But as they've said, they should be able to keep it closer to current than what it has been in the past.

Maybe you used an account which hold some of the settings, but even if you do, it doesn't restore a lot of them. For example quick-dial tiles. Not to mention many settings that don't exist yet, and they are probably lost forever.

About drag&drop, there is no reason it won't work, while on Chrome it does. As I've written, I even disabled all plugins and it still didn't work, while on the PC at home it does work.

About "bleeding edge", version 55 is the latest stable version, and it was out a month ago ( 2016-12-01) : https://en.wikipedia.org/wiki/Google_Chrome_version_history .
The "bleeding edge" version is 57...

Share this post


Link to post
Share on other sites
On 19/1/2017 at 0:36 AM, Chantao said:

This one please look picture. Once you have selected the area, it is immediately saved without selecting the folder. You probably have to specify the folder first, then select the area earlier, the reverse was also.

Can't confirm. Works as intended here. 

Select the bee icon, snapshot, select area, copy, select folder, add.

Share this post


Link to post
Share on other sites
5 hours ago, AndroidDeveloperLB said:

About drag&drop, there is no reason it won't work, while on Chrome it does. As I've written, I even disabled all plugins and it still didn't work, while on the PC at home it does work.

Have explained this in another thread. But Maxthon is not Chrome. What that does show is that it's not a system issue, but MX related. See other thread for details.

5 hours ago, AndroidDeveloperLB said:

About "bleeding edge", version 55 is the latest stable version, and it was out a month ago ( 2016-12-01) : https://en.wikipedia.org/wiki/Google_Chrome_version_history .
The "bleeding edge" version is 57...

So by the time v55 gets added to MX5 it will be about 3-4 months old. Not too bad considering how behind they've been in the past.

But as of now we're still on v47 which is about 13 months old. And when v55 is implemented who knows how long until the next Blink update? But they're definitely keeping their word in updating the core more frequently than in the past.

My point still stands, MX will always be behind compared to other Chrome clone browsers. But that's one of the trade-offs you make by using it for what ever other features you prefer in it.

5 hours ago, AndroidDeveloperLB said:

Maybe you used an account which hold some of the settings, but even if you do, it doesn't restore a lot of them. For example quick-dial tiles. Not to mention many settings that don't exist yet, and they are probably lost forever.

The update from MX4 > MX5 can be a little bumpy at times, but from what I can tell there isn't anything that doesn't get imported, at least in my cursory checks.

Just checked adding a QA tile to MX4, then opened MX5 and it was there. Only difference was that it was added to a "featured 1" group instead of on the main page. But that's probably due to the way the new QA works. It's quite simple to move it out to the main page if required. And once setup there shouldn't be any need to play around with it anymore if MX5 is your main browser.

Share this post


Link to post
Share on other sites
15 hours ago, Polaurent said:

Hi Chantao ,

Same problem for me , so confirmed , What is your OS ?

Windows 7

+++++++++++++++++++++

Now the MX5 is cumbersome, for example, as the MX4 affects what sort of bookmarks concerned. The MX5 works like Opera before it became a Chrome as a base in many ways. The only new feature is Maxnote with its 5-way selection. But if it does not work properly, then you can continue to use the latest version of MX4, because the old version of MX is also far better than any other browser. Screenshots can also be stored on the Harddsik. It is also better, because with every CleanInstall of MX5 the screenshots are away anyway.

On the other hand, there are so many versions of MX5. I use the official version, because I just got used to MX5. And MXnote is what it is to make some notes. Notes are quickly created things, which are then further processed, if you have time, so even if I want to save on harddisk, then I need the notes no longer. That is how it is conceived.

Share this post


Link to post
Share on other sites
17 hours ago, 7twenty said:

Have explained this in another thread. But Maxthon is not Chrome. What that does show is that it's not a system issue, but MX related. See other thread for details.

So by the time v55 gets added to MX5 it will be about 3-4 months old. Not too bad considering how behind they've been in the past.

But as of now we're still on v47 which is about 13 months old. And when v55 is implemented who knows how long until the next Blink update? But they're definitely keeping their word in updating the core more frequently than in the past.

My point still stands, MX will always be behind compared to other Chrome clone browsers. But that's one of the trade-offs you make by using it for what ever other features you prefer in it.

The update from MX4 > MX5 can be a little bumpy at times, but from what I can tell there isn't anything that doesn't get imported, at least in my cursory checks.

Just checked adding a QA tile to MX4, then opened MX5 and it was there. Only difference was that it was added to a "featured 1" group instead of on the main page. But that's probably due to the way the new QA works. It's quite simple to move it out to the main page if required. And once setup there shouldn't be any need to play around with it anymore if MX5 is your main browser.

The quick-dial did not sync with anything of MX4 for me. Same goes to a lot of other settings, mainly the magic fill.
Not even the favorites.

Speaking of favorites, I can't find out how to add a customized one to there.
For example, I want to have this script as a favorite (it allows to perform google-image-search on images) :
 

javascript:void((function(){var sir=document.createElement('script');sir.setAttribute('src','http://cdnjs.cloudflare.com/ajax/libs/require.js/0.26.0/require.min.js');sir.setAttribute('type','text/javascript');document.getElementsByTagName('head')[0].appendChild(sir);var sib=document.createElement('script');sib.setAttribute('src','http://jarred.github.com/src-img/js/app/bookmarklet.js?version=0.66');sib.setAttribute('type','text/javascript');document.getElementsByTagName('head')[0].appendChild(sib);})());

About the engine version, that's too bad, but it's partially because Google increases the versions very frequently. I have no idea how they reached so far in versions.

Share this post


Link to post
Share on other sites
2 minutes ago, AndroidDeveloperLB said:

The quick-dial did not sync with anything of MX4 for me. Same goes to a lot of other settings, mainly the magic fill.
Not even the favorites.

Clearly there's a problem. Favourites of all things should be imported without issue. So either the import wasn't instigated on the update for some reason, or it failed.

Have you tried the option in Menu > tools > Import/export userdata > import > MX4

10 minutes ago, AndroidDeveloperLB said:

Speaking of favorites, I can't find out how to add a customized one to there.

You're right, there is no simple way. Only way now is to make the current page a favourite, then go into maxnote and edit the URL/title.

They need to make the URL editable in the popup as it was in MX4.

1 person likes this

Share this post


Link to post
Share on other sites
4 minutes ago, 7twenty said:

Clearly there's a problem. Favourites of all things should be imported without issue. So either the import wasn't instigated on the update for some reason, or it failed.

Have you tried the option in Menu > tools > Import/export userdata > import > MX4

You're right, there is no simple way. Only way now is to make the current page a favourite, then go into maxnote and edit the URL/title.

They need to make the URL editable in the popup as it was in MX4.

Not the first time MX had issues with favs. The favs were reset on mx4 a long time ago due to my first login to MX account. I thought it will import what I have. But even on MX5 install (I don't call it update, because MX4 still exists and it didn't import almost anything well), it didn't import those that were on MX4 after that.

About the workaround, thanks. Still annoying. Another annoying thing I've noticed, is that when I created the new tiles in the quick-dial, sometimes when I wanted to drag to move them, it has put them in a folder, and then it was even more annoying to move them outside.

Share this post


Link to post
Share on other sites

in developer panel when window scrolled to bottom - can't scroll up with mouse or "up arrow" in following windows: console, network.

Share this post


Link to post
Share on other sites
On 19.01.2017 at 0:00 PM, PHYR said:

For those of you looking for the new favorite function, it's on the address bar bee when visiting a site you have in your favorites.

fav.png

The function works incorrectly. Please fixed

That should show this feature?
Shows that the sites are added to Maxnote?
I do not see the benefit in this.
 
It would be better implemented the ability to store more than the last two sessions. To them could be grouped. Or at least a story last session
 
with best regards

Share this post


Link to post
Share on other sites

Either way, the favorites icon isn't showing on the bee once the page is loaded, it only appears briefly before the page is loaded.

win10b15014 Mx5.0.2.1400

Reboot = working now....

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, joemax said:

Either way, the favorites icon isn't showing on the bee once the page is loaded, it only appears briefly before the page is loaded.

Can't confirm. Shows here as expected.

Share this post


Link to post
Share on other sites
5 minutes ago, 7twenty said:

Can't confirm. Shows here as expected.

I can confirm - icon appears on some sites during the download page, and then disappears. As I wrote above:

13 hours ago, RoofChyk said:

The function works incorrectly. Please fixed

 

1 person likes this

Share this post


Link to post
Share on other sites

Hello!
How to remove this panel? It prevents, it has cut icons that the browser does not always correctly finds. Although Maxthone previous version is displayed correctly.
Drag and drop is still not repaired in Yandex.

Share this post


Link to post
Share on other sites

Well, this version seems much better than all previous ones. But still not the best. Split screen mode still have some issues one of them is, if any website has iframe and there is a form in that iframe then after going from one side to that iframe side will not focus that side without double clicking that page which is kind of annoying. Version 4.8 and all earlier versions did not have this issue. In addition, this version shows the bold font lot bolder plus, blurry which 4.8 and all earlier versions did not have that issue. 

Share this post


Link to post
Share on other sites
4 hours ago, Chemodan said:

Drag and drop is still not repaired in Yandex

Some more info please.

Tested drag and drop on Yandex image search, https://yandex.com/images/ and it works fine. 

Share this post


Link to post
Share on other sites

@RoofChyk: "For those of you looking for the new favorite function, it's on the address bar bee when visiting a site you have in your favorites."

 

It is like the Chrome Extension "Find My Bookmarks", but you can see how many links you have already saved from the domain.

findmybookmarks.png

Share this post


Link to post
Share on other sites
On 27.01.2017 at 3:36 PM, Chantao said:

It shows that you have the bookmark already

History Extenson: http://extension.maxthon.com/detail/index.php?view_id=3043&category_id= 

I see no benefit in this function.
Sorry, but I do not understand why you gave links History Extension. I have not spoken about the "History Browser", I talked about the "Last Session".
I know many ways to discover history, I do not need this extension.
 
1 hour ago, Chantao said:

@RoofChyk: "For those of you looking for the new favorite function, it's on the address bar bee when visiting a site you have in your favorites."

It is like the Chrome Extension "Find My Bookmarks", but you can see how many links you have already saved from the domain.

If it's really showing how bookmarks of web pages of certain domain, it would be more valuable.
 
Earlier, I wrote:
On 27.01.2017 at 10:53 AM, RoofChyk said:

The function works incorrectly. Please fixed

I have more than 300 bookmarks in Maxnote. I saw some bookmarks appear green circle on the bee, and some tabs is not green circle appeared. I thought at first that the function "detect favorited vebsite" does not work correctly. But then I saw that some sites have changed address and sent to your new address sites. It is not so easy to see because each character is important to properly work function "detect favorited vebsite".

For example, if the bookmarks recorded "https://smarty.sale/ua" and loaded "https://smarty.sale/ua/", the function "detect favorited vebsite" not work.
Or:
If recorded "http://site.com" and loaded "https://site.com" - not work function "detect favorited vebsite".
If recorded "https://www.site.com" and loaded "https://site.com" - not work function "detect favorited vebsite".
If recorded "https://site.com.uk" and loaded "https://site.com" - not work function "detect favorited vebsite".
If recorded "https://site.com/uk" and loaded "https://site.com/" - not work function "detect favorited vebsite".
All such incidents affect the function. It is important to each character. But not so easy to see.

Here are my screenshots:

4.jpg5.jpg6.jpg

with best regards

1 person likes this

Share this post


Link to post
Share on other sites
19 hours ago, AndroidDeveloperLB said:

There shouldn't even be a login window here. 
This issue occurred more often on MX4, but now it occurs on MX5 too.

Hi there, sorry that I cannot confirm this on my device, I'm using MX5 1400 version. how about @7twenty @-ody- @No.1MaxthonFan you? Can you confirm?

If any of you can reproduce, maybe we can find out the common points and get to the root of this issue. :Smiling_Face_Emoji_with_Blushed_Cheeks_42x42:

Share this post


Link to post
Share on other sites
On 28.01.2017 at 0:27 AM, 7twenty said:

Some more info please.

Tested drag and drop on Yandex image search, https://yandex.com/images/ and it works fine. 

I have written in support of the two letters. And even sent them registration data. The problem arises on the main page after login. Maybe there prevents code that is associated with Yandex disc.

Share this post


Link to post
Share on other sites
6 hours ago, Chemodan said:

The problem arises on the main page after login. Maybe there prevents code that is associated with Yandex disc.

I don't have an account so haven't tried whilst logged in. But does it also happen when you aren't logged in?

On 2/2/2017 at 6:45 PM, AndroidDeveloperLB said:

sometimes, when I visit this website:
https://bintray.com/yahoo/maven/squidb/4.0.0-beta.1

I get login window over and over:

Are you logged in to this site when this happens? No issues here when testing from that link.

Share this post


Link to post
Share on other sites

mx5.0.2.1400-beta  

New Tabs not opening properly and the Opened tabs are also freezing, unable to Close them.

The Browser is slowing down.

The Sidebar Icons like Gmail, FB etc when clicked are not coming to the main browser and Opening up, instead the  stay in pop out window which is

highly usless to operate and write etc....

So many new tabs are opening just ffor single click also and are freezed, cannot close them again?

Share this post


Link to post
Share on other sites
On 29/1/2017 at 11:23 PM, RoofChyk said:

For example, if the bookmarks recorded "https://smarty.sale/ua" and loaded "https://smarty.sale/ua/", the function "detect favorited vebsite" not work.

Or:
If recorded "http://site.com" and loaded "https://site.com" - not work function "detect favorited vebsite".
If recorded "https://www.site.com" and loaded "https://site.com" - not work function "detect favorited vebsite".
If recorded "https://site.com.uk" and loaded "https://site.com" - not work function "detect favorited vebsite".
If recorded "https://site.com/uk" and loaded "https://site.com/" - not work function "detect favorited vebsite".
All such incidents affect the function. It is important to each character. But not so easy to see.

Firstly, thank you for doing some testing to determine the issues. As for the problems, some like the missing "/" could probably be fixed quite easily. The rest I don't think they're problems

The feature is to show which pages have been added as favourites. "https://site.com.uk" is not the same as "https://site.com", nor is "https://site.com/uk" and "https://site.com". A saved non-secure site is a questionable one. But if you don't compare the protocol you get hits for saved sites that might not actually be saved. Eg. a saved secure site https://my.bank.com will show as saved even though you went via a non-secure URL. Although the padlock icon is there to prevent issues with fraudulent sites, people might get complacent with using the "favourite webpage" icon.

Missing www i'm not sure how to work around, but that's probably why they've made it match exactly to the URL saved.

Share this post


Link to post
Share on other sites
13 hours ago, 7twenty said:

I don't have an account so haven't tried whilst logged in. But does it also happen when you aren't logged in?

Yes, only after logging in Yandex. With older versions (3,4, Nitro) everything is fine. The only problem is 5 version.

Share this post


Link to post
Share on other sites