Archived

This topic is now archived and is closed to further replies.

Orlith

winpc issue Default browser for Portable version

17 posts in this topic

Hi

 

I'm using the latest portable version on different computer.

Maxthon keeps asking / requesting rights to do change at startup in order to be the default browser, even if I unchecked the "Keep Maxthon as default bbtowser".

Any way to disable that check ? I don't want it to be default browser and I would like it to stop asking for. In my opinion it's not a good choice using a portable version of an application as default oepning program for anything.

 

Thanks

1 person likes this

Share this post


Link to post
Share on other sites

weird enough

are you sure there is not a don't ask me again option?

i'm using portable versions and never had this kind of trouble

in fact portable version never can be a default browser

Share this post


Link to post
Share on other sites

What OS are you running?

I've noticed that for a while now using Win10. But not sure if that's related to the OS, Maxthon not doing something properly, or a mix of the two.

48 minutes ago, karajan said:

in fact portable version never can be a default browser

Since when? I've been using MX portable exclusively as my default browser for quite some time. 

Share this post


Link to post
Share on other sites
20 hours ago, 7twenty said:

What OS are you running?

I've noticed that for a while now using Win10. But not sure if that's related to the OS, Maxthon not doing something properly, or a mix of the two.

Since when? I've been using MX portable exclusively as my default browser for quite some time. 

I'm also running w10. Sorry forget to write that.

Share this post


Link to post
Share on other sites

Portable can not be default browser. This is portable.

Share this post


Link to post
Share on other sites
2 hours ago, A.S. said:

Portable can not be default browser. This is portable.

 

On 29/11/2016 at 6:10 AM, karajan said:

in fact portable version never can be a default browser

How so? Windows doesn't know it's a portable version... it's just an .exe file. And the browser has (and has always had) an option to set as default.

I've always used a portable version and probably only recently with Windows 10 has it been an issue where you always get the prompt on starting. So it's either a problem with windows 10, or a conflict between MX and the way windows sets the default browser.

1 person likes this

Share this post


Link to post
Share on other sites

I fully agree with what is said above!

Share this post


Link to post
Share on other sites

Something weird definitely going on. Just checked windows default program settings and Edge was still set to default even though "Set Maxthon as default" was checked.

So again, either MX isn't changing the setting properly in windows or windows isn't allowing it.

Going to Default Programs in windows then selecting MX5/Maxthon Cloud Browser from the list fixes it. Not sure for how long though.

Share this post


Link to post
Share on other sites
2 hours ago, 7twenty said:

Something weird definitely going on. Just checked windows default program settings and Edge was still set to default even though "Set Maxthon as default" was checked.

So again, either MX isn't changing the setting properly in windows or windows isn't allowing it.

Going to Default Programs in windows then selecting MX5/Maxthon Cloud Browser from the list fixes it. Not sure for how long though.

Problem also occurs in other browsers and programs. Microsoft is promoting Edge and their own programs, so a specially hinders the use of third-party
software. In the web is a lot of critical comment on this.

1 person likes this

Share this post


Link to post
Share on other sites

I think Edge is set as default each time I update Windows which is relatively often as an insider...

Share this post


Link to post
Share on other sites

Anyway, Maxthon portable version keeps asking what ever we do (set as default or not) :)

FYI I got Maxthon (not portable) on another w10 computer, not set as default (IE11 is set as default)  and the issue is not there.

Thx

Share this post


Link to post
Share on other sites

as i said before i got 3 portables version running on win 10 pro

never had this issue

If you try to set as default browser; a portable version never appears in the setting listing

the action of clicking when ask for default has no action in win 10; it has to be done in settings

 

 

Share this post


Link to post
Share on other sites
On 29/11/2016 at 9:00 PM, 7twenty said:

What OS are you running?

I've noticed that for a while now using Win10. But not sure if that's related to the OS, Maxthon not doing something properly, or a mix of the two.

Since when? I've been using MX portable exclusively as my default browser for quite some time. 

since win 10 and remenber win 8; if you set a default browser other tan IE you can't use windows store.

Share this post


Link to post
Share on other sites
Quote

since win 10 and remenber win 8; if you set a default browser other tan IE you can't use windows store

Yes you can. Windows store and Chrome as default browser work fine.

Share this post


Link to post
Share on other sites
On 1/12/2016 at 1:18 PM, 7twenty said:

Going to Default Programs in windows then selecting MX5/Maxthon Cloud Browser from the list fixes it. Not sure for how long though.

This fixed it for me.

Share this post


Link to post
Share on other sites

Will try that thx but as I don't want it to be default as this is not the intented behavior for a portable version...

Thx

Share this post


Link to post
Share on other sites