Archived

This topic is now archived and is closed to further replies.

Sergey_K

Maxthon 4.9 проблемы с Youtube(только 360р и 720р)

15 posts in this topic

Собственно, решена ли была проблема вот по этой теме(там, похоже, уже закрыто для ответов): 

Сейчас использую версию 4.9.3.1000 и в ней так и не воспроизводятся некоторые видеоролики в разрешении отличном от 360р и 720р - это в HTML5 режиме. 

Использую расширение YouTube Center, дабы воспроизводить видео через Flash - там весь набор разрешений присутствует, но почему-то не работает предпросмотр видео(это когда курсором по полоске воспроизведения ведёшь и в маленьком окошке показываются кадры из видео - так вот в этом окошке ничего нет - просто чёрный квадратик.)

Может нашли уже какое-либо решение данной проблемы? Подскажите, пожалуйста!

P.S.: кстати, по ссылке https://www.youtube.com/html5 версия 4.9.3.1000 не поддерживает кодек  "MSE & H.264", однако предыдущая версия maxthon 4.4.8.2000 поддерживала абсолютно все кодеки с данной тестовой страницы HTML5.

Share this post


Link to post
Share on other sites

PPS: а вот на этом видео, например

 даже через flash не удаётся получить полный набор разрешений, хотя в том же GoogleChrome без проблем - полный набор включая 1080p60...

Share this post


Link to post
Share on other sites
13 hours ago, Sergey_K said:

кстати, по ссылке https://www.youtube.com/html5 версия 4.9.3.1000 не поддерживает кодек  "MSE & H.264", однако предыдущая версия maxthon 4.4.8.2000 поддерживала абсолютно все кодеки с данной тестовой страницы HTML5.

решение у вас перед глазами - поставьте обратно версию 4.4.8.х

4.9 - тестовая линейка, забудьте вообще про нее.

Share this post


Link to post
Share on other sites
27 minutes ago, fOrTune(r) said:

решение у вас перед глазами - поставьте обратно версию 4.4.8.х

4.9 - тестовая линейка, забудьте вообще про нее.

Ну вот чё за чушь? MX 4.9 нужен был, как первый шаг на пути к MX5. Внутренностями он на MX4 вообще не похож. Это новый браузер, но если он залит как "Release", значит и должен соответствовать релизу! А предупреждение, которое они прикрепляли почти под каждый билд, они лепили не потому, что они и сами в курсе, что это глючная мура, а потому что это была бета. Бета, Карл! За все это время было всего 3 стабильных версии. 

Плевать на философствования типа "Релизная версия ничем не отличается от беты. Они назвали это "релизом, чтобы расширить круг тестеров. Но этот "релиз" так и остался бетой!", это спекуляции. Это не решает проблему, ибо это никак с ней не связано:

- Доктор, мне взрывом оторвало ногу. Сделайте что-нибудь.
- О... Плохо. А вот не оторвало, было бы хорошо. Вот мне не оторвало, мне хорошо.

13 hours ago, Sergey_K said:

даже через flash не удаётся получить полный набор разрешений, хотя в том же GoogleChrome без проблем - полный набор включая 1080p60...

В Хроме тоже YouTube Center? Он ведь тоже не дает переключаться на Flash без расширений.
Попробуй другие расширения (под Хром их как минимум 2, под МХ - 1,5). Ну или попробуй скрипт YTC с ViolentMonkey (он обновляется чаще). Макстоновские модераторы теперь расширения пропускают, только когда волна гнева по форуму пойдет... несколько раз.
+ Flash поддерживает не все разрешения. У HTML5 их больше

14 hours ago, Sergey_K said:

кстати, по ссылке https://www.youtube.com/html5 версия 4.9.3.1000 не поддерживает кодек  "MSE & H.264", однако предыдущая версия maxthon 4.4.8.2000 поддерживала абсолютно все кодеки с данной тестовой страницы HTML5.

У MX 4.9 с поддержкой форматов как раз все лучше, чем у MX4. То, что годами не работало, теперь работает. Но, возможно, они как всегда напортачили с идентификацией браузера. Поменяй UserAgent. Раньше тут была тема, но не уверен, что она обновляется. 

А вообще, загугли "Maxthon Exatel Fidelis". Сказкам про тупое удаление всего, что связано с UEIP, верят только те, кто до сих пор верит в сказки про мгновенное шифрование, разделение информации по куче серверов по всему миру и еще одно шифрование. Все это абсолютная чушь, а уважение к вам настолько велико, что никто даже не удосужился придумать нормальную отговорку.

Share this post


Link to post
Share on other sites

Ну да, 4.9 "должен" соответствовать релизу, но - не соответствует )) поэтому, дорогой, прекращай ссать кипятком и пытаться всех поправить )) ты тут не самый умный, зато самый многословный. В 4.9 масса вещей через жопу работает, и почему его назвали релизом - один бог знает, но именно из-за этого куча людей, любителей самых новых версий, регулярно наступает на грабли, теряет данные Блокнота, получает кучу глюков на свою голову - и именно поэтому я НЕ РЕКОМЕНДУЮ юзать эту линейку.

А что там где написано - кашлять я хотел.

Share this post


Link to post
Share on other sites
52 minutes ago, fOrTune(r) said:

В 4.9 масса вещей через жопу работает, и почему его назвали релизом - один бог знает, но именно из-за этого куча людей, любителей самых новых версий, регулярно наступает на грабли, теряет данные Блокнота, получает кучу глюков на свою голову - и именно поэтому я НЕ РЕКОМЕНДУЮ юзать эту линейку.

И как это решает проблему? Никак? Тогда давай пойдем ещё дальше: советуй сразу валить с МХ. Нет МХ - нет проблемы!
И хватит путать то, что творится у тебя в голове, с реальным миром: 3 из 19 билдов MX 4.9 были релизами. Зови как хочешь, но людям то голову не морочь. 
С поддержкой форматов у MX 4.9 все в разы лучше, чем у MX4. Ты его хоть запускал?

Share this post


Link to post
Share on other sites

Путают реальность разработчики, когда называют релизом то, то называть им нельзя ))

Валить с МХ по ходу твоя тема, это ты панику поднимаешь с переводами про утечку данных и прочие сюрпризы от китайцев ))

Share this post


Link to post
Share on other sites
1 hour ago, fOrTune(r) said:

Валить с МХ по ходу твоя тема, это ты панику поднимаешь с переводами про утечку данных и прочие сюрпризы от китайцев ))

А лучше замалчивать проблему или придумывать простые способы "избавится" от слежки, которые не работают? Сколько лет нам рассказывали, что вся информация шифруется, делится между серверами и снова шифруется? Сколько раз нам говорили, что сервера у MX по всему миру и информация в Китай вообще не уходит? Единственное, что оказалось правдой, это ключ шифрования, который хранится на самом устройстве. Отличная новость! Даже если MX - хорошие ребята, плохих парней никто не отменял!

За это время МХ дали два противоположных комментария:

  1. Да, мы собираем данные всех пользователей, независимо от того, хотите вы принять участие в программе UEIP или нет. Разница только в том, как много информации о вас будет знать браузер. То есть никто ничего не отрицает!
  2. Нет, всё это из-за бага. Из-за бага мы собирали так много информации, из-за бага мы собирали её ото всех пользователей. Хорошо, что это кто-то заметил.

Вот только багу этому 9 лет. Так трудно заметить, что 400 миллионов пользователей каждый день (как нам опять же говорят долгие годы) отправляет на твой сервер информацию, которая тебе не нужна? Так трудно заметить, что ты ждёшь одни данные, а получаешь другие? За 9 то лет?

И хватит сваливать любое обсуждение в офф-топ. Измени подпись на "Старую - обновить, новую - откатать!" и экономь своё и чужое время.
С YouTube то что делать?

Share this post


Link to post
Share on other sites
20 hours ago, fOrTune(r) said:

решение у вас перед глазами - поставьте обратно версию 4.4.8.х

4.9 - тестовая линейка, забудьте вообще про нее.

Естественно я ставил и 4.4.8.2000, но на ней почему-то ни в какую не хотят работать googlemaps в 3D-режиме (Earth). Вообще, 4.9 мне как-то больше приглянулся и, в принципе, всем устраивает, но вот эта "засада" с YouTube всё перечёркивает.

Тут немного попытался разобраться в причинах: скорее всего, всё дело в наличии/отсутствии необходимой поддержки со стороны кодеков... Вот, например, что показывает HTML5Test (см. раздел "Streaming", подраздел "Codecs"): http://html5test.com/compare/browser/mybrowser/chrome-51/firefox-47.html

Обратите внимание - у браузеров Firefox и Chrome имеется поддержка кодеков "MP4 with H.264 support" и "MP4 with AAC support", а у MX4.9 - нет.

Со стороны разработчиков, считаю, данное недопустимым - браузер по основному функционалу(поддержка HTML5, Flash, Java и т.д.) должен быть как минимум  на уровне конкурентов. 

Может быть можно с помощью какого-то расширения увеличить набор поддерживаемых кодеков? 

 

Share this post


Link to post
Share on other sites
21 hours ago, A.S. said:

В Хроме тоже YouTube Center? Он ведь тоже не дает переключаться на Flash без расширений.
Попробуй другие расширения (под Хром их как минимум 2, под МХ - 1,5). Ну или попробуй скрипт YTC с ViolentMonkey (он обновляется чаще). Макстоновские модераторы теперь расширения пропускают, только когда волна гнева по форуму пойдет... несколько раз.
+ Flash поддерживает не все разрешения. У HTML5 их больше

Нет, Chrome без YTC, да и Flash-режим мне особо не нужен(это вынужденная мера) - вполне устраивает и HTML5, даже согласен и без YTC и проч. лишь бы работало как надо. 

UserAgent всякие пробовал, даже вручную версии Chroma и Firefox вбивал - ничего. Скорее всего всё-таки наличие в браузере кодеков имеет решающее значение. 

P.S.: О, пока суть да дело - на mail пришёл MX5 - ура! Сейчас затестим :) 

Share this post


Link to post
Share on other sites
1 hour ago, Sergey_K said:

Со стороны разработчиков, считаю, данное недопустимым - браузер по основному функционалу(поддержка HTML5, Flash, Java и т.д.) должен быть как минимум  на уровне конкурентов. 

Конечно должен )) но именно поэтому 4.9 и не может считаться релизом - по причине отсутствия подобного функционала.

4.4.х просто устарели уже со своим движком.

Пятерка тоже не факт что все потянет сейчас, альфа ведь всего лишь.

Share this post


Link to post
Share on other sites
1 hour ago, Sergey_K said:

Нет, Chrome без YTC, да и Flash-режим мне особо не нужен(это вынужденная мера) - вполне устраивает и HTML5, даже согласен и без YTC и проч. лишь бы работало как надо. 

Только сейчас дошло: причем здесь Flash и поддержка HTML5?

Если проблема с Flash, то, скорее всего от того, что MX его почти никогда не обновляет. Они считают, что чем новее Flash, тем больше в нём уязвимостей: ведь их находят каждый день! Поэтому MX и использует старый Flash, в котором было меньше известных проблем. Я серьёзно, это слова вице-президента. Так что Flash в MX всегда дико старый. В MX 4.9 тупо скопируй его из какого-нибудь Хрома и ему подобных.

А HTML5Test опирается на честность браузеров. И MX частенько его результаты накручивает. И об этом тоже полно статей. Да сам создатель теста писал, что был в шоке от результатов МХ, установил его, чтобы посмотреть, что это за чудо такое, и был в шоке от того, насколько его тест легко обдурить. МХ тогда тоже всё свалили на техническую ошибку.

P.S. Есть еще вариант снести или вырубить YTC и попробовать это. Но не думаю, что поможет. 

Share this post


Link to post
Share on other sites

Нууу... что только не делал уж... Flash обновлял с родного сайта до последней версии и переименовывал... Disable HTML5 ставил - результатов ноль. Сейчас доэкспериментировался до того, что google maps перестал в 3D работать - только спутник. :arf:

Короче, пока плюнул - пришла 5-ка, установил, бегло проверил - в ней всё работает - и youtube и Google 3D - уже здорово. Пока в повседневной работе и отдыхе перехожу на тестирование MX5.

 

Share this post


Link to post
Share on other sites
29 minutes ago, Sergey_K said:

Flash обновлял с родного сайта до последней версии и переименовывал...

Maxthon плевать на твой Flash. Скопируй вручную их Хрома (если речь идёт об MX 4.9). 

Share this post


Link to post
Share on other sites