Archived

This topic is now archived and is closed to further replies.

PsyAfter

Address bar : various issues

26 posts in this topic

Text align center and displaying domain only is not too comfortably.

In prev version it was better (left align + full url with bolded domain)

9 people like this

Share this post


Link to post
Share on other sites

Agree x100

At minimum there should be an option to disable "dumb address bar"

But you can thank apple for that, and their innate ability to implement features that trickle everywhere no matter how stupid it may seem.

7 people like this

Share this post


Link to post
Share on other sites
2 hours ago, PsyAfter said:

Text align center and displaying domain only is not too comfortably.

In prev version it was better (left align + full url with bolded domain)

all thats possible but its a skin mod - history mostly says what we have on the stock UI will not change

Share this post


Link to post
Share on other sites

Address bar :

  1. Switch Core button is  missing
  2. When you try to use "paste& go" (by right click) at address bar you have to click on the middle of it! or it takes 2 steps :  1)left click anywhere into address bar to expand the url, 2) then right click to copy/paste. An option to not hide the true URL in the address bar would be nice
  3. right-click does not work in address bar (reported by magg)
  4. searched words and alias remain in address bar (has to be deleted before you type another word into address bar) 

addressbug.png

1 person likes this

Share this post


Link to post
Share on other sites

2. is (at least partially) fixed in 2700 ! (clean instlall)

 search alias do work as intended, searched words and URL do no longer remain in address bar.

Share this post


Link to post
Share on other sites
9 minutes ago, -ody- said:

2. is (at least partially) fixed in 2700 ! (clean instlall)

 search alias do work as intended, searched words and URL do no longer remain in address bar.

As time goes on we will need to use mode button less often...

Share this post


Link to post
Share on other sites
Just now, joemax said:

As time goes on we will need to use mode button less often...

maybe,  but for now I still need it.

Share this post


Link to post
Share on other sites

The adress bar should be left aligned and show the domain in bold and the rest of the url in a normal (or maby light/gray) font.

1 person likes this

Share this post


Link to post
Share on other sites

switch core button missing :

OK, I can change the mode (main menu/tools), it's not handy but possible,  but then,  how do I know which mode I am without this button ?

1 person likes this

Share this post


Link to post
Share on other sites
52 minutes ago, -ody- said:

switch core button missing :

OK, I can change the mode (main menu/tools), it's not handy but possible,  but then,  how do I know which mode I am without this button ?

When you switch from Ultra to Retro, the menu entry changes and reads Retro to Ultra.  Not convenient at all.

2 people like this

Share this post


Link to post
Share on other sites
4 minutes ago, No.1MaxthonFan said:

When you switch from Ultra to Retro, the menu entry changes and reads Retro to Ultra.  Not convenient at all.

yes and there's no way to know which mode you're on but going to main menu/tools !

1 person likes this

Share this post


Link to post
Share on other sites

You answered your own question. When do you need to see it is the question.

Share this post


Link to post
Share on other sites

With the new .2700 alpha build, an ugly problem from M4 has been reintroduced - and worsened.

If I go to type a URL into the address bar, it begins suggesting possible URLs from my history, as you would expect. However, it then ignores whatever I type after the first character or two, so when I press Enter it only activates the first part of the address. Sometimes this results in searching the specified search engine (Google UK in my case), and sometimes the first suggest matched URL.

For example:

I want to go to http://getbootstrap.com/css/

I open the new tab page and begin typing 'getb...'

getbootstrap.com/css/ pops up as first result in the suggest dropdown, as I've visited numerous times before. I press the down arrow to select it, then Enter.

I end up being taken to https://www.google.co.uk/search?q=g&gws_rd=ssl

This is driving me slowly insane. Is anyone else having similar problems?  It has been evident in the most recent build of M4, although not quite so persistently, and I didn't notice it in M5 alpha 2500.

2 people like this

Share this post


Link to post
Share on other sites
1 hour ago, vityushka said:

Ok, guys. How I can back old address bar view? Now it show only root website address.

For example, for 'Ask New Question' page I see only 'forum.maxthon.com' without subpage, but real url (I can see it, when click to address field) http://forum.maxthon.com/index.php?/forum/95-mx5-alpha-version-qa/&do=add

another way is to click the little arrow next to the bee.

but there's no option yet to "always" display the real url

Share this post


Link to post
Share on other sites
1 hour ago, -ody- said:

another way is to click the little arrow next to the bee.

but there's no option yet to "always" display the real url

Yes, and this is sad. Really strange solution. I hope it will be fixed in next builds of Maxthon 5, because I really don't understand reason, why Maxthon hide full url path. Always click somewhere, when I wanna see full url? Are you #$%# kidding me?:)

2 people like this

Share this post


Link to post
Share on other sites
17 minutes ago, vityushka said:

Yes, and this is sad. Really strange solution. I hope it will be fixed in next builds of Maxthon 5, because I really don't understand reason, why Maxthon hide full url path. Always click somewhere, when I wanna see full url? Are you #$%# kidding me?:)

they say "it's for aesthetic reasons" ...

looking at the new QA, we don't have the same idea of what "aesthetic" means :wacko:

2 people like this

Share this post


Link to post
Share on other sites
2 hours ago, AaronX said:

With the new .2700 alpha build, an ugly problem from M4 has been reintroduced - and worsened.

If I go to type a URL into the address bar, it begins suggesting possible URLs from my history, as you would expect. However, it then ignores whatever I type after the first character or two, so when I press Enter it only activates the first part of the address. Sometimes this results in searching the specified search engine (Google UK in my case), and sometimes the first suggest matched URL.

For example:

I want to go to http://getbootstrap.com/css/

I open the new tab page and begin typing 'getb...'

getbootstrap.com/css/ pops up as first result in the suggest dropdown, as I've visited numerous times before. I press the down arrow to select it, then Enter.

I end up being taken to https://www.google.co.uk/search?q=g&gws_rd=ssl

This is driving me slowly insane. Is anyone else having similar problems?  It has been evident in the most recent build of M4, although not quite so persistently, and I didn't notice it in M5 alpha 2500.

I can't reproduce this, I tried with several words, never got to google instead of the url

Share this post


Link to post
Share on other sites
2 hours ago, AaronX said:

With the new .2700 alpha build, an ugly problem from M4 has been reintroduced - and worsened.

If I go to type a URL into the address bar, it begins suggesting possible URLs from my history, as you would expect. However, it then ignores whatever I type after the first character or two, so when I press Enter it only activates the first part of the address. Sometimes this results in searching the specified search engine (Google UK in my case), and sometimes the first suggest matched URL.

For example:

I want to go to http://getbootstrap.com/css/

I open the new tab page and begin typing 'getb...'

getbootstrap.com/css/ pops up as first result in the suggest dropdown, as I've visited numerous times before. I press the down arrow to select it, then Enter.

I end up being taken to https://www.google.co.uk/search?q=g&gws_rd=ssl

This is driving me slowly insane. Is anyone else having similar problems?  It has been evident in the most recent build of M4, although not quite so persistently, and I didn't notice it in M5 alpha 2500.

I can't reproduce this either.  

Share this post


Link to post
Share on other sites
7 hours ago, -ody- said:

I can't reproduce this, I tried with several words, never got to google instead of the url

It is slightly temperamental. Seems more likely to happen the longer the browser is open - even for as little as a couple of hours of usage. Sometimes I can type in the entire URL, not use the suggested URLs at all, and it still takes me either to Google or to the first suggested page when I press Enter. It's a nightmare.

For clarity, I'm running on Windows 10 Pro x64.

Screenshots attached. See how much I've typed, and how much it's actually acknowledged and matched in the dropdown in bold.

fail.gif

fail2.gif

Share this post


Link to post
Share on other sites
On 2016/7/13 at 4:35 PM, PsyAfter said:

Text align center and displaying domain only is not too comfortably.

In prev version it was better (left align + full url with bolded domain)

Hello, thanks your suggestion firstly, PsyAfter.

This suggestion already sent to design team. We will consider your suggestion. :)

Share this post


Link to post
Share on other sites

Ok. I will add my case. I'm a dev and I really wanna see full URL all time for my work. In Maxthon 5 I must: 1) Click to address bar 2) Click to part of url  that I want to change. This is too slow. Dev-guys, please, add some option in settings for this (if you don't want to show full url for all).

Share this post


Link to post
Share on other sites
1 hour ago, vityushka said:

Ok. I will add my case. I'm a dev and I really wanna see full URL all time for my work. In Maxthon 5 I must: 1) Click to address bar 2) Click to part of url  that I want to change. This is too slow. Dev-guys, please, add some option in settings for this (if you don't want to show full url for all).

Don't know if you will be interested, but there is a Skin that does what you want with the URL  You can find it here:  

 

sshot-5.png.23468c480301f7a4deed248e5b610374.png

2 people like this

Share this post


Link to post
Share on other sites
12 hours ago, No.1MaxthonFan said:

Don't know if you will be interested, but there is a Skin that does what you want with the URL  You can find it here:  

THANK YOU! Dark skin and full URL in address bar - this is what I need!

Share this post


Link to post
Share on other sites

I have seen that some users have mentioned that they would like to see the full URL shown in the address bar and others may like a shortened URL to be shown. My suggestion is that users may have a choice (you can add that word to your vocabulary) of having the shortened URL or a full URL, that is a choice I would like to see.

2 people like this

Share this post


Link to post
Share on other sites
Quote

My suggestion is that users may have a choice (you can add that word to your vocabulary) of having the shortened URL or a full URL, that is a choice I would like to see.

Yep, this is better way. Some option inside settings will be ok.

Share this post


Link to post
Share on other sites