Archived

This topic is now archived and is closed to further replies.

mels

"Unsupported Browser"

13 posts in this topic

I've been using Maxthon since the MyIE2 days.  I love it and have always considered it the best browser available.  Unfortunately, over the past year, more and more websites are identifying Maxthon as an unsupported browser.  It's causing annoying recurring banner messages and even the loss of functionality on some websites.  It surprises me that this has not been resolved.  I would hope Maxthon's developers are proactive and will address this issue globally and quickly so that Maxthon users do not begin (or continue) to migrate to alternative browsers.  I would hate to change browsers, but it's getting to the point that having to switch between retro / ultra mode and even having to open a different browser on occasion to access a website is just an unnecessary use of my time.

Thanks for listening.
<<a concerned long-time user>>

3 people like this

Share this post


Link to post
Share on other sites

They are promising that Maxthon 5 will solve that and many more problems.  When that is going to happen is anyone's guess.  They have been saying since last year that it will be "soon". 

Share this post


Link to post
Share on other sites
4 hours ago, mels said:

I've been using Maxthon since the MyIE2 days.  I love it and have always considered it the best browser available.  Unfortunately, over the past year, more and more websites are identifying Maxthon as an unsupported browser.  It's causing annoying recurring banner messages and even the loss of functionality on some websites.  It surprises me that this has not been resolved.  I would hope Maxthon's developers are proactive and will address this issue globally and quickly so that Maxthon users do not begin (or continue) to migrate to alternative browsers.  I would hate to change browsers, but it's getting to the point that having to switch between retro / ultra mode and even having to open a different browser on occasion to access a website is just an unnecessary use of my time.

Thanks for listening.
<<a concerned long-time user>>

You'll have to update the UserAgent to resolve your issue.

Share this post


Link to post
Share on other sites

Hi, Mels. I very understand you. I wanna trying my best to solve it.

Could you give me a sample link for this problem, please? and I can find the root of issue.

Thanks and looking forward to your response.

Share this post


Link to post
Share on other sites

I may be having the same problem: each time there's a video embedded in a Twitter post, I get the message "This browser does not support video playback." 

This is in both Ultra and Retro mode, I'm using Maxthon v4.4.8.2000.

It's hit-or-miss on videos at the best of times, I'm always having to switch from one mode to another, and lately that doesn't even get the video to play. Way past annoying, and it's causing me to use Chrome a lot more since that browser plays everything with no problems. 

I've used Maxthon since it first arrived, and I've been hooked since forever, it seems; but it better get fixed fast, as I'm finally losing patience!

1 person likes this

Share this post


Link to post
Share on other sites

One example site that has prominantly displayed the "unsupported" message for the past few months ... https://www.chase.com/ ,

A mildly popular site around the world.

 

Chase.jpg

1 person likes this

Share this post


Link to post
Share on other sites

On the website mels just posted, www.chase.com (and I do have an account with that bank) in Ultra mode I get a message saying, "Your browser is out of date. Please update your browser" as mels posted in the screenshot above. They give a link which lists browsers that will work with their website (Maxthon isn't one of them.) The message indicates that soon they plan to upgrade their website, and when that happens Maxthon will not be usable, though at present it works. It loaded very, very slowly for me.

In Retro mode, the login page is blank, but I do see some "News and Stories" pictures down at the bottom, which were also shown in Ultra mode. The website is not usable at all in Retro mode.

So that's a great example of Maxthon needing some big fixes, and soon!

1 person likes this

Share this post


Link to post
Share on other sites
30 minutes ago, Esky1700781 said:

(Maxthon isn't one of them.)

Neither is:
PaleMoon
360browser

Avant Browser
Lunascape
Comodo Dragon
Eco Browser
SRWare 
Iron Torch

Yandex Browser
Cốc Cốc
QupZilla
Sleipnir
SlimBoat
Slimjet
Vivaldi

Microsoft Edge

Some are probably bigger or more well known than Maxthon, doesn't mean they don't work, or won't work in the future. It's just a warning based on the detection of the useragent being used. See this old post about the same issue.

To fix: select one of the other useragent options in settings, or choose Maxthon and remove the "Maxthon/4.9.x.xxx" part.

Just one of the niggles you have to deal with when using a non-mainstream browser and websites using stupid code to detect stuff.

1 person likes this

Share this post


Link to post
Share on other sites
On 2016/5/28 at 0:41 PM, mels said:

One example site that has prominantly displayed the "unsupported" message for the past few months ... https://www.chase.com/ ,

A mildly popular site around the world.

 

Chase.jpg

Thanks for quick response and cooperation.

I just sent information to test team. If they give me the feedback, I will contact you ASAP.

1 person likes this

Share this post


Link to post
Share on other sites

A fix for this is essential. I keep muddling through when I see this message, and most  of the time, I can still use a site. But others who are not so loyal to Maxthon are just going to say, "#### it" and start using Chrome.  Today, my wife was having so many problems with a popular retail site -- the latest of many -- that she said she was switching to Chrome. I doubt my wife is alone in her decision. Maxthon is likely leaking users at a serious rate. Either this problem is because of how sites are reading the User String or it's because there is some real incompatibility. Either way, when your patient is bleeding out, you don't ignore that wound because you're preoccupied with doing some plastic surgery or some other nonfatal problem.  This is not something Jeff and the developers need to decide whether they want to do. It's not up for discussion. And it needs to be done soon.

1 person likes this

Share this post


Link to post
Share on other sites

Hello, Mels. It's confirmed as a bug. We will confirm it ASAP.

Thanks your feedback.:)

1 person likes this

Share this post


Link to post
Share on other sites
On 5/28/2016 at 4:41 PM, mels said:

One example site that has prominantly displayed the "unsupported" message for the past few months ... https://www.chase.com/ ,

A mildly popular site around the world.

 

Chase.jpg

seems to be working in latest beta.

1 person likes this

Share this post


Link to post
Share on other sites