R3gi

Text size

6 posts in this topic

Hello,

I was notified by one visually impaired user of our local Maxthon.cz forum about his problems using Maxthon browser. However, this problem affects also e.g. users of large screens.

It seems Maxthon still doesn't support changing font size. Option in Settings > Advanced > Webpage display > Web page font is useless and confusing, because it doesn't work. It's been already discussed here (#1, #2), but nothing has changed. It's sad that even much worse browsers have a better support for this basic feature.

So I would like to remind this problem and ask, if we can reckon some solution in the future?

By the way, I've found this workaround:

1. Install Violentmonkey extension.

2. Go to this page and click on „install this style as a user script“. This will send an userscript installation request to Violentmonkey. Confirm that installation.

3. Done! Text size should be large now.

Just to be sure, I attach that script here, if it eventually disappeared from the userstyles database:// ==UserScript==

// @name Global Font Size

// @namespace http://userstyles.org

// @description Relax your eyes, as you can choose to have one Font Size for everything.

// @author valmynd

// @homepage https://userstyles.org/styles/68263

// @run-at document-start

// @version 0.20130426094209

// ==/UserScript==

(function() {var css = .join("\n");

if (typeof GM_addStyle != "undefined") {

GM_addStyle(css);

} else if (typeof PRO_addStyle != "undefined") {

PRO_addStyle(css);

} else if (typeof addStyle != "undefined") {

addStyle(css);

} else {

var node = document.createElement("style");

node.type = "text/css";

node.appendChild(document.createTextNode(css));

var heads = document.getElementsByTagName("head");

if (heads.length > 0) {

heads.appendChild(node);

} else {

// no head yet, stick it whereever

document.documentElement.appendChild(node);

}

}

})();

Share this post


Link to post
Share on other sites

bug is still present !:(

Share this post


Link to post
Share on other sites

Hey guys,

Thanks for mentioning this issue again.

At the moment there is no plan to include font size option in Settings anymore. However this functionality will not be abandoned. As you have already found out a workaround to change fonts, we will do same by building an extension for font management after the official version of Mx5 has been released:)

Please stay tuned.

Thanks for your patience and support for Maxthon.

1 person likes this

Share this post


Link to post
Share on other sites
16 minutes ago, BugSir007 said:

At the moment there is no plan to include font size option in Settings anymore.

patiently waiting ! :)

in the meantime it would be wise to remove this useless feature from settings !

Share this post


Link to post
Share on other sites
23 minutes ago, -ody- said:

patiently waiting ! :)

in the meantime it would be wise to remove this useless feature from settings !

It has been removed in Mx 4.9....:)

1 person likes this

Share this post


Link to post
Share on other sites