Sign in to follow this  
Followers 0
7twenty

winpc resolved Disable auto-search from address bar

16 posts in this topic

So something has changed since this workaround. It seems the suggestions are no longer sourced online or they are and the block still works, but they've added a local list as well.

Given that there is still no option to disable suggestions i've started looking for a means to disable them... and so far I can't seem to find or figure out where they're sourced or even how to just remove that from the dropdown.

Any suggestions from anyone? Or even better, Dev's give us an option to enable or disable them at our own discretion!! I don't need to see some random sites in my addressbar dropdown that I probably never want to visit anyway.

Share this post


Link to post
Share on other sites

Hello:

For many versions one could work around the privacy problem of auto-search from the address bar by adding API.BING.COM to the Windows HOSTS file. Apparently the authors of Maxthon simply couldn't have that so they've worked around it somehow.

Now again with version 4.4.3.1000 our privacy is being sent to who knows where and used who knows how and sold to who knows whom whenever we type a word in to the address bar.

Does anyone know how, with version 4.4.3.1000 we can subvert this insidious behavior? Adding API.BING.COM to our HOSTS file no longer works.

Thank you in advance for any knowledge anyone can share to avoid this privacy voilating behavior.

Share this post


Link to post
Share on other sites

EDIT: See the next post for latest update.

I've found there is an easy way which is to simply remove/rename the MxSmartUrl.dll file from the install folder, but that also removes favourites & recently used URL suggestions as well. Unsure of what else it might break as well. You also can't replace it with a previous version as MX just crashes.

Now again with version 4.4.3.1000 our privacy is being sent to who knows where and used who knows how and sold to who knows whom whenever we type a word in to the address bar.As stated in my previous post it's now local, you can disable your network connection and you will still see them as it seems that the suggestion list data is kept in a maxthon file. So the data isn't leaving your PC. Doing some snooping of the data MX sends I couldn't find any other random urls that it's using (unless it's encrypted?).

So from a privacy standpoint I don't believe there is an issue. It's just annoying seeing pointless suggestions which could be used for my history or fav's etc.

Share this post


Link to post
Share on other sites

So played around a little more. Seems all the suggestions are part of the update.db file in the \public\SmartUrl folder. If you create a new empty text file named update.db and mark it read-only then things will go back to normal.

The only caveat is that it seems when typing in the address bar the matched URLs are a little slower than normal. Not 100% on that, but that's what it feels like. And of course i'm unaware of anything else it might break.

I wonder how long till this is broken as well? Once again dev's, give users the option to disable it. None of the other major browsers that also offer this force it on users - they all allow it to be turned off.

NOTE: You must keep the HOSTS file workaround enabled, as this does not override that fix.

-

On a somewhat related note, there seems to be some porn links in the suggestions - type in "you" and you'll get at least two. Now, it doesn't bother me, but if you have kids using Maxthon and they stumble across them - well it doesn't bode well for a family friendly browser does it?

Share this post


Link to post
Share on other sites

7twenty replied at 2014-11-16 06:11 back.gif

On a somewhat related note, there seems to be some porn links in the suggestions - type in "you" and you'll get at least two. Now, it doesn't bother me, but if you have kids using Maxthon and they stumble across them - well it doesn't bode well for a family friendly browser does it?

definitely a good reason to give users the option to disable it.

Share this post


Link to post
Share on other sites

>> I've found there is an easy way which is to simply remove/rename the MxSmartUrl.dll file from the install folder

>> Seems all the suggestions are part of the update.db file in the \public\SmartUrl folder. If you create a new empty text file named update.db and mark it read-only then things will go back to normal.

This does it for me! Thank you VERY much for your time and research. I for one appreciate it greatly.

Share this post


Link to post
Share on other sites

Arrrrgghhh. Workaround 1 no longer works, renaming MxSmartUrl.dll disables the favorites history part as well, and the update.db file is something I can't find. What next????

Share this post


Link to post
Share on other sites

Have you run Maxthon at least once so the files are updated? The userdata folder isn't created until MX is run the first time. And are you looking in the right place?

It should be in the UserData\public\SmartUrl folder. If you used the installed version of Maxthon, open an explorer window and paste in %appdata%\Maxthon3\UserData\Public\SmartUrl in the address bar. For the portable version, userdata is in the folder Maxthon was extracted to.

Share this post


Link to post
Share on other sites

Yes I found it, I was looking in program files when I posted that and it's in appdata. But it didn't work!

Share this post


Link to post
Share on other sites

AylaAsperger replied at 2014-11-30 04:14 back.gif

Yes I found it, I was looking in program files when I posted that and it's in appdata. But it didn't work!Are you following the instructions correctly? I've been using this workaround since I found it while using 4.4.3.2000 and have since updated to .3000 and it still works fine.

Empty text file named to update.db, marked as read-only in the public\smarturl folder.

123p3bd.png

Also interesting that no rep has made any mention about the porn links suggestions?

Share this post


Link to post
Share on other sites

I did EXACTLY that, with my browser closed, but I still get those search hints whatever I type!!

Share this post


Link to post
Share on other sites

I just tested again on a new portable install and also with a passport account, and it worked fine in both cases. I can't see any reason why it isn't working for you. I have not tested with the installer version, but I can't see any reason why that would be different as it's basically the same files packaged differently and set to use the %appdata% folder to save userdata.

Did you remove the HOSTS file workaround by any chance? If I recall correctly it's still required. So the file workaround might be working, but you are actually seeing the suggestions provided by api.bing.com.

Share this post


Link to post
Share on other sites

Yes, it is indeed slower. Maxthon should really fix this issue instead of breaking the workaround.

Share this post


Link to post
Share on other sites

wondering if anyone found an answer to this yet, from reading posts looking for an answer I see alot of people getting mad at people that don't like this feature and telling them to use another browser, we don't want the feature taken back out, just the option to turn it off. I'm looking for a new browser after Opera destroyed itself and so far maxthon is the only one I remotely like otherwise I would go to something else. The problem is most browsers are trying to be the same thing. Instead of having features you can turn on or off, they all seem to be removing the features I use and adding features I don't want with no way to turn them off. Relating to this topic; when I start typing in the address bar, the only suggestion I want is from my favorites, NOTHING ELSE. Please Maxthon, your the closed I've found to a browser that I like.

Share this post


Link to post
Share on other sites

DreamsOfAnarchy replied at 2015-1-10 00:25 back.gif

wondering if anyone found an answer to this yet, from reading posts looking for an answer I see alot ...

A workaround is explained in post #11. Unfortunately there is no easy on/off option.

when I start typing in the address bar, the only suggestion I want is from my favorites, NOTHING ELSE.The closest you will get is doing the workaround as listed above, and unchecking the "Show History items in suggestions" option in the address bar settings.

After that it will only show matched URLs that you've typed in the address bar and those in your favourites.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0