-ody-

Updated User Agent

98 posts in this topic

I'm still using MX 4.4.5.1000 on win 8.1 and I've updated my UA as follows:

 

Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.4.5.1000 Chrome/42.0.2311.135 Safari/537.36

 

I don't know whether it is right or maybe there's something wrong/less, but so far it works fine to open YouTube, Gmail, and playing some flash games on Facebook.

 

PS: I don't see any UA update for MX 4.4.5.1000 even in old forum (There are only for MX 4.4.4.3000 and MX 4.4.5.1200 beta)

Share this post


Link to post
Share on other sites

I'm still using MX 4.4.5.1000 on win 8.1 and I've updated my UA as follows:

 

Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.4.5.1000 Chrome/42.0.2311.135 Safari/537.36

 

I don't know whether it is right or maybe there's something wrong/less, but so far it works fine to open YouTube, Gmail, and playing some flash games on Facebook.

 

PS: I don't see any UA update for MX 4.4.5.1000 even in old forum (There are only for MX 4.4.4.3000 and MX 4.4.5.1200 beta)

it's the UA smilefly told us to use, no wonder it works fine  :top:

1 person likes this

Share this post


Link to post
Share on other sites

@ Bisoprolol

 

You can make your UA more minimalist and compatible by changing it to this.

 

Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 Maxthon/4.4.5 Chrome/42.0.2311.135 Safari/537.36

 

or this one

 

Mozilla/5.0 (compatible; Windows NT 6.3; WOW64; IA64; en) AppleWebKit/599.0+ Chrome/42.0.2311.135 Maxthon/4.4.5 QupZilla/1.8.6

 

you shouldn't need the "1000" in Maxthon 4.5.5

2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

I have Windows 7 (64-bit) and uses Maxthon Latest Stable v.4.4.5.1000
For Customized UserAgent string, I use this (set to Maxthon). Have customized a little bit manually, shorten the Mx number and Copy/Paste the new Chrome v. in, all works OK. 

Mozilla/5.0 (compatible; Windows NT 6.1; U; WOW64; IA64; en) AppleWebKit/599.0+ (KHTML, like Gecko) Maxthon/4.4.5 Chrome/42.0.2311.135  Safari/537.36  OPR/28.0.1750.51  QupZilla/1.8.6

I only have 2 questions about it. 1.) OPR does it stand for the Opera browser.?? 2.) QupZilla is a Linux browser, do I need to have it, if I don't use any Linux system.?? Can I just remove QupZilla then.??
 • UserAgentString.com - Get an analysis of your or any other User Agent string.
http://www.useragentstring.com/
 Last a Request to Magdalene,

I know this Topic is mowed from the old-forum, so the BBCode is lost etc.. So next time, you have the time and stamina to update your TOP notch post. @Thanks to Imanerd also.
Please can you type in a version number also, a bit like this I mean >  Latest Stable Version (v.4.4.5.1000) (Updated 12th April 2015)
More so all can see that UA you made, fits the correct version, the user uses. And also the keep the update time, it's a good thing you do there.
 Many great-full thanks for all you work and testing. And thanks to the one, that answers this post also... (^^,)
Best Regards Ohke
 
EDIT: UA string correct now... So I don't get Error 1010 from CloudFlare... Error 1010 gives access denied on some websites...

Edited by ~Ohke
1 person likes this

Share this post


Link to post
Share on other sites

I have Windows 7 (64-bit) and uses Maxthon Latest Stable Version ( v.4.4.5.1000 )

For Customized UserAgent string, I use this (set to Maxthon)... I have customized it a little bit manually, shorten the Maxthon number and Copy/Paste the new Chrome version in, all works OK. 

Mozilla/5.0 (compatible; Windows NT 6.1; U; WOW64; IA64; en) AppleWebKit/599.0+ (KHTML, like Gecko) Maxthon/4.4.5 Chrome/42.0.2311.135 
Safari/537.36 OPR/28.0.1750.51 QupZilla/1.8.6

I only have 2 questions about it. 1.) OPR does it stand for the Opera browser.?? 2.) QupZilla is a Linux browser, do I need to have it, if I don't use any Linux system.?? Can I just remove QupZilla then.??

 

Last a Request to Magdalene, I know this Topic is mowed from the old-forum, so the BBCode is lost etc... So next time, you have the time and stamina to update your TOP post.

Please type in a version number also, a bit like this I mean >  Latest Stable Version (v.4.4.5.1000) (Updated 12th April 2015)

More so all can see that UA you made, fits the correct version, the user uses. And also the keep the update time, it's a good thing you do there.

 

Many great-full thanks for all you work and testing. And thanks to the one, that answers this post also... (^^,)

Best Regards Ohke

 

 

OPR is Opera after presto was dumped (if muscle memory serves, after 12.31 or around it), but Opera is Opera before it.

 

QupZilla was designed for FOSS OSs, but it's also available for Linux. I was the one who put QupZilla in the original version off which Magdalene is basing the new ones: it balances it out, because of how sites interpret the UA. You can also use QtWeb/3.8.5.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

@ Ohke The UA's I post are usable with any version of Maxthon 4 i.e a version for 4.4.5 will work for 4.4.3. I have updated them in this thread on the new forum now. Qupzilla is also available for Windows. I wasn't able to access this thread until today. I recommend the Minimalist UA's. They work  and need a lot less updating.

 

For people who don't understand the need for these updates; it's to aid access to certain websites particularly Youtube which often requires the latest version of Chrome in a UA.

Edited by Magdalene
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

I think there are some problem in the UA. Whenever I try to change my UA, I always get recognized as the default one:

post-809-0-06304800-1431773003_thumb.png

post-809-0-58547700-1431773013_thumb.png

 

Mx Portable version!

Edited by Ices_Eyes

Share this post


Link to post
Share on other sites

Posted (edited)

@ Ice Eyes.

 

keep the maxthon user agent box ticked

 

 post-91606-0-44242700-1431802794_thumb.p

Edited by Magdalene

Share this post


Link to post
Share on other sites

It's a problem with http://whatsmyuseragent.com/

 

Try another like http://whichbrowser.net/

 

And see my original post

 

 

@ Ice Eyes.

 

keep the maxthon user agent box ticked

 

 attachicon.gifUntitled20150516195604.png

 

Ok, it seems that by using another site as said by Oliver. the update UA is shown. So this make me wonder why I continue to see the yellow bar on gmail...  :wacko:

Share this post


Link to post
Share on other sites

Posted (edited)

Actually to @Smilefly:  You said to let you (the devs I presume) know of any website that has a problem with the new default UA.

 

I have one, cbs..com.  Videos do not play on cbs.com if I use the default UA in 4.4.5.2000 with adblocking enabled using Wilser's Super Quick List posted on the forum here ... but no other lists whatever.   I originally thought of this and reported it as an adblocking problem, but then found that by changing the UA ABP could remain enabled and work.  When I change the UA to Firefox, everything works as it should with ABP.

 

Can you see if the default Maxthon UA can be revised to let ABP work as it does when you use a Firefox UA.

 

EDIT(6/6/15):  I've been dong some more UA testing today and discovered what appears to be the factor in the UA strings that blocks vidoes from playing on cbs.com ... the browser engine.  If I specify the Gecko engine and give it a version (revision) within the Windows elements, cbs.com plays correctly even if it identifies the browser as Maxthon/4.4.5 or Maxthon/4.  But if AppleWebkit is specified with or without the parenthetical element "like Gecko", the vidoes do not play.

 

I confirmed this by trying to play them in Safari and they behaved just as they have in Maxthon in Ultra mode.

 

I currently have set the following as UA and it parses as shown by the website whatsmyua.com:

{

"ua": "Mozilla/5.0 (Windows NT 6.1, rv:38.0) Gecko/20100101 Maxthon/4.4.5",

"browser": {

"name": "Maxthon",

"version": "4.4.5",

"major": "4"

},

"engine": {

"name": "Gecko",

"version": "38.0"

},

"os": {

"name": "Windows",

"version": "7"

},

"device": {},

"cpu": {}

}

 

With this UA CBS.com plays the videos. I dont know if falsifying the engine will cause problems; it seems possible if a website tries to use something Gecho has which Blink does not.

 

The Blink engine being used (lidentrified by AppleWebkit/*** in the UAs) has a problem on this particular website which happens to be the one I watch the most.

 

Another thought hit me as I recall mention that Firefox was following the Chrome path.  Does following that path mean Firefox is giving up on the Gecko engine and switching to their own version of Blink from Chromium?  Or is it just that they are doing "Chrome style" appearance?

 

Thanks ...

 

                      <<SL>>

Edited by SnowLeopard
1 person likes this

Share this post


Link to post
Share on other sites

UA's updated to latest version of Maxthon. New versions of Chrome and Opera.

1 person likes this

Share this post


Link to post
Share on other sites

Where are the latest UA's string?

top of this topic, first page

1 person likes this

Share this post


Link to post
Share on other sites

UA's updated today. New versions of Maxthon and Chrome.

2 people like this

Share this post


Link to post
Share on other sites

UA's updated again for stable and new Beta versions. New version of Chrome. 

Share this post


Link to post
Share on other sites

UA's updated again for stable and new Beta versions. New version of Chrome. 

Share this post


Link to post
Share on other sites

Thanks for the updates...however,Gmail gave the same stupid notification over and over again.Please fix this browser by removing the stupid notification from Gmail perminately.

Share this post


Link to post
Share on other sites

UA's updated. New Chrome and Opera.

Windows 10 is no longer in preview....

Share this post


Link to post
Share on other sites

see below for updated user agent string

I think as it is additionally connected to the Maxthon adaptation. magg and me are utilizing 4.4.1.500, and we have the issue. In the event that I utilize a more established variant, no issue.

Share this post


Link to post
Share on other sites

It was wonderful...thank you...but,I just wanted Maxthon to go back into its old self instead of acting like Google Chrome...

1 person likes this

Share this post


Link to post
Share on other sites

I have windows 7 

What is the best string for my pc ? 

Thanks you !

 

Share this post


Link to post
Share on other sites

UA's updated. New stable version of Maxthon, Chrome and Opera.

1 person likes this

Share this post


Link to post
Share on other sites