7twenty

Vice Admin
  • Content count

    4,653
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Everything posted by 7twenty

  1. Night Mode (MX4 style)

    just an update with this. Working on adding a settings page to adjust the colours. Code's a bit of a mess but does the job. But that's what happens when you learn as you go. Will hopefully have the updated version up within the next few days. Still haven't got around to seeing if it can be enabled on all pages. Might be next on the to do list.
  2. Probably not going to get a reply... but will give it a go and see what happens. I'm having trouble getting the "activate" parameter of the newtab function to work when the string is called from a variable. In: mxTabs.newTab({url:"url", activate:true, position:"afterCurrrent"}); when activate is set to true or false directly in that line it works fine. If I have a variable "openTab" set to true or false and called in that same line "activate:openTab" it also works. But if I have a variable "openTab" with a value set to true or false which is determined from some javascript, and then saved and called via the mx.storage api, it never seems to work and always defaults to "true". Doing an alert (openTab) or rt.storage.getConfig("openTab") shows that the string is correct. Getting quite annoying, as I know what I want to do and i'm pretty sure i've got it all right, but this just won't work.
  3. Official translator on Crowdin

    Ummm, you already are:
  4. Update? Also, on the Passkeeper lock screen there is a space after "welcome". This is due to a non-standard character being used as noted above. There is no translation string found for this on Crowdin. Fix it and add it to Crowdin.
  5. Export passwords

    Seems that might not even be possible. Chrome and Opera at least only show Firefox and IE when trying to import data.
  6. Export passwords

    I don't think Maxthon supports exporting passwords. If you're moving to another browser hopefully it can import them directly.
  7. Can't download tutorials

    This is what Google has for developers: https://developer.chrome.com/extensions This is what Microsoft has for developers: https://docs.microsoft.com/en-us/microsoft-edge/extensions/api-support/supported-apis This is what Mozilla has for developers: https://developer.mozilla.org/en-US/Add-ons This is what Opera has for developers: https://dev.opera.com/extensions/ All the information related to extensions (and other stuff) is on their developer pages. Maxthon on the other hand, requires you to go to the extension/skins sites (not an issue), but then the links Maxthon Extension SDK / Beginner Tutorials / Submission and Update Process / Approval Criteria, all lead you to the MX forum... then you have to download a compressed version of a MS word file to access the info. We're in 2017, and this is a web browser company yet still making people do things in such a convoluted way like we're still in the 90's. No one is asking that it's as complex or in depth as the sites above. Just bring the info to the web where it should be. All the info in the forum posts mentioned above should be on this "MX developer site", and any competent coder should be able to convert those .doc files into a website relatively easily. That plus direct download links to the examples and the MXpacker. This is just one example of the "many are issues that could be updated fairly easily" but not done, mentioned by MaxthonGuy. This would take someone less than a few days to come up a perfectly workable site, and would rarely be needed to be updated (given how often that info has been in the past). And even when it does it's just a matter of updating those sections that's required, the same way the .doc file would have been updated anyway.
  8. Can't download tutorials

    Preaching to the choir there buddy! I've been forever harping on about exactly that... small things that can be fixed quickly and may never have to be touched till the next major update, yet they still don't change, update after update after update.
  9. Can't download tutorials

    I've asked that question countless times... never got an answer, It's just the way it is... Maybe one day they'll actually make a proper developer site for things like this, like all the browsers have. Their web design team put together the MX5 launch pages and revamped maxthon.com, but can't quickly knock up a small mini-site (1 or 2 pages) for SDK instructions and relevant downloads (or update the skins/extensions sites)!?
  10. Search Engine

    Does it happen on every search? Have you tried changing to another then going back to Bing? Does the same happen when you use the address bar to search? (enter your search term into the address bar, enter)
  11. Sooo do any MX5 skins exist?

    Why can't it be that simple? Many versions don't change anything, or just minor things like a text placeholder etc. Others completely change the code for UI elements. Just looking back at my current 4.9 skin to the 5.x skins, while things look similar on the outside, there's been quite a few changes of code behind the scenes. And in whichever version they change the names of the files, hopefully related to the talk of a proper skin system being put back in place. So it's hard to say what exactly needs to be changed, as it's not a case of changing a line that says "version=5.0.1" to "version=5.0.2" to make it compatible. It really does depend on what was changed. It might be just a text string placeholder, where you'll get the placeholder instead of the actual text. It might be a link to something outside of the HTML files which was moved/changed, in which case just renaming the files won't work, and you need to rewrite/update the code to allow for that.
  12. Upgrade skin to support MX 5.0.2

    You can try renaming the files. 0.dat > UIMain.dat 1.dat > UIHuge.dat No guarantee that it will work 100% or at all.
  13. Problems with facebook

    Looks like some infection, as Facebook or Maxthon shouldn't be doing that. Does the same happen on other browsers? Re-scan your system with kaspersky. Update Maxthon to the latest version http://forum.maxthon.com/index.php?/release-notes4.9/
  14. BlockADBlock

    Which page?
  15. This is a basic troubleshooting guide for users to try and find the cause of issues. Following the guide should allow you to hopefully fix the issue, or at least figure out the source that is causing it so that when posting on the forum users have more information available to offer help. 1 /Are you running the latest version of Maxthon? Check the forum for any new releases and update/reinstall. Most issues will generally be resolved in new builds, or just by the reinstall process. Also ensure you have the latest version of Flash and any other plugins you might be using. If an update/reinstall doesn't work, try doing a clean install which removes all userdata during the uninstall process. Your userdata will be restored if you are using a Maxthon Passport. If you're using a local/guest account, make sure you have a backup of your Maxthon userdata folder (Open an explorer window and type %appdata%\Maxthon5\Users\guest into the address bar). Keep a copy this folder, then copy it back once you have reinstalled. 2 /Do a forum search. Chances are someone has had the issue before you and a fix has been found. If you find a solution that works, reply in the thread so others know that it has worked for other users as well. 3 /Try changing to Retro Mode. A great feature of Maxthon that allows you to view a site using the Internet Explorer renderer in case the site has issues with Blink. Main Menu > Tools > Switch Browser Core, or press the lightning button on the right of the address bar so it changes to a blue e icon. 4 /Connection error? (Eg. unable to resolve domain name or can't connect error) try with another browser to see if it also has the same issue. Use a site like http://isup.me to check that the site is in fact online. Also check there isn't a problem with your DNS servers. You can try testing with Google (8.8.8.8) or OpenDNS (208.67.222.220) servers. And always provide a link to the site/page in question when posting so others can check to see if the problem is more widespread. 5 /Try disabling AdBlock Plus. Sometimes overly aggressive blocking can cause issues on a site. If this fixes the problem some of your rules may need to be revised. Post on the forum and someone should be able to offer a solution. 6 /Try deleting/clearing cookies. There might be a corrupt or invalid cookie causing the problem. Deleting them will ensure new ones are created. Option 1: (Ctrl-Shift-Del) or from the Main Menu > Clear Browsing Data menu option, or toolbar. [Images here] Option 2: To delete cookies for only one site you can use the Developer Tools. [Images here] Option 3: You can also use the following 3rd party programs: -CookieSpy#1 which can show Maxthon cookies, and DB Browser for SQLite which offer more advanced means of working with cookies. [More details here]NOTE: Only option 1 is recommended. Options 2 & 3 are only for advanced users. 7 /Try disabling all extensions. If disabling extensions fixes the problem then one of your extensions is causing the problem. Enable them one by one testing after each until you find the one causing the problem. 8 /Check the advanced options. Ensure you are using the default User Agent (should be unchecked), check with GPU acceleration on/off, and ensure that "Allow all sites to run plug-ins is enabled" if trying to troubleshoot a plugin related problem. These can be found by going to Main Menu > Settings > Advanced. If the above steps don't resolve the issue, follow the next steps which should help determine if the problem is with Maxthon, your account settings or system related and hopefully lead to the cause of the problem. 9 /Sign out of your Maxthon Passport. Check to see if the same problem still occurs. If not signing in fixes the problem, then it's more than likely a settings related issue. Disable all sync options from the menu then enable them one by one, testing for the problem until it occurs again. Once you know which settings are causing the issue make a post on the forum with the details for further assistance. 10 /Test with Maxthon Portable. Download & extract to any folder, run, check for the issue. DO NOT SIGN IN to your Maxthon Passport account. If this works then it's more than likely related to your install. Doing a clean install should fix the problem. If going through the above doesn't fix the problem, then start a thread on the forum to see if someone can help out. Offer as much information as you can, especially the following: - Any error messages; - What version of Maxthon and operating system you are running; - Any out of the ordinary programs (network related like firewalls, downloaders like Orbit, mouse or other hardware related utilities); - What you have tried to fix/find out what the issue was. Otherwise people will offer solutions that you may have already done; - And if applicable link some screenshots or video if it will make things easier for others to understand the problem. The best case scenario is you will find and fix the issue without having to wait hours or days for a response on the forum. At minimum you will narrow in on the issue allowing others to offer a quicker and more appropriate response for the problem. And you may learn something as well :-) Happy troubleshooting! Note #1 - CookieSpy is no longer developed or supported by the creator. The files are provided for your use, but no responsibility is taken for any loss of data or issues caused by it's use.
  16. Disable address bar Auto-Suggestions Maxthon doesn't offer an option to disable address bar auto-suggestions. To manually disable this feature follow the instructions below. Open Notepad with administrator privileges, add the following line to your HOSTS file and save. 127.0.0.1 api.bing.com The HOSTS file can be found %SystemRoot%\system32\drivers\etc See note #1 Navigate to the \public\SmartUrl folder in your Maxthon install folder (or in appdata\roaming\Maxthon5 for installer version) Rename (or delete) the original update.db file (see image below). Create a new empty text file named update.db and mark it read-only. See note #2 Restart Maxthon and the auto-suggestions won't show up. Before auto-suggest fix After auto-suggest fix note 1: This change won't affect anything else except any other programs that use that address for the same suggestions. All it does is tell the browser the IP address for that URL is the localhost address instead of the correct one, so nothing leaves your computer. note 2: The only caveat is that when typing in the address bar it seems the matched URLs are a little slower than normal. Not 100% on that, but that's what it feels like. And of course i'm unaware of anything else it might break.
  17. Clearing cookies using Developer Tools FOR MX5 (5.1.x and later) - Open the Developer Tools (F12)- Go to the Application tab, click the Clear storage item. - Ensure at least the Cookies option is selected in the right pane. - Click the Clear site data button. - You can also right-click on the site address under Storage > Cookies and select Clear. FOR MX4.9 (and early MX5 versions) - Open the Developer Tools (F12)- Go to the Resources tab, then the cookies section. - Right-click on the address you would like to clear cookies from and select Clear. - You can also select individual cookies if required in the right pane.
  18. CrashesTo help the Maxthon developers find the cause of crashes, you can send crash reports found in the %temp%\MaxthonCrashData folder. Open a Windows Explorer window and type the path into the address bar. Zip the folders and send the file in an email to: help@maxthon.comYou can also make a post on the forum.Plug-in IssuesFirst test with Retro mode.Ensure the "Allow all sites to run plugins" option is checked in the Advanced Settings page.Use Retro mode as an alternative until it's fixed in UltraAdobe FlashFor information on getting the most recent version of Adobe Flash working with Maxthon, please see this thread.
  19. Maxthon comes with a version of Adobe Flash to ensure the browser is able to play all Flash content upon installation, although this version isn't always the most recent. This is to ensure that any issues related to new releases of Flash don't cause issues with Maxthon. You can force Maxthon to use the most current version of Flash by following the instructions below. The most recent version of Adobe Flash is available from here: http://get.adobe.com/flash The "Allow all sites to run plug-ins" option must be enabled in Settings > Advanced. The MX Flash Updater is recommended to check and update your system and Maxthon Flash version. The auto-updater tool created by Truuuc also automates the Flash install procedures below, along with some extra options for languages and other plugins. NOTE: the update programs or the instructions below will NOT work for Windows XP/Server 2000/2003. If you have any issues with the above, please follow the descriptions linked below. For Maxthon 4.9.x and later follow the instructions in this post. For Maxthon 4.4.x and earlier follow the instructions in this post.
  20. Return the normal font! (MX4.9)

    Did you check ClearType and the DirectWrite option on/off?
  21. Return the normal font! (MX4.9)

    Have you setup ClearType in windows? Search for "ClearType" in windows and follow the instructions. Could be that MX4.4 was using a different text rendering method that didn't used ClearType. If MX4.9 changed that, if your ClearType settings aren't set up correctly you'll get weird text like that. Looks like a case of the text not being aliased properly, which is something that ClearType does. Although not sure how the new DirectWrite option changes that. I've had no issues with it, looks the same as it always has.
  22. I think it's irrelevant what fonts it works with or not, especially as Maxthon doesn't have any advanced font management options. Default, which is what most users will be using, is what it should be made to display with correctly. And all that is required is the use of the standard apostrophe, instead of the weird non-standard variation that is in use at the moment. ’ This is what is being used - Alt+0146 on the keypad to type it. ' This is what should be used - apostrophe key on keyboard. As to why it's happening, i don't know, but the fix is simple.