7twenty

Vice Admin
  • Content count

    4,601
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Everything posted by 7twenty

  1. about:blank ?

    Yep, when in Retro you get an about:blank page instead of the link you expect to open. Doesn't happen when testing with Bing, so something is going on there. Regardless, Retro should only be used if a site has issues with using Ultra. The google banner thing will always crop up due to the way MX updates the blink core. Best to ignore it or my preference, hide it using adblock.
  2. Yes we do all have opinions, but you'll notice mine came with reasons supporting my actions and arguments against yours. Falling back on the "leave your comment" phrase, which can be read literally or within the context of the forum as noted above, while does support your argument, i gave counter-arguments as to why I thought it wasn't good idea to allow comments in that forum/thread. Looking at it from another view; would you prefer the main support section have only threads for each version of MX? That way if a user has a problem with 5.2.5, then they post the issue in that thread only, which may also have 10 other problems mentioned? If this was a reddit style forum, where each post can have it's own thread within the main thread, then that could work. How things are setup here i don't think it's viable. reasons?? "A strawberry tastes nice" is an opinion. "A strawberry tastes nice because it's sweet" is an opinion with a reason to support it.. See the difference?
  3. Had you quoted (and read) the full paragraph, you would have your answer. I've bolded it for you in case you missed it. . If you want to read it literally, sure. But if you read between the lines and note that this is a support forum with different sections for different things, you'll notice there's a specific forum that deals with support issues. The thread was posted in an Announcement section. Otherwise we may as well just have one section and people can post whatever they want mixed in with everything else. And we've been through this before, it used to be noted in the posts that issues should be created in the support section. Due to the revolving door that is the bugsir* account, it's been dropped at some stage. It also says "Happy Browser", based on that maybe we should be reading between the lines. Highly dependent on how you browse the forum. I use the unread activity stream feature, anything unread is shown, doesn't matter where it is. If you manually look through for unread posts, then you may miss it, especially if you don't look in the announcement forum. That was one that I never frequented. That's the way it was setup by one of the previous bug*s. An oversight possibly, or maybe they were thinking that people would take note of the "post issues in the support forum" line when it was there. The only user levels able to post there were MX master and moderators. Will revise it, or change the forum to read only. But when it comes to tracking issues, a separate thread for each issue is the best way to do it. This way you can see when it happened, what was done to try and fix it, update the thread if new versions fix or still have the issue. And it's easier follow a problem as you're not reading through other posts about someones QA issue, or login problems, or extension problem, or broken youtube, or <insert whatever website> that doesn't load. Long post, but hey, you asked for an explanation. And yes, i moved these posts as well!
  4. Flash should have no bearing on video playback (depending on the site), but especially Youtube. As above, i believe they went to HTML5 back in 2015/16. I doubt the issues are Flash/memory leak related; given that there's no issue using Chromium it's odd that it won't work in MX, although could be related to the older core. Also I think Chrome/ium auto update Flash, or at least used to, which means it may have been running on a more recent version than your v10.0.9 possibly affecting playback. Not sure how i got onto this, because as above it shouldn't affect anything due to HTML5. That said, MX does/did(?) lack some hardware acceleration options which may be a problem depending on the specs of the device in use. Given the 2gb RAM, chances are the CPU/GPU combo isn't great either, add on software video decode, it probably isn't a great platform for smooth video playback depending on what else is going on. You may be mixing up HTML5 & h264. H264 is a compressed video format, one that Flash supports and can happily play. Flash is to some degree a container format that can contain video/audio/animation/3D content and allows user interactivity, which is what HTML5 also does.
  5. about:blank ?

    Two things: 1 / why are you using Retro mode for Google? Does the same issue occur when using Ultra? 2 / can you post a screenshot of your Search Engine Management settings?
  6. Posts have been merged into here. No one should be posting in there anyway. It's an announcement forum so regular users don't have access to those forums. That's pretty much it. Probably added as another means to get users to the extension site for those that don't have the sidebar open?! Unfortunately, the translation isn't available (and isn't in Crowdin) for en-GB, and probably many more.
  7. I've been forever complaining about some of the UI issues in MX. While things have improved since MX4, there are still some things out of place, or just plain not updated because of whatever reason. So in the same spirit of the Typo's, grammar issues etc... lets make a list! thread... here we go with MX UI issues...lets make a list!! Although somehow I don't think it will get the same response as the other thread... of which also has been somewhat slow to fix issues of late... So off we go... Lock button has text lower than the Security button A message about Chrome?? Not sure how this came up, nor have I seen it more than twice, but still i'll add it in Reader mode: The search bars are different in Maxnote and Passkeeper. In Maxnote - Colours are lighter, smaller text, different magnifying glass icon Choose one style and make them the same. Different heading style compared to downloader/ABP/clear browsing data/sniffer dialogs etc. FIXED - In QA setttings, "background" is cut off even though there is plenty of room for the (?) to be moved to the right: More to come... Once they've been looked at it would be nice if the UI could get a slight make over. Currently it's very static, buttons are either on/off, there's no movement. Add some animation (eg. fade in/out) when moving over tabs/buttons. Opening/closing tabs is very, very jerky compared to almost every other browser. The latest Firefox looks amazing, animation on hovering over the tabs, a colour flourish when a tab is loaded, animated refresh button, fades on menus. Even just the fade on the text in the tab bar when the titles are too long - it looks better than the ellipsis (...) that Maxthon uses. All very small things, but they complete the experience and makes the whole browser look very polished and complete. The new Maxnote style is nice. The animated drop shadows when hovering over items is a nice touch. Hopefully that starts making it's way into the rest of the browser over time.
  8. a little more clarification as to the actual issue would be handy. Stuttering? no video? no sound? wrong frame rate? wrong aspect ratio? wrong colours? Dropped frames? What resolution are you using? is it a 60fps video? Can you provide a link to a video that exhibits the issue?
  9. Switch core function

    Once you switch core it will be remembered for each subsequent visit. But there is no way to set the useragent per site, IE10/11 etc. It's Blink or IE(latest version on your system), using the Switch Core option only.
  10. True, in the same way that a moved menu item is a browser breaking bug. In summary, 1. a workaround for the sub-menu issue has been given 2. it's simple to ignore all the extra "crap" 3. video playback isn't an issue as far as i'm aware, otherwise there would be a lot more complaints 4. use portable and you'll never see a nag to update. Where's the problem? http://dl.maxthon.com/mx4/maxthon_portable_4.9.5.1000.7z http://dl.maxthon.com/mx4/maxthon_portable_4.4.8.2000.7z
  11. As per the title. Was working fine, but i decided to close the browser... after that i now get a dark grey screen a after a quick flash of the page. After logging out/in the main page displays properly and you can play whatever is already in the playlist, BUT if you go to any album/playlist etc you just get the dark background displayed. You can't get to anything after that. F5/CTRL+F5 doesn't do anything, only logging out/in shows the main page, but goes back to black after that. Tested with MX5.2.5.1000 portable - my everyday browser and a fresh test portable. Works fine in Opera 53 (Chrome 66 in UA string) Logged in/out of spotify multiple times - still happens Tested with ABP on/off - still happens Changed UA to latest Chrome version - still happens Retro mode - still happens As usual it seems Spotify has made some changes/updates and older versions of blink seem to be a problem...
  12. Spotify Broken... again

    Scratch that.... Seems to have resolved itself. Possibly bad timing on my side when they did some test updates??!
  13. What main page? Do you use a passport account? How did you update to the latest version?
  14. favorites drag and drop

    No problem here. I don't see the little extra note "+Add to ...", but the record does move to the desired folder. Does it work again if you refresh the page?
  15. After it was pointed out in another thread that Maxthon no longer has the option to Block third party cookies I thought i'd ask the question, why? I don't think there's another browser out there that doesn't have that option. And MX4 had it available. What's the story?
  16. I could be wrong here, but i believe much of these fixes are to the Blink core, which Maxthon tweaks, but doesn't get into the security side as much. Most Chrome clones seem to be essentially skins with some mods, so when there's a Blink update they can just update the core and release a new version with the updated core with the security fixes. For some reason Maxthon seems to use a different system, so the core updates are longer between each (most of the time there's 7-10 Blink updates between each MX blink core update), for that reason any security fixes don't show up in Maxthon for some time.
  17. Not for third party cookies only. Disabling the current setting means all cookies are disabled on all sites. This means options like stay logged in, site modifications (colour schemes or layout), location details etc. are lost when closing the page.
  18. You make some good points. MX does have it's issues, i've mentioined it countless times and posted threads about them - to me in some respects it comes across as amateurish, if only due to the constant issues with translations. But adding things like exploits that take longer to fix due to the delayed core updates, non-existent flash update options, syncing options that seem to cause more grief than positives, it doesn't come across great. But there's plenty of users that don't want or need or use these features and Maxthon works well for them. I tested the crypto thing, and Defender quarantined the suspect file and I got a protected smiley face for my system. While that shouldn't be a pass for Maxthon, most people shouldn't be affected by this if they have even a basic level of AV protection installed. Especially since around Win7/8, Defender or some equivalent has been available. No doubt about it, but it's been like that for a long, long time...Going back to MX3 to varying degrees if you ask me. But looking back to the OPs issues, I fail to see how any of that is related. 1 & 2 are personal preferences in what/how they want to use the browser, 3 is an issue related to an (early?) MX5 version with no information to verify it was an actual MX5 issue. 4, well enough has been said about that...
  19. Well aren't you a pleasant fellow. That is the sort of attitude that won't get you anywhere. I, along with the others in this thread are trying to help with an issue that so far, no one else has been able to duplicate. Yet apparently it's too hard to do a simple test (with instructions) that will take no more than 2mins to check if the problem still occurs, so others might be able to help you. I'm not sure what exactly caused the sudden change in attitude (see below); my post may have been somewhat terse, but your reply was uncalled for. Have fun --- From V V V to WOW!!
  20. Yes Everyone is entitled to their opinion, it doesn't mean it's right. There's things i don't like about the browser as well... just look at the stickies on the front page of the forum. But i deal with it because, for me it's still the best browser that does what i want. So how can you say that 4.4.8.1000 is the best, when it took countless iterations to get to that point? It may be the first version that you used and liked, but many users were in the same position in each and every release till then dealing with things that may have changed/moved/were updated to get to the "perfect browser". MX5.5.2.3000 could very well be the next "perfect" version, but that will never happen unless the constant updates and changes occur. The devs? Jeff, the owner/original creator? i'm not sure. Print dialog was either a designer choice, OR they had data showing that many people don't use it regularly, so they moved it to a sub-menu to clean up the main menu. It's not, but i don't understand the lack of desire to use the context menu option.. .as stated, it's always there, top level AND easier to access. I can't think of one reason why you wouldn't use this... outside of muscle memory and being used to the old way. And frankly, that's not a good reason. That's quite a subjective comment. Browsers have come a long way since MyIE, there's only so much you can add to the browser that's useful anymore. As for being fun? it's a browser, not a game, be it v1 or 5 i don't think it was ever "fun", it just did it's job. Reliability seems to be different for everyone; some people post here every other day with issues, others like me rarely have an issue. True, but that's something that Maxthon has always done. Remove/change options for some unknown reason then add them back at some stage. Now that you mention the TP cookie thing, i'm also a little annoyed. If there's things to complain about with Maxthon, i think it's biggest failure is not giving enough user control to various options such as cookies (ability to delete by date/site), thirdparty cookies, granular control of plugins/cookies per site (it's always enable or disable everywhere), lack of disabling media auto play on sites, access to advanced options (like chrome://flags). The "issues" the OP mentions are all without merit and basically come down to not wanting to deal with change because they're comfortable with what they have.
  21. Find the databases folder in %appdata%\maxthon5\users\[your_account_name or guest]\ and delete/rename it. Something in there is causing the crash. I'm not sure exactly what the folder is for, but some various website data. Using the clean website-related data option from the clear browsing data doesn't seem to fix the problem.
  22. This is an interesting one. Tested on a clean portable and the site works fine. But when tested on my main version, MX crashed. So there's something going on that is causing it to happen.
  23. Not what was asked. Sign out of your account, use the skip login option as shown below. Go to youtube and see if the same problem happens. DO NOT install or do anything else.
  24. Access it from the context menu. Single level and less mouse travel. Yep that's the way to do it for a standalone system. Unless you want features like syncing on other devices etc...then you sort of have to use the account option. speak for yourself, no major problems here. MX has it's issues, but i've seen no consistent video problems except when pages download in the background where there's some stuttering for a fraction of a second. So you're ok with a V1 product, but not subsequent updates? That makes no sense whatsoever. Why do you trust the V1 product? Who's to say that version doesn't have all the nefarious additions you mention? In fact seeing as "If it works the first time then it works", why did you update past MyiE let alone all the way up to the final version in the 4.4.x series of Maxthon? or even Windows V1? While there's the possibility of issues being introduced with later versions thanks to refactoring or new features, bug/security fixes, most of the time they are beneficial. Eg, updates to the browser core or security fixes for exploits which seem to be announced all the time these days. The fact is people like what they're used to and don't like change, which is fine. But don't assume that just because you think that particular version is the pinnacle of Maxthon development, that it actually is. A print option an extra level deep which you aren't forced to use, an account option which you aren't forced to use, alleged playback issues which may or may not be system related and accusations of additions of nefarious code are poor excuses to justify your desire to not update. If you're happy living in the past and 4.4.8.1000 works for you with the sites you visit, then i don't see the point of this thread. If on the other hand it's causing issues due to being so old, then you may have to forgo some of your concerns and move to something newer. Which based on my replies none are valid, except for maybe #4 depending on your level of trust in the code since the apparent gold standard of web browser development that was Maxthon 4.4.8.1000. It's going to be posted, but i think you won't like the responses. Although i'm not sure what the threat about posting elsewhere with 55m people/month is about.
  25. Maxthon 5.2.5 and mouse gestures

    No issue here. Only way i can get it to do what you described is to use the left mouse button, which is how it's supposed to work. I'd suggest it's a mouse/system issue rather than maxthon.